summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2017-12-29 10:13:33 +0100
committerVladimír Čunát <vcunat@gmail.com>2017-12-29 10:13:33 +0100
commitf29000b0023a879b42be2a8bd59136ec0c533b88 (patch)
tree4b0b2851c7dec0588d236f6d3946b8018a74afb9 /pkgs/tools
parent291eac9d70e5f4b8cbbc7632afcac5ea79eb62ba (diff)
parent76c146c99073ad27046a0a28bb3d2881486e32bb (diff)
downloadnixlib-f29000b0023a879b42be2a8bd59136ec0c533b88.tar
nixlib-f29000b0023a879b42be2a8bd59136ec0c533b88.tar.gz
nixlib-f29000b0023a879b42be2a8bd59136ec0c533b88.tar.bz2
nixlib-f29000b0023a879b42be2a8bd59136ec0c533b88.tar.lz
nixlib-f29000b0023a879b42be2a8bd59136ec0c533b88.tar.xz
nixlib-f29000b0023a879b42be2a8bd59136ec0c533b88.tar.zst
nixlib-f29000b0023a879b42be2a8bd59136ec0c533b88.zip
Merge branch 'master' into staging
Hydra: ?compare=1421760
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/inputmethods/uim/default.nix14
-rw-r--r--pkgs/tools/misc/yle-dl/default.nix8
-rw-r--r--pkgs/tools/networking/uwimap/default.nix4
-rw-r--r--pkgs/tools/security/chkrootkit/default.nix9
-rw-r--r--pkgs/tools/security/nitrokey-app/default.nix10
-rw-r--r--pkgs/tools/system/netdata/default.nix4
6 files changed, 23 insertions, 26 deletions
diff --git a/pkgs/tools/inputmethods/uim/default.nix b/pkgs/tools/inputmethods/uim/default.nix
index bba55acc0608..96b887141785 100644
--- a/pkgs/tools/inputmethods/uim/default.nix
+++ b/pkgs/tools/inputmethods/uim/default.nix
@@ -6,10 +6,7 @@
 , withGtk3 ? withGtk, gtk3 ? null
 , withQt ? true
 , withQt4 ? withQt, qt4 ? null
-, withKde ? withQt
-, withKde4 ? withKde && withQt4, kdelibs4 ? null, automoc4 ? null
-, withKNotify4 ? false
-, withLibnotify ? !withKNotify4, libnotify ? null
+, withLibnotify ? true, libnotify ? null
 , withSqlite ? true, sqlite ? null
 , withNetworking ? true, curl ? null, openssl ? null
 , withFFI ? true, libffi ? null
@@ -24,9 +21,7 @@ assert withAnthy -> anthy != null;
 assert withGtk2 -> gtk2 != null;
 assert withGtk3 -> gtk3 != null;
 assert withQt4 -> qt4 != null;
-assert withKde4 -> withQt4 && kdelibs4 != null && automoc4 != null;
-assert withKNotify4 -> withKde4 && !withLibnotify;
-assert withLibnotify -> !withKNotify4 && libnotify != null;
+assert withLibnotify -> libnotify != null;
 assert withSqlite -> sqlite != null;
 assert withNetworking -> curl != null && openssl != null;
 assert withFFI -> libffi != null;
@@ -49,9 +44,6 @@ stdenv.mkDerivation rec {
   ++ optional withGtk2 gtk2
   ++ optional withGtk3 gtk3
   ++ optional withQt4 qt4
-  ++ optionals withKde4 [
-    kdelibs4 automoc4
-  ]
   ++ optional withLibnotify libnotify
   ++ optional withSqlite sqlite
   ++ optionals withNetworking [
@@ -76,8 +68,6 @@ stdenv.mkDerivation rec {
     "--with-qt4"
     "--with-qt4-immodule"
   ]
-  ++ optional withKde4 "--enable-kde4-applet"
-  ++ optional withKNotify4 "--enable-notify=knotify4"
   ++ optional withLibnotify "--enable-notify=libnotify"
   ++ optional withSqlite "--with-sqlite3"
   ++ optionals withNetworking [
diff --git a/pkgs/tools/misc/yle-dl/default.nix b/pkgs/tools/misc/yle-dl/default.nix
index 34ac4cb7366f..2967892521ca 100644
--- a/pkgs/tools/misc/yle-dl/default.nix
+++ b/pkgs/tools/misc/yle-dl/default.nix
@@ -1,17 +1,17 @@
-{ stdenv, fetchFromGitHub, rtmpdump, php, pythonPackages }:
+{ stdenv, fetchFromGitHub, rtmpdump, php, pythonPackages, ffmpeg }:
 
 pythonPackages.buildPythonApplication rec {
   name = "yle-dl-${version}";
-  version = "2.28";
+  version = "2.30";
 
   src = fetchFromGitHub {
     owner = "aajanki";
     repo = "yle-dl";
     rev = version;
-    sha256 = "1nb3gmkizgkd09slihc2iaf3rh1s7bdhy9zydkfghmqi7nv4mmq0";
+    sha256 = "08qqsg0rmp4xfzmla81f0a4vblqfw3rh90wvxm91vbm6937b4i7i";
   };
 
-  propagatedBuildInputs = with pythonPackages; [ lxml pyamf pycrypto requests ];
+  propagatedBuildInputs = with pythonPackages; [ lxml pyamf pycrypto requests future ffmpeg ];
   pythonPath = [ rtmpdump php ];
 
   doCheck = false; # tests require network access
diff --git a/pkgs/tools/networking/uwimap/default.nix b/pkgs/tools/networking/uwimap/default.nix
index c2c707fbc77a..7cb489a3f213 100644
--- a/pkgs/tools/networking/uwimap/default.nix
+++ b/pkgs/tools/networking/uwimap/default.nix
@@ -29,8 +29,8 @@ stdenv.mkDerivation {
     "-I${openssl.dev}/include/openssl";
 
   installPhase = ''
-    mkdir -p $out/bin $out/lib $out/include
-    cp c-client/*.h c-client/linkage.c $out/include
+    mkdir -p $out/bin $out/lib $out/include/c-client
+    cp c-client/*.h osdep/unix/*.h c-client/linkage.c c-client/auths.c $out/include/c-client/
     cp c-client/c-client.a $out/lib/libc-client.a
     cp mailutil/mailutil imapd/imapd dmail/dmail mlock/mlock mtest/mtest tmail/tmail \
       tools/{an,ua} $out/bin
diff --git a/pkgs/tools/security/chkrootkit/default.nix b/pkgs/tools/security/chkrootkit/default.nix
index 54aeb32cabd6..0cc026f0c877 100644
--- a/pkgs/tools/security/chkrootkit/default.nix
+++ b/pkgs/tools/security/chkrootkit/default.nix
@@ -1,16 +1,21 @@
 { stdenv, fetchurl }:
 
 stdenv.mkDerivation rec {
-  name = "chkrootkit-0.51";
+  name = "chkrootkit-0.52";
 
   src = fetchurl {
     url = "ftp://ftp.pangeia.com.br/pub/seg/pac/${name}.tar.gz";
-    sha256 = "0y0kbhy8156y8zli0wcqbakb9rprzl1w7jn0kw3xjfgzrgsncqgn";
+    sha256 = "04d2yxpy99y90rvrlc9fqmlffs6iyfbghxbhvv12j1xfr2ww0y65";
   };
 
   # TODO: a lazy work-around for linux build failure ...
   makeFlags = [ "STATIC=" ];
 
+   postPatch = ''
+    substituteInPlace chkrootkit \
+      --replace " ./" " $out/bin/"
+   '';
+
   installPhase = ''
     mkdir -p $out/sbin
     cp check_wtmpx chkdirs chklastlog chkproc chkrootkit chkutmp chkwtmp ifpromisc strings-static $out/sbin
diff --git a/pkgs/tools/security/nitrokey-app/default.nix b/pkgs/tools/security/nitrokey-app/default.nix
index 1443409c0226..1aced2cd427d 100644
--- a/pkgs/tools/security/nitrokey-app/default.nix
+++ b/pkgs/tools/security/nitrokey-app/default.nix
@@ -1,16 +1,18 @@
-{ stdenv, cmake, fetchgit, hidapi, libusb1, pkgconfig, qt5 }:
+{ stdenv, bash-completion, cmake, fetchgit, hidapi, libusb1, pkgconfig, qt5 }:
 
 stdenv.mkDerivation rec {
   name = "nitrokey-app";
-  version = "1.1";
+  version = "1.2";
 
+  # We use fetchgit instead of fetchFromGitHub because of necessary git submodules
   src = fetchgit {
     url = "https://github.com/Nitrokey/nitrokey-app.git";
     rev = "refs/tags/v${version}";
-    sha256 = "11pz1p5qgghkr5f8s2wg34zqhxk2vq465i73w1h479j88x35rdp0";
+    sha256 = "0mm6vlgxlmpahmmcn4awnfpx5rx5bj8m44cywhgxlmz012x73hzi";
   };
 
   buildInputs = [
+    bash-completion
     hidapi
     libusb1
     qt5.qtbase
@@ -20,7 +22,7 @@ stdenv.mkDerivation rec {
     cmake
     pkgconfig
   ];
-  cmakeFlags = "-DHAVE_LIBAPPINDICATOR=NO";
+  cmakeFlags = "-DCMAKE_BUILD_TYPE=Release";
 
   meta = with stdenv.lib; {
     description      = "Provides extra functionality for the Nitrokey Pro and Storage";
diff --git a/pkgs/tools/system/netdata/default.nix b/pkgs/tools/system/netdata/default.nix
index ed177820b644..7bb98e8e80c4 100644
--- a/pkgs/tools/system/netdata/default.nix
+++ b/pkgs/tools/system/netdata/default.nix
@@ -1,14 +1,14 @@
 { stdenv, fetchFromGitHub, autoreconfHook, zlib, pkgconfig, libuuid }:
 
 stdenv.mkDerivation rec{
-  version = "1.7.0";
+  version = "1.9.0";
   name = "netdata-${version}";
 
   src = fetchFromGitHub {
     rev = "v${version}";
     owner = "firehol";
     repo = "netdata";
-    sha256 = "1fv01jnbgwbafsxavlji90zdqizn8m4nfg9ivc4sbi05j036bg6n";
+    sha256 = "1vy0jz5lxw63b830l9jgf1qqhp41gzapyhdr5k1gwg3zghvlg10w";
   };
 
   nativeBuildInputs = [ autoreconfHook pkgconfig ];