summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorTuomas Tynkkynen <tuomas@tuxera.com>2018-03-15 22:30:56 +0200
committerTuomas Tynkkynen <tuomas@tuxera.com>2018-03-15 22:30:56 +0200
commitef64208eba1a2b9052ce6d96b4539163d1aeda9f (patch)
treec4fc3d5a6b5512b0e11021e18237977440207ae1 /pkgs/tools
parent208abe9ae3f4a3ced8942ebd3419496089e06453 (diff)
parent3ab2949e1fdfb6ef18c2935ab3e72ea1f9348ef5 (diff)
downloadnixlib-ef64208eba1a2b9052ce6d96b4539163d1aeda9f.tar
nixlib-ef64208eba1a2b9052ce6d96b4539163d1aeda9f.tar.gz
nixlib-ef64208eba1a2b9052ce6d96b4539163d1aeda9f.tar.bz2
nixlib-ef64208eba1a2b9052ce6d96b4539163d1aeda9f.tar.lz
nixlib-ef64208eba1a2b9052ce6d96b4539163d1aeda9f.tar.xz
nixlib-ef64208eba1a2b9052ce6d96b4539163d1aeda9f.tar.zst
nixlib-ef64208eba1a2b9052ce6d96b4539163d1aeda9f.zip
Merge commit '3ab2949' from staging into master
Conflicts:
	pkgs/development/compilers/llvm/6/llvm.nix
	pkgs/servers/home-assistant/component-packages.nix
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/admin/awscli/default.nix48
-rw-r--r--pkgs/tools/compression/lzip/default.nix6
-rw-r--r--pkgs/tools/filesystems/btrfs-progs/default.nix4
-rw-r--r--pkgs/tools/filesystems/e2fsprogs/default.nix4
-rw-r--r--pkgs/tools/misc/you-get/default.nix4
-rw-r--r--pkgs/tools/networking/dhcp/default.nix10
-rw-r--r--pkgs/tools/networking/dhcp/flush-if.patch76
-rw-r--r--pkgs/tools/networking/dhcp/set-hostname.patch24
-rw-r--r--pkgs/tools/networking/dhcpcd/default.nix7
-rw-r--r--pkgs/tools/security/gnupg/22.nix4
-rw-r--r--pkgs/tools/security/gnupg/fix-libusb-include-path.patch5
-rw-r--r--pkgs/tools/security/sudo/default.nix3
-rw-r--r--pkgs/tools/text/gawk/default.nix4
-rw-r--r--pkgs/tools/text/groff/default.nix4
-rw-r--r--pkgs/tools/typesetting/docbook2x/default.nix4
-rw-r--r--pkgs/tools/typesetting/tex/texlive/bin.nix12
-rw-r--r--pkgs/tools/typesetting/tex/texlive/default.nix8
17 files changed, 74 insertions, 153 deletions
diff --git a/pkgs/tools/admin/awscli/default.nix b/pkgs/tools/admin/awscli/default.nix
index 4c6a91ec321b..eb735a04abb9 100644
--- a/pkgs/tools/admin/awscli/default.nix
+++ b/pkgs/tools/admin/awscli/default.nix
@@ -1,48 +1,40 @@
-{ stdenv
-, buildPythonPackage
-, fetchPypi
-, botocore
-, bcdoc
-, s3transfer
-, six
-, colorama
-, docutils
-, rsa
-, pyyaml
+{ lib
+, python
 , groff
 , less
 }:
 
 let
-  colorama_3_7 = colorama.overrideAttrs (old: rec {
-    name = "${pname}-${version}";
-    pname = "colorama";
-    version = "0.3.7";
-    src = old.src.override {
-      inherit version;
-      sha256 = "0avqkn6362v7k2kg3afb35g4sfdvixjgy890clip4q174p9whhz0";
+  py = python.override {
+    packageOverrides = self: super: {
+      colorama = super.colorama.overridePythonAttrs (oldAttrs: rec {
+        version = "0.3.7";
+        src = oldAttrs.src.override {
+          inherit version;
+          sha256 = "0avqkn6362v7k2kg3afb35g4sfdvixjgy890clip4q174p9whhz0";
+        };
+      });
     };
-  });
+  };
 
-in buildPythonPackage rec {
+in py.pkgs.buildPythonApplication rec {
   pname = "awscli";
-  version = "1.14.41";
-  namePrefix = "";
+  version = "1.14.47";
 
-  src = fetchPypi {
+  src = py.pkgs.fetchPypi {
     inherit pname version;
-    sha256 = "8cf2a52d56f26e22e2fbd7b72649ef1d3de8930df7a730d7f27418d129bb3a6a";
+    sha256 = "269483910c820ae5b4f60021375f07e4f1c23f86505e1b9e29243880a660c1d8";
   };
 
   # No tests included
   doCheck = false;
 
-  propagatedBuildInputs = [
+  propagatedBuildInputs = with py.pkgs; [
     botocore
     bcdoc
     s3transfer
     six
-    colorama_3_7
+    colorama
     docutils
     rsa
     pyyaml
@@ -58,10 +50,10 @@ in buildPythonPackage rec {
     rm $out/bin/aws.cmd
   '';
 
-  meta = with stdenv.lib; {
+  meta = with lib; {
     homepage = https://aws.amazon.com/cli/;
     description = "Unified tool to manage your AWS services";
-    license = stdenv.lib.licenses.asl20;
+    license = licenses.asl20;
     maintainers = with maintainers; [ muflax ];
   };
 }
diff --git a/pkgs/tools/compression/lzip/default.nix b/pkgs/tools/compression/lzip/default.nix
index 298e490be873..25d09e6e947b 100644
--- a/pkgs/tools/compression/lzip/default.nix
+++ b/pkgs/tools/compression/lzip/default.nix
@@ -2,16 +2,16 @@
 
 stdenv.mkDerivation rec {
   name = "lzip-${version}";
-  version = "1.19";
+  version = "1.20";
 
   buildInputs = [ texinfo ];
 
   src = fetchurl {
     url = "mirror://savannah/lzip/${name}.tar.gz";
-    sha256 = "1abbch762gv8rjr579q3qyyk6c80plklbv2mw4x0vg71dgsw9bgz";
+    sha256 = "0319q59kb8g324wnj7xzbr7vvlx5bcs13lr34j0zb3kqlyjq2fy9";
   };
 
-  configureFlags = "CPPFLAGS=-DNDEBUG CFLAGS=-O3 CXXFLAGS=-O3";
+  configureFlags = "CPPFLAGS=-DNDEBUG CFLAGS=-O3 CXXFLAGS=-O3" + stdenv.lib.optionalString stdenv.isCross " CXX=${stdenv.cc.targetPrefix}c++";
 
   setupHook = ./lzip-setup-hook.sh;
 
diff --git a/pkgs/tools/filesystems/btrfs-progs/default.nix b/pkgs/tools/filesystems/btrfs-progs/default.nix
index fb24e1394b7b..09f004f28440 100644
--- a/pkgs/tools/filesystems/btrfs-progs/default.nix
+++ b/pkgs/tools/filesystems/btrfs-progs/default.nix
@@ -2,14 +2,14 @@
 , asciidoc, xmlto, docbook_xml_dtd_45, docbook_xsl, libxslt, zstd
 }:
 
-let version = "4.14.1"; in
+let version = "4.15.1"; in
 
 stdenv.mkDerivation rec {
   name = "btrfs-progs-${version}";
 
   src = fetchurl {
     url = "mirror://kernel/linux/kernel/people/kdave/btrfs-progs/btrfs-progs-v${version}.tar.xz";
-    sha256 = "1palnddw3d50kyflwk1j4xapbc6jniid6j5i9dsr8l8a7nkv7ich";
+    sha256 = "15izak6jg6pqr6ha9447cdrdj9k6kfiarvwlrj53cpvrsv02l437";
   };
 
   nativeBuildInputs = [
diff --git a/pkgs/tools/filesystems/e2fsprogs/default.nix b/pkgs/tools/filesystems/e2fsprogs/default.nix
index 6326cda35397..62eab06c387c 100644
--- a/pkgs/tools/filesystems/e2fsprogs/default.nix
+++ b/pkgs/tools/filesystems/e2fsprogs/default.nix
@@ -1,11 +1,11 @@
 { stdenv, buildPackages, fetchurl, pkgconfig, libuuid, gettext, texinfo }:
 
 stdenv.mkDerivation rec {
-  name = "e2fsprogs-1.43.8";
+  name = "e2fsprogs-1.43.9";
 
   src = fetchurl {
     url = "mirror://sourceforge/e2fsprogs/${name}.tar.gz";
-    sha256 = "1pn33rap3lcjm3gx07pmgyhx4j634gja63phmi4g5dq8yj0z8ciz";
+    sha256 = "15rqvkzylqqckshfy7vmk15k7wds2rh3k1pwrkrs684p3g0gzq2v";
   };
 
   outputs = [ "bin" "dev" "out" "man" "info" ];
diff --git a/pkgs/tools/misc/you-get/default.nix b/pkgs/tools/misc/you-get/default.nix
index 5ae99d239391..795c2ab191d1 100644
--- a/pkgs/tools/misc/you-get/default.nix
+++ b/pkgs/tools/misc/you-get/default.nix
@@ -2,7 +2,7 @@
 
 buildPythonApplication rec {
   pname = "you-get";
-  version = "0.4.1025";
+  version = "0.4.1040";
 
   # Tests aren't packaged, but they all hit the real network so
   # probably aren't suitable for a build environment anyway.
@@ -10,7 +10,7 @@ buildPythonApplication rec {
 
   src = fetchPypi {
     inherit pname version;
-    sha256 = "1dbalpwhzn39kgswjy84720wfjssa087adavbwig53krsjdvhj6k";
+    sha256 = "fdc9021e8b1cf936aad4bd6c74b80ea8fa3573b807c41242ba781e247f8c8ca8";
   };
 
   meta = with stdenv.lib; {
diff --git a/pkgs/tools/networking/dhcp/default.nix b/pkgs/tools/networking/dhcp/default.nix
index 1812e95dcbb7..8b1ac864a434 100644
--- a/pkgs/tools/networking/dhcp/default.nix
+++ b/pkgs/tools/networking/dhcp/default.nix
@@ -4,19 +4,15 @@
 
 stdenv.mkDerivation rec {
   name = "dhcp-${version}";
-  version = "4.3.4";
+  version = "4.3.6-P1";
 
   src = fetchurl {
     url = "http://ftp.isc.org/isc/dhcp/${version}/${name}.tar.gz";
-    sha256 = "0zk0imll6bfyp9p4ndn8h6s4ifijnw5bhixswifr5rnk7pp5l4gm";
+    sha256 = "1hx3az6ckvgvybr1ag4k9kqr8zfcpzcww4vpw5gz0mi8y2z7gl9g";
   };
 
   patches =
-    [ # Don't bring down interfaces, because wpa_supplicant doesn't
-      # recover when the wlan interface goes down.  Instead just flush
-      # all addresses, routes and neighbours of the interface.
-      ./flush-if.patch
-
+    [
       # Make sure that the hostname gets set on reboot.  Without this
       # patch, the hostname doesn't get set properly if the old
       # hostname (i.e. before reboot) is equal to the new hostname.
diff --git a/pkgs/tools/networking/dhcp/flush-if.patch b/pkgs/tools/networking/dhcp/flush-if.patch
deleted file mode 100644
index ff72248b0abb..000000000000
--- a/pkgs/tools/networking/dhcp/flush-if.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-diff --exclude '*~' -rc dhcp-4.1.0p1-orig/client/scripts/linux dhcp-4.1.0p1/client/scripts/linux
-*** dhcp-4.1.0p1-orig/client/scripts/linux	2008-05-23 15:56:07.000000000 +0200
---- dhcp-4.1.0p1/client/scripts/linux	2009-09-29 17:56:57.000000000 +0200
-***************
-*** 67,72 ****
---- 67,80 ----
-    exit $exit_status
-  }
-  
-+ # Delete the old addresses, routes and ARP information for this
-+ # interface.
-+ flush_if() {
-+   ${ip} -4 address flush dev $interface
-+   ${ip} -4 route flush dev $interface
-+   ${ip} -4 neighbour flush dev $interface
-+ }
-+ 
-  # Invoke the local dhcp client enter hooks, if they exist.
-  if [ -f /etc/dhclient-enter-hooks ]; then
-    exit_status=0
-***************
-*** 150,159 ****
-      ifconfig $interface:0- inet 0
-    fi
-    if [ x$old_ip_address != x ] && [ x$old_ip_address != x$new_ip_address ]; then
-!     # IP address changed. Bringing down the interface will delete all routes,
-!     # and clear the ARP cache.
-!     ifconfig $interface inet 0 down
-! 
-    fi
-    if [ x$old_ip_address = x ] || [ x$old_ip_address != x$new_ip_address ] || \
-       [ x$reason = xBOUND ] || [ x$reason = xREBOOT ]; then
---- 158,165 ----
-      ifconfig $interface:0- inet 0
-    fi
-    if [ x$old_ip_address != x ] && [ x$old_ip_address != x$new_ip_address ]; then
-!     # IP address changed.
-!     flush_if
-    fi
-    if [ x$old_ip_address = x ] || [ x$old_ip_address != x$new_ip_address ] || \
-       [ x$reason = xBOUND ] || [ x$reason = xREBOOT ]; then
-***************
-*** 189,196 ****
-      ifconfig $interface:0- inet 0
-    fi
-    if [ x$old_ip_address != x ]; then
-!     # Shut down interface, which will delete routes and clear arp cache.
-!     ifconfig $interface inet 0 down
-    fi
-    if [ x$alias_ip_address != x ]; then
-      ifconfig $interface:0 inet $alias_ip_address $alias_subnet_arg
---- 195,201 ----
-      ifconfig $interface:0- inet 0
-    fi
-    if [ x$old_ip_address != x ]; then
-!     flush_if
-    fi
-    if [ x$alias_ip_address != x ]; then
-      ifconfig $interface:0 inet $alias_ip_address $alias_subnet_arg
-***************
-*** 225,231 ****
-      make_resolv_conf
-      exit_with_hooks 0
-    fi
-!   ifconfig $interface inet 0 down
-    exit_with_hooks 1
-  fi
-  
---- 230,236 ----
-      make_resolv_conf
-      exit_with_hooks 0
-    fi
-!   flush_if
-    exit_with_hooks 1
-  fi
-  
diff --git a/pkgs/tools/networking/dhcp/set-hostname.patch b/pkgs/tools/networking/dhcp/set-hostname.patch
index 495a8a124be3..7aa9d0814514 100644
--- a/pkgs/tools/networking/dhcp/set-hostname.patch
+++ b/pkgs/tools/networking/dhcp/set-hostname.patch
@@ -1,14 +1,12 @@
-diff -ru -x '*~' dhcp-4.1.2-P1-orig//client/scripts/linux dhcp-4.1.2-P1//client/scripts/linux
---- dhcp-4.1.2-P1-orig//client/scripts/linux	2010-09-15 00:49:48.000000000 +0200
-+++ dhcp-4.1.2-P1//client/scripts/linux	2011-04-01 16:08:10.984372269 +0200
+--- a/client/scripts/linux	2010-09-15 00:49:48.000000000 +0200
++++ b/client/scripts/linux	2011-04-01 16:08:10.984372269 +0200
 @@ -133,9 +133,7 @@
-      [ x$current_hostname = "x(none)" ] || \
-      [ x$current_hostname = xlocalhost ] || \
-      [ x$current_hostname = x$old_host_name ]; then
--    if [ x$new_host_name != x$old_host_name ]; then
--      hostname "$new_host_name"
--    fi
-+    hostname "$new_host_name"
-   fi
-     
-   if [ x$old_ip_address != x ] && [ x$alias_ip_address != x ] && \
+            [ "$current_hostname" = '(none)' ] ||
+            [ "$current_hostname" = 'localhost' ] ||
+            [ "$current_hostname" = "$old_host_name" ]; then
+-           if [ "$new_host_name" != "$old_host_name" ]; then
+-               hostname "$new_host_name"
+-           fi
++           hostname "$new_host_name"
+         fi
+     fi
diff --git a/pkgs/tools/networking/dhcpcd/default.nix b/pkgs/tools/networking/dhcpcd/default.nix
index 95e3193fd0f5..02d5a3073f4b 100644
--- a/pkgs/tools/networking/dhcpcd/default.nix
+++ b/pkgs/tools/networking/dhcpcd/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, pkgconfig, udev }:
+{ stdenv, fetchurl, pkgconfig, udev, runtimeShellPackage }:
 
 stdenv.mkDerivation rec {
   # when updating this to >=7, check, see previous reverts:
@@ -27,6 +27,11 @@ stdenv.mkDerivation rec {
   # Check that the udev plugin got built.
   postInstall = stdenv.lib.optional (udev != null) "[ -e $out/lib/dhcpcd/dev/udev.so ]";
 
+  # TODO shlevy remove once patchShebangs is fixed
+  postFixup = ''
+    find $out -type f -print0 | xargs --null sed -i 's|${stdenv.shellPackage}|${runtimeShellPackage}|'
+  '';
+
   meta = {
     description = "A client for the Dynamic Host Configuration Protocol (DHCP)";
     homepage = https://roy.marples.name/projects/dhcpcd;
diff --git a/pkgs/tools/security/gnupg/22.nix b/pkgs/tools/security/gnupg/22.nix
index 89fee90364e8..c47780588cd7 100644
--- a/pkgs/tools/security/gnupg/22.nix
+++ b/pkgs/tools/security/gnupg/22.nix
@@ -15,11 +15,11 @@ assert guiSupport -> pinentry != null;
 stdenv.mkDerivation rec {
   name = "gnupg-${version}";
 
-  version = "2.2.4";
+  version = "2.2.5";
 
   src = fetchurl {
     url = "mirror://gnupg/gnupg/${name}.tar.bz2";
-    sha256 = "1v7j8v2ww1knknbrhw3svfrqkmf9ll58iq0dczbsdpqgg1j3w6j0";
+    sha256 = "0mzgibq4dpxh3i9anmwg12xdjry28y83icafhx3j3djg5niqk89z";
   };
 
   nativeBuildInputs = [ pkgconfig ];
diff --git a/pkgs/tools/security/gnupg/fix-libusb-include-path.patch b/pkgs/tools/security/gnupg/fix-libusb-include-path.patch
index 18c4f1107388..a5432f8e3d95 100644
--- a/pkgs/tools/security/gnupg/fix-libusb-include-path.patch
+++ b/pkgs/tools/security/gnupg/fix-libusb-include-path.patch
@@ -1,10 +1,11 @@
 --- a/configure
 +++ b/configure
-@@ -8872,7 +8872,7 @@
+@@ -8987,8 +8987,7 @@
     { $as_echo "$as_me:${as_lineno-$LINENO}: checking libusb include dir" >&5
  $as_echo_n "checking libusb include dir... " >&6; }
     usb_incdir_found="no"
--   for _incdir in "" "/usr/include/libusb-1.0" "/usr/local/include/libusb-1.0"; do
+-   for _incdir in "" "/usr/include/libusb-1.0" \
+-       "/usr/local/include/libusb-1.0" "/usr/pkg/include/libusb-1.0"; do
 +   for _incdir in "$($PKG_CONFIG --variable=includedir libusb-1.0)/libusb-1.0"; do
       _libusb_save_cppflags=$CPPFLAGS
       if test -n "${_incdir}"; then
diff --git a/pkgs/tools/security/sudo/default.nix b/pkgs/tools/security/sudo/default.nix
index 1edd5b60926f..85dba08255da 100644
--- a/pkgs/tools/security/sudo/default.nix
+++ b/pkgs/tools/security/sudo/default.nix
@@ -51,7 +51,8 @@ stdenv.mkDerivation rec {
     installFlags="sudoers_uid=$(id -u) sudoers_gid=$(id -g) sysconfdir=$out/etc rundir=$TMPDIR/dummy vardir=$TMPDIR/dummy"
     '';
 
-  buildInputs = [ coreutils pam groff ];
+  nativeBuildInputs = [ groff ];
+  buildInputs = [ pam ];
 
   enableParallelBuilding = true;
 
diff --git a/pkgs/tools/text/gawk/default.nix b/pkgs/tools/text/gawk/default.nix
index 6783158ca77e..c0c06813dc94 100644
--- a/pkgs/tools/text/gawk/default.nix
+++ b/pkgs/tools/text/gawk/default.nix
@@ -19,11 +19,11 @@ let
   inherit (stdenv.lib) optional;
 in
 stdenv.mkDerivation rec {
-  name = "gawk-4.2.0";
+  name = "gawk-4.2.1";
 
   src = fetchurl {
     url = "mirror://gnu/gawk/${name}.tar.xz";
-    sha256 = "1wm9lqj77y7xz07zi0n187aqm8zavzxzpm1j53ahxz81q0qwvwyl";
+    sha256 = "0lam2zf3n7ak4pig8w46lhx9hzx50kj2v2yj1616mm26wy2rf4fi";
   };
 
   # When we do build separate interactive version, it makes sense to always include man.
diff --git a/pkgs/tools/text/groff/default.nix b/pkgs/tools/text/groff/default.nix
index 6d01c42f93d1..4495a85b2885 100644
--- a/pkgs/tools/text/groff/default.nix
+++ b/pkgs/tools/text/groff/default.nix
@@ -47,7 +47,7 @@ stdenv.mkDerivation rec {
   ] ++ stdenv.lib.optionals (ghostscript != null) [
     "--with-gs=${ghostscript}/bin/gs"
   ] ++ stdenv.lib.optionals (stdenv.buildPlatform != stdenv.hostPlatform) [
-    "ac_cv_path_PERL=${perl}/bin/perl"
+    "ac_cv_path_PERL=${buildPackages.perl}/bin/perl"
   ];
 
   doCheck = true;
@@ -103,6 +103,8 @@ stdenv.mkDerivation rec {
     substituteInPlace $perl/bin/grog \
       --replace $out/lib/groff/grog $perl/lib/groff/grog
 
+  '' + stdenv.lib.optionalString (stdenv.buildPlatform != stdenv.hostPlatform) ''
+    find $perl/ -type f -print0 | xargs --null sed -i 's|${buildPackages.perl}|${perl}|'
   '';
 
   meta = with stdenv.lib; {
diff --git a/pkgs/tools/typesetting/docbook2x/default.nix b/pkgs/tools/typesetting/docbook2x/default.nix
index 37cd6a2e50b3..9c802a1187a8 100644
--- a/pkgs/tools/typesetting/docbook2x/default.nix
+++ b/pkgs/tools/typesetting/docbook2x/default.nix
@@ -1,5 +1,5 @@
 { fetchurl, stdenv, texinfo, perl
-, XMLSAX, XMLParser, XMLNamespaceSupport
+, XMLSAX, XMLSAXBase, XMLParser, XMLNamespaceSupport
 , groff, libxml2, libxslt, gnused, libiconv, opensp
 , docbook_xml_dtd_43
 , makeWrapper }:
@@ -35,7 +35,7 @@ stdenv.mkDerivation rec {
       # XXX: We work around the fact that `wrapProgram' doesn't support
       # spaces below by inserting escaped backslashes.
       wrapProgram $out/bin/$i --prefix PERL5LIB :			\
-        "${XMLSAX}/lib/perl5/site_perl:${XMLParser}/lib/perl5/site_perl" \
+        "${XMLSAX}/lib/perl5/site_perl:${XMLSAXBase}/lib/perl5/site_perl:${XMLParser}/lib/perl5/site_perl" \
 	--prefix PERL5LIB :						\
 	"${XMLNamespaceSupport}/lib/perl5/site_perl"			\
 	--prefix XML_CATALOG_FILES "\ "					\
diff --git a/pkgs/tools/typesetting/tex/texlive/bin.nix b/pkgs/tools/typesetting/tex/texlive/bin.nix
index f022ccb829ab..8318ad2afe99 100644
--- a/pkgs/tools/typesetting/tex/texlive/bin.nix
+++ b/pkgs/tools/typesetting/tex/texlive/bin.nix
@@ -28,6 +28,14 @@ let
       sha256 = "1amjrxyasplv4alfwcxwnw4nrx7dz2ydmddkq16k6hg90i9njq81";
     };
 
+    patches = [
+      (fetchurl {
+        name = "texlive-poppler-0.59.patch";
+        url = https://git.archlinux.org/svntogit/packages.git/plain/trunk/texlive-poppler-0.59.patch?h=packages/texlive-bin&id=6308ec39bce2a4d735f6ff8a4e94473748d7b450;
+        sha256 = "1c4ikq4kxw48bi3i33bzpabrjvbk01fwjr2lz20gkc9kv8l0bg3n";
+      })
+    ];
+
     configureFlags = [
       "--with-banner-add=/NixOS.org"
       "--disable-missing" "--disable-native-texlive-build"
@@ -58,7 +66,7 @@ texliveYear = year;
 core = stdenv.mkDerivation rec {
   name = "texlive-bin-${version}";
 
-  inherit (common) src;
+  inherit (common) src patches;
 
   outputs = [ "out" "doc" ];
 
@@ -168,7 +176,7 @@ core-big = stdenv.mkDerivation { #TODO: upmendex
         # http://tex.stackexchange.com/questions/97999/when-to-use-luajittex-in-favour-of-luatex
       ];
 
-  patches = [ ./luatex-gcc7.patch ];
+  patches = common.patches ++ [ ./luatex-gcc7.patch ];
 
   configureScript = ":";
 
diff --git a/pkgs/tools/typesetting/tex/texlive/default.nix b/pkgs/tools/typesetting/tex/texlive/default.nix
index dc8f0908ea89..d0c9da9b9131 100644
--- a/pkgs/tools/typesetting/tex/texlive/default.nix
+++ b/pkgs/tools/typesetting/tex/texlive/default.nix
@@ -57,15 +57,9 @@ let
 
       # remove dependency-heavy packages from the basic collections
       collection-basic = orig.collection-basic // {
-        deps = removeAttrs orig.collection-basic.deps [ "luatex" "metafont" "xdvi" ];
-      };
-      latex = orig.latex // {
-        deps = removeAttrs orig.latex.deps [ "luatex" ];
+        deps = removeAttrs orig.collection-basic.deps [ "metafont" "xdvi" ];
       };
       # add them elsewhere so that collections cover all packages
-      collection-luatex = orig.collection-luatex // {
-        deps = orig.collection-luatex.deps // { inherit (tl) luatex; };
-      };
       collection-metapost = orig.collection-metapost // {
         deps = orig.collection-metapost.deps // { inherit (tl) metafont; };
       };