summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorSergey Mironov <ierton@gmail.com>2013-03-31 12:57:28 +0400
committerSergey Mironov <ierton@gmail.com>2013-03-31 13:06:31 +0400
commitee921d9df413b7634229e79630b7ca9217a1cb2d (patch)
tree9873d2ad7af2ae78f08acd434f67e7fc9aad9c16 /pkgs/tools
parentf7efab5fd83e5b28c5e5f54dff057be7a33b0d39 (diff)
downloadnixlib-ee921d9df413b7634229e79630b7ca9217a1cb2d.tar
nixlib-ee921d9df413b7634229e79630b7ca9217a1cb2d.tar.gz
nixlib-ee921d9df413b7634229e79630b7ca9217a1cb2d.tar.bz2
nixlib-ee921d9df413b7634229e79630b7ca9217a1cb2d.tar.lz
nixlib-ee921d9df413b7634229e79630b7ca9217a1cb2d.tar.xz
nixlib-ee921d9df413b7634229e79630b7ca9217a1cb2d.tar.zst
nixlib-ee921d9df413b7634229e79630b7ca9217a1cb2d.zip
wicd: fix missing application icon
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/wicd/default.nix1
-rw-r--r--pkgs/tools/networking/wicd/fix-app-icon.patch19
2 files changed, 20 insertions, 0 deletions
diff --git a/pkgs/tools/networking/wicd/default.nix b/pkgs/tools/networking/wicd/default.nix
index b080018f1cb0..0b63f40a95be 100644
--- a/pkgs/tools/networking/wicd/default.nix
+++ b/pkgs/tools/networking/wicd/default.nix
@@ -24,6 +24,7 @@ stdenv.mkDerivation rec {
     ./no-optimization.patch
     ./dhclient.patch 
     ./no-ast-transl.patch
+    ./fix-app-icon.patch
     ];
 
   # Should I be using pygtk's propogated build inputs?
diff --git a/pkgs/tools/networking/wicd/fix-app-icon.patch b/pkgs/tools/networking/wicd/fix-app-icon.patch
new file mode 100644
index 000000000000..154d7da35108
--- /dev/null
+++ b/pkgs/tools/networking/wicd/fix-app-icon.patch
@@ -0,0 +1,19 @@
+Someone forgot to pack wicd.png icon. We will replace it with existing one.
+
+diff -ruN wicd-1.7.2.4.orig/gtk/gui.py wicd-1.7.2.4/gtk/gui.py
+--- wicd-1.7.2.4.orig/gtk/gui.py	2013-03-30 21:47:19.802907553 +0000
++++ wicd-1.7.2.4/gtk/gui.py	2013-03-31 08:13:32.876871673 +0000
+@@ -205,8 +205,10 @@
+ 
+         self.status_area.hide_all()
+ 
+-        if os.path.exists(os.path.join(wpath.images, "wicd.png")):
+-            self.window.set_icon_from_file(os.path.join(wpath.images, "wicd.png"))
++        if os.path.exists(os.path.join(wpath.images, "../../icons/hicolour/128x128/apps/wicd-gtk.png")):
++            self.window.set_icon_from_file(os.path.join(wpath.images, "../../icons/hicolour/128x128/apps/wicd-gtk.png"))
++        else:
++            print 'icon doesn\'t exist %s' % os.path.join(wpath.images, "../../icons/hicolour/128x128/apps/wicd-gtk.png")
+         self.statusID = None
+         self.first_dialog_load = True
+         self.is_visible = True
+