summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorviric <viric@viric.name>2018-07-29 00:17:44 +0200
committerGitHub <noreply@github.com>2018-07-29 00:17:44 +0200
commitdf9f76c62d47e856afedb7e4d1b921e1000a8dc1 (patch)
tree5cd8373dfbdb456954e2e6a6746acab0ef45eefd /pkgs/tools
parent585ded73298c0f74e4bed64a22367b9914f00f06 (diff)
parent322b2043f92b00a74246772349fd03c6c3513a15 (diff)
downloadnixlib-df9f76c62d47e856afedb7e4d1b921e1000a8dc1.tar
nixlib-df9f76c62d47e856afedb7e4d1b921e1000a8dc1.tar.gz
nixlib-df9f76c62d47e856afedb7e4d1b921e1000a8dc1.tar.bz2
nixlib-df9f76c62d47e856afedb7e4d1b921e1000a8dc1.tar.lz
nixlib-df9f76c62d47e856afedb7e4d1b921e1000a8dc1.tar.xz
nixlib-df9f76c62d47e856afedb7e4d1b921e1000a8dc1.tar.zst
nixlib-df9f76c62d47e856afedb7e4d1b921e1000a8dc1.zip
Merge pull request #43983 from viric/coreutils_ssl_master
Openssl in coreutils makes *sum programs much faster (RFC)
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/coreutils/default.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/pkgs/tools/misc/coreutils/default.nix b/pkgs/tools/misc/coreutils/default.nix
index 589c58d0acc0..146b5b5110c1 100644
--- a/pkgs/tools/misc/coreutils/default.nix
+++ b/pkgs/tools/misc/coreutils/default.nix
@@ -1,5 +1,5 @@
 { stdenv, lib, buildPackages
-, autoreconfHook, texinfo, fetchurl, perl, xz, libiconv, gmp ? null
+, autoreconfHook, texinfo, fetchurl, perl, xz, libiconv, openssl, gmp ? null
 , hostPlatform, buildPlatform
 , aclSupport ? false, acl ? null
 , attrSupport ? false, attr ? null
@@ -37,8 +37,8 @@ stdenv.mkDerivation rec {
   outputs = [ "out" "info" ];
 
   nativeBuildInputs = [ perl xz.bin ];
-  configureFlags =
-    optional (singleBinary != false)
+  configureFlags = [ "--with-openssl" ]
+    ++ optional (singleBinary != false)
       ("--enable-single-binary" + optionalString (isString singleBinary) "=${singleBinary}")
     ++ optional hostPlatform.isSunOS "ac_cv_func_inotify_init=no"
     ++ optional withPrefix "--program-prefix=g"
@@ -49,7 +49,7 @@ stdenv.mkDerivation rec {
     ];
 
 
-  buildInputs = [ gmp ]
+  buildInputs = [ gmp openssl ]
     ++ optional aclSupport acl
     ++ optional attrSupport attr
     ++ optionals hostPlatform.isCygwin [ autoreconfHook texinfo ]   # due to patch
@@ -71,7 +71,7 @@ stdenv.mkDerivation rec {
 
   # Saw random failures like ‘help2man: can't get '--help' info from
   # man/sha512sum.td/sha512sum’.
-  enableParallelBuilding = false;
+  enableParallelBuilding = true;
 
   NIX_LDFLAGS = optionalString selinuxSupport "-lsepol";
   FORCE_UNSAFE_CONFIGURE = optionalString hostPlatform.isSunOS "1";