summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorWilliam Roe <git@wjlr.org.uk>2015-03-04 16:14:49 +0000
committerWilliam Roe <git@wjlr.org.uk>2015-03-04 16:14:49 +0000
commitdf73d821fa24454d7d296fcaecb5bf90709373dd (patch)
tree8a2d62b36eda699783bcfba8316b5323f670e53c /pkgs/tools
parent13764f0b0f610fde990343be7851a6818bb1b32a (diff)
downloadnixlib-df73d821fa24454d7d296fcaecb5bf90709373dd.tar
nixlib-df73d821fa24454d7d296fcaecb5bf90709373dd.tar.gz
nixlib-df73d821fa24454d7d296fcaecb5bf90709373dd.tar.bz2
nixlib-df73d821fa24454d7d296fcaecb5bf90709373dd.tar.lz
nixlib-df73d821fa24454d7d296fcaecb5bf90709373dd.tar.xz
nixlib-df73d821fa24454d7d296fcaecb5bf90709373dd.tar.zst
nixlib-df73d821fa24454d7d296fcaecb5bf90709373dd.zip
autojump: Update to 22.2.4
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/autojump/default.nix11
1 files changed, 4 insertions, 7 deletions
diff --git a/pkgs/tools/misc/autojump/default.nix b/pkgs/tools/misc/autojump/default.nix
index a94ad14ca229..b0b82f3cc762 100644
--- a/pkgs/tools/misc/autojump/default.nix
+++ b/pkgs/tools/misc/autojump/default.nix
@@ -1,7 +1,7 @@
 { fetchurl, stdenv, python, bash }:
 
 let 
-  version = "21.6.9";
+  version = "22.2.4";
 in
   stdenv.mkDerivation rec {
     name = "autojump-${version}";
@@ -9,21 +9,18 @@ in
     src = fetchurl {
       url = "http://github.com/joelthelion/autojump/archive/release-v${version}.tar.gz";
       name = "autojump-${version}.tar.gz";
-      sha256 = "0js6jp9l83zxhd9bn8hjn4yf8gydnldrlmafgvlg3rd4i1v82649";
+      sha256 = "816badb0721f735e2b86bdfa8b333112f3867343c7c2263c569f75b4ec91f475";
     };
 
     buildInputs = [ python bash ];
     dontBuild = true;
 
     installPhase = ''
-      # don't check shell support (we're running with bash anyway)
-      sed -i -e 150,153d install.sh
-
-      bash ./install.sh -d $out -p ""
+      python ./install.py -d $out -p ""
       chmod +x $out/etc/profile.d/*
 
       mkdir -p "$out/etc/bash_completion.d"
-      cp -v $out/etc/profile.d/autojump.bash "$out/etc/bash_completion.d"
+      cp -v $out/share/autojump/autojump.bash "$out/etc/bash_completion.d"
 
       # FIXME: What's the right place for `autojump.zsh'?
     '';