summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorsjau <github.com@sjau.ch>2018-10-28 15:13:00 +0100
committersjau <github.com@sjau.ch>2018-10-31 04:41:23 +0100
commitdf51c5ef808d01a72ce3990254c880c389c7f2d4 (patch)
tree3e264977387ffd697a846303515ec282f52972d4 /pkgs/tools
parent7c3dd045ce323dc6e0a997175508399c8e7a42a5 (diff)
downloadnixlib-df51c5ef808d01a72ce3990254c880c389c7f2d4.tar
nixlib-df51c5ef808d01a72ce3990254c880c389c7f2d4.tar.gz
nixlib-df51c5ef808d01a72ce3990254c880c389c7f2d4.tar.bz2
nixlib-df51c5ef808d01a72ce3990254c880c389c7f2d4.tar.lz
nixlib-df51c5ef808d01a72ce3990254c880c389c7f2d4.tar.xz
nixlib-df51c5ef808d01a72ce3990254c880c389c7f2d4.tar.zst
nixlib-df51c5ef808d01a72ce3990254c880c389c7f2d4.zip
easysnap: init at 2018-10-28
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/backup/easysnap/default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/pkgs/tools/backup/easysnap/default.nix b/pkgs/tools/backup/easysnap/default.nix
new file mode 100644
index 000000000000..a8c726c9e161
--- /dev/null
+++ b/pkgs/tools/backup/easysnap/default.nix
@@ -0,0 +1,31 @@
+{stdenv, fetchFromGitHub, zfs }:
+
+stdenv.mkDerivation rec {
+  name = "easysnap-${version}";
+  version = "unstable-2018-10-28";
+
+  src = fetchFromGitHub {
+    owner = "sjau";
+    repo = "easysnap";
+    rev = "aa2768762da7730aa3eb90fdc2190a8359976edc";
+    sha256 = "0csn7capsmlkin4cf1fgl766gvszvqfllqkiyz0g9bvbapxv7nba";
+  };
+
+  installPhase = ''
+    mkdir -p $out/bin
+    cp -n easysnap* $out/bin/
+
+    for i in $out/bin/*; do
+      substituteInPlace $i \
+        --replace zfs ${zfs}/bin/zfs
+    done
+  '';
+
+  meta = with stdenv.lib; {
+    homepage    = https://github.com/sjau/easysnap;
+    description = "Customizable ZFS Snapshotting tool with zfs send/recv pulling";
+    license     = licenses.gpl3;
+    maintainers = with maintainers; [ sjau ];
+  };
+
+}