summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorJoachim Schiele <js@lastlog.de>2014-09-18 18:06:49 +0200
committerJoachim Schiele <js@lastlog.de>2014-09-18 18:06:49 +0200
commitdc86f52740690888d87f5fa65ae566b6e0746bbf (patch)
treec076b61d65cc7f5217006cc2896e946401d90c59 /pkgs/tools
parent477eb18d18843d91c2004f72d5377c7a5edac941 (diff)
downloadnixlib-dc86f52740690888d87f5fa65ae566b6e0746bbf.tar
nixlib-dc86f52740690888d87f5fa65ae566b6e0746bbf.tar.gz
nixlib-dc86f52740690888d87f5fa65ae566b6e0746bbf.tar.bz2
nixlib-dc86f52740690888d87f5fa65ae566b6e0746bbf.tar.lz
nixlib-dc86f52740690888d87f5fa65ae566b6e0746bbf.tar.xz
nixlib-dc86f52740690888d87f5fa65ae566b6e0746bbf.tar.zst
nixlib-dc86f52740690888d87f5fa65ae566b6e0746bbf.zip
dfc-3.0.4: a colored df -h replacement
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/system/dfc/default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/pkgs/tools/system/dfc/default.nix b/pkgs/tools/system/dfc/default.nix
new file mode 100644
index 000000000000..84150b468378
--- /dev/null
+++ b/pkgs/tools/system/dfc/default.nix
@@ -0,0 +1,21 @@
+{stdenv, fetchurl, cmake, gettext}:
+
+stdenv.mkDerivation rec {
+  name = "dfc-3.0.4";
+
+  src = fetchurl {
+    url = "http://projects.gw-computing.net/attachments/download/79/dfc-3.0.4.tar.gz";
+    sha256 = "0bdc2edb92c7f740a0b7d3fa75eb134adf197ba711bfa589ab51c691fabd617e";
+  };
+
+  buildInputs = [ cmake gettext ];
+
+  meta = {
+    homepage = "http://projects.gw-computing.net/projects/dfc";
+    description = "displays file system space usage using graphs and colors";
+    license="free";
+    maintainers = with stdenv.lib.maintainers; [qknight];
+    platforms = with stdenv.lib.platforms; all;
+  };
+}
+