summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorMitch Tishmack <mitch.tishmack@gmail.com>2016-03-21 14:05:01 -0500
committerMitch Tishmack <mitch.tishmack@gmail.com>2016-03-21 14:05:01 -0500
commitdb6dff75bd8905e7f7c7c679d5dc6680f65e5ae0 (patch)
tree6898ec1c8b91064d27911f1c930f849bf819bd92 /pkgs/tools
parent74f04dc83c016386ef87c0b82b91fa42780192a0 (diff)
downloadnixlib-db6dff75bd8905e7f7c7c679d5dc6680f65e5ae0.tar
nixlib-db6dff75bd8905e7f7c7c679d5dc6680f65e5ae0.tar.gz
nixlib-db6dff75bd8905e7f7c7c679d5dc6680f65e5ae0.tar.bz2
nixlib-db6dff75bd8905e7f7c7c679d5dc6680f65e5ae0.tar.lz
nixlib-db6dff75bd8905e7f7c7c679d5dc6680f65e5ae0.tar.xz
nixlib-db6dff75bd8905e7f7c7c679d5dc6680f65e5ae0.tar.zst
nixlib-db6dff75bd8905e7f7c7c679d5dc6680f65e5ae0.zip
htop: fix build on darwin
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/system/htop/default.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/pkgs/tools/system/htop/default.nix b/pkgs/tools/system/htop/default.nix
index 46547aa45fd9..9301107d2db9 100644
--- a/pkgs/tools/system/htop/default.nix
+++ b/pkgs/tools/system/htop/default.nix
@@ -1,4 +1,5 @@
-{ fetchurl, stdenv, ncurses }:
+{ lib, fetchurl, stdenv, ncurses,
+IOKit }:
 
 stdenv.mkDerivation rec {
   name = "htop-${version}";
@@ -9,7 +10,9 @@ stdenv.mkDerivation rec {
     url = "http://hisham.hm/htop/releases/${version}/${name}.tar.gz";
   };
 
-  buildInputs = [ ncurses ];
+  buildInputs =
+    [ ncurses ] ++
+    lib.optionals stdenv.isDarwin [ IOKit ];
 
   meta = with stdenv.lib; {
     description = "An interactive process viewer for Linux";