summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2015-01-14 10:02:05 +0100
committerTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2015-01-14 10:02:05 +0100
commitd885a5003a46f43415b23a1384268ddf6f2f594b (patch)
tree4854ff3dc1278d7c007e33a5f1d7521e3f217bd6 /pkgs/tools
parent5ac7febcb3c693a05e112f6458b10c453268a632 (diff)
downloadnixlib-d885a5003a46f43415b23a1384268ddf6f2f594b.tar
nixlib-d885a5003a46f43415b23a1384268ddf6f2f594b.tar.gz
nixlib-d885a5003a46f43415b23a1384268ddf6f2f594b.tar.bz2
nixlib-d885a5003a46f43415b23a1384268ddf6f2f594b.tar.lz
nixlib-d885a5003a46f43415b23a1384268ddf6f2f594b.tar.xz
nixlib-d885a5003a46f43415b23a1384268ddf6f2f594b.tar.zst
nixlib-d885a5003a46f43415b23a1384268ddf6f2f594b.zip
Add stress-ng 0.03.09: stress test a computer system
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/system/stress-ng/default.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/pkgs/tools/system/stress-ng/default.nix b/pkgs/tools/system/stress-ng/default.nix
new file mode 100644
index 000000000000..73dda1b55166
--- /dev/null
+++ b/pkgs/tools/system/stress-ng/default.nix
@@ -0,0 +1,39 @@
+{ stdenv, fetchurl }:
+
+stdenv.mkDerivation rec {
+  version = "0.03.09";
+  name = "stress-ng-${version}";
+
+  src = fetchurl {
+    url = "http://kernel.ubuntu.com/~cking/tarballs/stress-ng/${name}.tar.gz";
+    sha256 = "0lpm04yn7jkfbmdhv73vnnskj492cwvcddh962pgz1mb5rzdkskj";
+  };
+
+  patchPhase = ''
+    substituteInPlace Makefile --replace "/usr" ""
+  '';
+
+  enableParallelBuilding = true;
+
+  makeFlags = "DESTDIR=$(out)";
+
+  meta = with stdenv.lib; {
+    description = "Stress test a computer system";
+    longDescription = ''
+      Stress test a computer system in various selectable ways, by exercising
+      various physical subsystems of a computer as well as the various
+      operating system kernel interfaces. Stress-ng features:
+      - over 60 different stress tests
+      - over 50 CPU specific stress tests that exercise floating point,
+        integer, bit manipulation and control flow
+      - over 20 virtual memory stress tests
+      stress-ng was originally intended to make a machine work hard and trip
+      hardware issues such as thermal overruns as well as operating system
+      bugs that only occur when a system is being thrashed hard.
+    '';
+    homepage = http://kernel.ubuntu.com/~cking/stress-ng/;
+    license = with licenses; gpl2Plus;
+    platforms = with platforms; linux;
+    maintainers = with maintainers; [ nckx ];
+  };
+}