summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2015-09-24 01:32:25 +0200
committerTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2015-09-24 13:18:38 +0200
commitd2f3041d270cba3746dbdb021a4be3d166517e77 (patch)
treeff1d9d76d4af16f0b8e2f7387f435196d561a653 /pkgs/tools
parent1e1a54f62c7b3a849bd353b70cbe06aebcfdb60c (diff)
downloadnixlib-d2f3041d270cba3746dbdb021a4be3d166517e77.tar
nixlib-d2f3041d270cba3746dbdb021a4be3d166517e77.tar.gz
nixlib-d2f3041d270cba3746dbdb021a4be3d166517e77.tar.bz2
nixlib-d2f3041d270cba3746dbdb021a4be3d166517e77.tar.lz
nixlib-d2f3041d270cba3746dbdb021a4be3d166517e77.tar.xz
nixlib-d2f3041d270cba3746dbdb021a4be3d166517e77.tar.zst
nixlib-d2f3041d270cba3746dbdb021a4be3d166517e77.zip
sshuttle: carry a few bug fixes until next release
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/security/sshuttle/default.nix17
1 files changed, 16 insertions, 1 deletions
diff --git a/pkgs/tools/security/sshuttle/default.nix b/pkgs/tools/security/sshuttle/default.nix
index 18997abb6788..d392f8a2fb63 100644
--- a/pkgs/tools/security/sshuttle/default.nix
+++ b/pkgs/tools/security/sshuttle/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchFromGitHub, makeWrapper, pandoc
+{ stdenv, fetchFromGitHub, fetchpatch, makeWrapper, pandoc
 , coreutils, iptables, nettools, openssh, procps,  python }:
   
 let version = "0.71"; in
@@ -12,6 +12,21 @@ stdenv.mkDerivation rec {
     owner = "sshuttle";
   };
 
+  patches = [
+    (fetchpatch {
+      sha256 = "1yrjyvdz6k6zk020dmbagf8w49w8vhfbzgfpsq9jqdh2hbykv3m3";
+      url = https://github.com/sshuttle/sshuttle/commit/3cf5002b62650c26a50e18af8d8c5c91d754bab9.patch;
+    })
+    (fetchpatch {
+      sha256 = "091gg28cnmx200q46bcnxpp9ih9p5qlq0r3bxfm0f4qalg8rmp2g";
+      url = https://github.com/sshuttle/sshuttle/commit/d70b5f2b89e593506834cf8ea10785d96c801dfc.patch;
+    })
+    (fetchpatch {
+      sha256 = "17l9h8clqlbyxdkssavxqpb902j7b3yabrrdalybfpkhj69x8ghk";
+      url = https://github.com/sshuttle/sshuttle/commit/a38963301e9c29fbe3232f0a41ea080b642c5ad2.patch;
+    })
+  ];
+
   nativeBuildInputs = [ makeWrapper pandoc ];
   buildInputs = [ coreutils iptables nettools openssh procps python ];