summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorLancelot SIX <lancelot@lancelotsix.com>2015-08-03 22:05:16 +0200
committerLancelot SIX <lancelot@lancelotsix.com>2015-08-06 00:22:18 +0200
commitd165ea2329b1f73fea087dab8ccbef7b339302b2 (patch)
tree7deefe377a721e933e49a867db3ba707df8617fa /pkgs/tools
parentc6159b261499c32ad636f57774b9de559e48959c (diff)
downloadnixlib-d165ea2329b1f73fea087dab8ccbef7b339302b2.tar
nixlib-d165ea2329b1f73fea087dab8ccbef7b339302b2.tar.gz
nixlib-d165ea2329b1f73fea087dab8ccbef7b339302b2.tar.bz2
nixlib-d165ea2329b1f73fea087dab8ccbef7b339302b2.tar.lz
nixlib-d165ea2329b1f73fea087dab8ccbef7b339302b2.tar.xz
nixlib-d165ea2329b1f73fea087dab8ccbef7b339302b2.tar.zst
nixlib-d165ea2329b1f73fea087dab8ccbef7b339302b2.zip
hubicfuse: init at 2.1.0
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/filesystems/hubicfuse/default.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/pkgs/tools/filesystems/hubicfuse/default.nix b/pkgs/tools/filesystems/hubicfuse/default.nix
new file mode 100644
index 000000000000..7ce48d288030
--- /dev/null
+++ b/pkgs/tools/filesystems/hubicfuse/default.nix
@@ -0,0 +1,25 @@
+{ stdenv, fetchurl, pkgconfig, curl, openssl, fuse, libxml2, json_c, file }:
+
+stdenv.mkDerivation rec {
+  name = "hubicfuse-${version}";
+  version = "2.1.0";
+
+  src = fetchurl {
+    url = https://github.com/TurboGit/hubicfuse/archive/v2.1.0.tar.gz;
+    sha256 = "1mnijcwac6k3f6xknvdrsbmkkizpwbayqkb5l6jic15ymxv1fs7d";
+  };
+
+  buildInputs = [ pkgconfig curl openssl fuse libxml2 json_c file ];
+  postInstall = ''
+    install hubic_token $out/bin
+    mkdir -p $out/sbin
+    ln -sf $out/bin/hubicfuse $out/sbin/mount.hubicfuse
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = https://github.com/TurboGit/hubicfuse;
+    description = "FUSE-based filesystem to access hubic cloud storage";
+    platforms = platforms.linux;
+    license = licenses.mit;
+  };
+}