summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorJosef Kemetmueller <josef.kemetmueller@gmail.com>2018-02-05 20:25:43 +0000
committerJosef Kemetmueller <josef.kemetmueller@gmail.com>2018-02-05 20:41:22 +0000
commitceeacd52052a2ebd27a6648f7604db7aea7e4b69 (patch)
tree524c986abbbc3043b9daa051ba6f1de19d04b340 /pkgs/tools
parentd7000b03cd851175cda5bd6ce8d25cab7d341c38 (diff)
downloadnixlib-ceeacd52052a2ebd27a6648f7604db7aea7e4b69.tar
nixlib-ceeacd52052a2ebd27a6648f7604db7aea7e4b69.tar.gz
nixlib-ceeacd52052a2ebd27a6648f7604db7aea7e4b69.tar.bz2
nixlib-ceeacd52052a2ebd27a6648f7604db7aea7e4b69.tar.lz
nixlib-ceeacd52052a2ebd27a6648f7604db7aea7e4b69.tar.xz
nixlib-ceeacd52052a2ebd27a6648f7604db7aea7e4b69.tar.zst
nixlib-ceeacd52052a2ebd27a6648f7604db7aea7e4b69.zip
graphviz: Explicitly specify libltdl directories
This should prevent the build from picking up /usr/lib/libltdl.so in
non-chroot builds on non-nixOS.
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/graphics/graphviz/base.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/pkgs/tools/graphics/graphviz/base.nix b/pkgs/tools/graphics/graphviz/base.nix
index 8a46b302dcdf..f61c7923d794 100644
--- a/pkgs/tools/graphics/graphviz/base.nix
+++ b/pkgs/tools/graphics/graphviz/base.nix
@@ -31,7 +31,10 @@ stdenv.mkDerivation rec {
   CPPFLAGS = stdenv.lib.optionalString (xorg != null && stdenv.isDarwin)
     "-I${cairo.dev}/include/cairo";
 
-  configureFlags = optional (xorg == null) "--without-x";
+  configureFlags = [
+    "--with-ltdl-lib=${libtool.lib}/lib"
+    "--with-ltdl-include=${libtool}/include"
+  ] ++ stdenv.lib.optional (xorg == null) [ "--without-x" ];
 
   postPatch = ''
     for f in $(find . -name Makefile.in); do