summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorDaiderd Jordan <daiderd@gmail.com>2018-04-03 21:10:26 +0200
committerGitHub <noreply@github.com>2018-04-03 21:10:26 +0200
commitcc1d4addc541746aad69fa7e035c2b3566f5b4fa (patch)
treea992fc577c3e8f0748e2c9e2cbb923b3dce0488c /pkgs/tools
parentd305c24b8d96a7a2db49c1f395ef40a964beb06a (diff)
parent8f2102def60ef91462d79e257fc4b120c76d6f5c (diff)
downloadnixlib-cc1d4addc541746aad69fa7e035c2b3566f5b4fa.tar
nixlib-cc1d4addc541746aad69fa7e035c2b3566f5b4fa.tar.gz
nixlib-cc1d4addc541746aad69fa7e035c2b3566f5b4fa.tar.bz2
nixlib-cc1d4addc541746aad69fa7e035c2b3566f5b4fa.tar.lz
nixlib-cc1d4addc541746aad69fa7e035c2b3566f5b4fa.tar.xz
nixlib-cc1d4addc541746aad69fa7e035c2b3566f5b4fa.tar.zst
nixlib-cc1d4addc541746aad69fa7e035c2b3566f5b4fa.zip
Merge pull request #38384 from mbode/tectonic_darwin
tectonic: fix darwin build
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/typesetting/tectonic/default.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/pkgs/tools/typesetting/tectonic/default.nix b/pkgs/tools/typesetting/tectonic/default.nix
index ad612fa18af6..f3f0a60b4802 100644
--- a/pkgs/tools/typesetting/tectonic/default.nix
+++ b/pkgs/tools/typesetting/tectonic/default.nix
@@ -1,5 +1,5 @@
 { stdenv, fetchFromGitHub, rustPlatform, makeWrapper
-, fontconfig, harfbuzz-icu, openssl, pkgconfig }:
+, darwin, fontconfig, harfbuzz-icu, openssl, pkgconfig }:
 
 rustPlatform.buildRustPackage rec {
   name = "tectonic-${version}";
@@ -16,7 +16,8 @@ rustPlatform.buildRustPackage rec {
 
   nativeBuildInputs = [ pkgconfig ];
 
-  buildInputs = [ fontconfig harfbuzz-icu openssl ];
+  buildInputs = [ fontconfig harfbuzz-icu openssl ]
+    ++ stdenv.lib.optionals stdenv.isDarwin (with darwin.apple_sdk.frameworks; [ ApplicationServices Cocoa Foundation ]);
 
   # tests fail due to read-only nix store
   doCheck = false;