summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorThomas Tuegel <ttuegel@mailbox.org>2017-05-17 14:26:11 -0500
committerThomas Tuegel <ttuegel@mailbox.org>2017-06-18 08:44:42 -0500
commitc816bbc8a86c7ea6c09ca42e1694fe08003a55fc (patch)
tree036a3c0d8a3a6a4be068cf153a863fc0114ef28f /pkgs/tools
parent1607f51613fc63a6fbfc1884c55a9efea06161b3 (diff)
downloadnixlib-c816bbc8a86c7ea6c09ca42e1694fe08003a55fc.tar
nixlib-c816bbc8a86c7ea6c09ca42e1694fe08003a55fc.tar.gz
nixlib-c816bbc8a86c7ea6c09ca42e1694fe08003a55fc.tar.bz2
nixlib-c816bbc8a86c7ea6c09ca42e1694fe08003a55fc.tar.lz
nixlib-c816bbc8a86c7ea6c09ca42e1694fe08003a55fc.tar.xz
nixlib-c816bbc8a86c7ea6c09ca42e1694fe08003a55fc.tar.zst
nixlib-c816bbc8a86c7ea6c09ca42e1694fe08003a55fc.zip
qt5: remove makeQtWrapper
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/audio/qastools/default.nix11
-rw-r--r--pkgs/tools/misc/antimicro/default.nix13
-rw-r--r--pkgs/tools/misc/qt5ct/default.nix6
-rw-r--r--pkgs/tools/misc/radeon-profile/default.nix5
-rw-r--r--pkgs/tools/misc/rockbox-utility/default.nix6
5 files changed, 16 insertions, 25 deletions
diff --git a/pkgs/tools/audio/qastools/default.nix b/pkgs/tools/audio/qastools/default.nix
index 3456f0986488..d86a0b09c269 100644
--- a/pkgs/tools/audio/qastools/default.nix
+++ b/pkgs/tools/audio/qastools/default.nix
@@ -1,11 +1,10 @@
-{ stdenv, fetchurl, cmake, alsaLib, udev, qtbase,
-  qtsvg, qttools, makeQtWrapper }:
+{ mkDerivation, lib, fetchurl, cmake, alsaLib, udev, qtbase, qtsvg, qttools }:
 
 let
   version = "0.21.0";
 in
 
-stdenv.mkDerivation {
+mkDerivation {
   name = "qastools-${version}";
 
   src = fetchurl {
@@ -14,15 +13,15 @@ stdenv.mkDerivation {
   };
 
   buildInputs = [
-    cmake alsaLib udev qtbase qtsvg qttools makeQtWrapper
+    alsaLib udev qtbase qtsvg qttools
   ];
+  nativeBuildInputs = [ cmake ];
 
   cmakeFlags = [
-    "-DCMAKE_INSALL_PREFIX=$out"
     "-DALSA_INCLUDE=${alsaLib.dev}/include/alsa/version.h"
   ];
 
-  meta = with stdenv.lib; {
+  meta = with lib; {
     description = "Collection of desktop applications for ALSA configuration";
     license = licenses.gpl3;
     platforms = platforms.linux;
diff --git a/pkgs/tools/misc/antimicro/default.nix b/pkgs/tools/misc/antimicro/default.nix
index 02d65597f749..ee0accac2d9b 100644
--- a/pkgs/tools/misc/antimicro/default.nix
+++ b/pkgs/tools/misc/antimicro/default.nix
@@ -1,6 +1,6 @@
-{ stdenv, cmake, pkgconfig, SDL2, qtbase, qttools, makeQtWrapper, xorg, fetchFromGitHub }:
+{ mkDerivation, lib, cmake, pkgconfig, SDL2, qtbase, qttools, xorg, fetchFromGitHub }:
 
-stdenv.mkDerivation rec {
+mkDerivation rec {
   name = "antimicro-${version}";
   version = "2.23";
 
@@ -11,15 +11,12 @@ stdenv.mkDerivation rec {
     sha256 = "1q40ayxwwyq85lc89cnj1cm2nar625h4vhh8dvmb2qcxczaggf4v";
   };
 
+  nativeBuildInputs = [ cmake pkgconfig ];
   buildInputs = [
-    cmake pkgconfig SDL2 qtbase qttools xorg.libXtst makeQtWrapper
+    SDL2 qtbase qttools xorg.libXtst
   ];
 
-  postInstall = ''
-    wrapQtProgram $out/bin/antimicro
-  '';
-
-  meta = with stdenv.lib; {
+  meta = with lib; {
     description = "GUI for mapping keyboard and mouse controls to a gamepad";
     inherit (src.meta) homepage;
     maintainers = with maintainers; [ jb55 ];
diff --git a/pkgs/tools/misc/qt5ct/default.nix b/pkgs/tools/misc/qt5ct/default.nix
index dce2392cc7b2..86750518bb5a 100644
--- a/pkgs/tools/misc/qt5ct/default.nix
+++ b/pkgs/tools/misc/qt5ct/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, qtbase, qtsvg, qttools, qmake, makeQtWrapper }:
+{ stdenv, fetchurl, qtbase, qtsvg, qttools, qmake }:
 
 stdenv.mkDerivation rec {
   name = "qt5ct-${version}";
@@ -18,10 +18,6 @@ stdenv.mkDerivation rec {
     qmakeFlags="$qmakeFlags PLUGINDIR=$out/$qtPluginPrefix"
   '';
 
-  preFixup = ''
-    wrapQtProgram $out/bin/qt5ct
-  '';
-
   meta = with stdenv.lib; {
     description = "Qt5 Configuration Tool";
     homepage = https://www.opendesktop.org/content/show.php?content=168066;
diff --git a/pkgs/tools/misc/radeon-profile/default.nix b/pkgs/tools/misc/radeon-profile/default.nix
index f07e1d4adc7f..63f32763f223 100644
--- a/pkgs/tools/misc/radeon-profile/default.nix
+++ b/pkgs/tools/misc/radeon-profile/default.nix
@@ -1,11 +1,11 @@
-{ stdenv, fetchFromGitHub, qtbase, qmake, makeQtWrapper, libXrandr }:
+{ stdenv, fetchFromGitHub, qtbase, qmake, libXrandr }:
 
 stdenv.mkDerivation rec {
 
   name = "radeon-profile-${version}";
   version = "20161221";
 
-  nativeBuildInputs = [ qmake makeQtWrapper ];
+  nativeBuildInputs = [ qmake ];
   buildInputs = [ qtbase libXrandr ];
 
   src = (fetchFromGitHub {
@@ -18,7 +18,6 @@ stdenv.mkDerivation rec {
   postInstall = ''
     mkdir -p $out/bin
     cp ./radeon-profile $out/bin/radeon-profile
-    wrapQtProgram  $out/bin/radeon-profile
   '';
 
   meta = with stdenv.lib; {
diff --git a/pkgs/tools/misc/rockbox-utility/default.nix b/pkgs/tools/misc/rockbox-utility/default.nix
index 0538dd79508e..f84b9563967f 100644
--- a/pkgs/tools/misc/rockbox-utility/default.nix
+++ b/pkgs/tools/misc/rockbox-utility/default.nix
@@ -1,5 +1,5 @@
 { stdenv, fetchurl, pkgconfig, libusb1
-, qtbase, qttools, makeQtWrapper, qmake
+, qtbase, qttools, makeWrapper, qmake
 , withEspeak ? false, espeak ? null }:
 
 stdenv.mkDerivation  rec {
@@ -13,7 +13,7 @@ stdenv.mkDerivation  rec {
 
   buildInputs = [ libusb1 qtbase qttools ]
     ++ stdenv.lib.optional withEspeak espeak;
-  nativeBuildInputs = [ makeQtWrapper pkgconfig qmake ];
+  nativeBuildInputs = [ makeWrapper pkgconfig qmake ];
 
   preConfigure = ''
     cd rbutil/rbutilqt
@@ -24,7 +24,7 @@ stdenv.mkDerivation  rec {
 
     install -Dm755 RockboxUtility $out/bin/rockboxutility
     ln -s $out/bin/rockboxutility $out/bin/RockboxUtility
-    wrapQtProgram $out/bin/rockboxutility \
+    wrapProgram $out/bin/rockboxutility \
     ${stdenv.lib.optionalString withEspeak ''
       --prefix PATH : ${espeak}/bin
     ''}