summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorMoritz Ulrich <moritz@tarn-vedra.de>2013-11-29 01:10:01 +0100
committerMoritz Ulrich <moritz@tarn-vedra.de>2013-11-29 11:47:00 +0100
commitc71d6f3b1a5a33bdc09842e2f29d2a9e43818574 (patch)
treef62c5789e2acf2518be91b9d3878a60083ba4e37 /pkgs/tools
parent69c132ae9c054f12eac658d608be10da14b9d66c (diff)
downloadnixlib-c71d6f3b1a5a33bdc09842e2f29d2a9e43818574.tar
nixlib-c71d6f3b1a5a33bdc09842e2f29d2a9e43818574.tar.gz
nixlib-c71d6f3b1a5a33bdc09842e2f29d2a9e43818574.tar.bz2
nixlib-c71d6f3b1a5a33bdc09842e2f29d2a9e43818574.tar.lz
nixlib-c71d6f3b1a5a33bdc09842e2f29d2a9e43818574.tar.xz
nixlib-c71d6f3b1a5a33bdc09842e2f29d2a9e43818574.tar.zst
nixlib-c71d6f3b1a5a33bdc09842e2f29d2a9e43818574.zip
g500-control: Add myself as maintainer
Signed-off-by: Moritz Ulrich <moritz@tarn-vedra.de>
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/g500-control/default.nix13
1 files changed, 6 insertions, 7 deletions
diff --git a/pkgs/tools/misc/g500-control/default.nix b/pkgs/tools/misc/g500-control/default.nix
index adccde71c46d..9d42c7d68d53 100644
--- a/pkgs/tools/misc/g500-control/default.nix
+++ b/pkgs/tools/misc/g500-control/default.nix
@@ -1,6 +1,6 @@
-{stdenv, fetchurl, coreutils}:
+{ stdenv, fetchurl }:
 
-stdenv.mkDerivation rec {
+stdenv.mkDerivation {
   name = "g500-control-0.0.1";
 
   src = fetchurl {
@@ -8,10 +8,8 @@ stdenv.mkDerivation rec {
     sha256 = "1xlg9lpxnk3228k81y1i6jjh4df1p4jh64g54w969g6a6v6dazvb";
   };
 
-  buildInputs = [ coreutils ];
-  
   unpackPhase = ''
-    mkdir -pv g500-control
+    mkdir -p g500-control
     tar -C g500-control/ -xf $src
   '';
 
@@ -21,15 +19,16 @@ stdenv.mkDerivation rec {
   '';
 
   installPhase = ''
-    mkdir -pv $out/bin/
+    mkdir -p $out/bin/
     cp g500-control $out/bin/
   '';
-  
+
   meta = {
     homepage = http://code.google.com/p/g500-control/;
     description = "Configure Logitech G500's internal profile under Linux";
     license = stdenv.lib.licenses.gpl2;
     platforms = stdenv.lib.platforms.linux;
+    maintainers = with stdenv.lib.maintainers; [ the-kenny ];
   };
 }