summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorRob Vermaas <rob.vermaas@gmail.com>2009-09-17 07:31:34 +0000
committerRob Vermaas <rob.vermaas@gmail.com>2009-09-17 07:31:34 +0000
commitc3fe98554617eb9e80bb462ac4fdac103ef574c2 (patch)
tree289a942611cb241a44907cfc253a70b68b818883 /pkgs/tools
parent5915d8560d068227efa85bd4bcc179a8f592ebf4 (diff)
downloadnixlib-c3fe98554617eb9e80bb462ac4fdac103ef574c2.tar
nixlib-c3fe98554617eb9e80bb462ac4fdac103ef574c2.tar.gz
nixlib-c3fe98554617eb9e80bb462ac4fdac103ef574c2.tar.bz2
nixlib-c3fe98554617eb9e80bb462ac4fdac103ef574c2.tar.lz
nixlib-c3fe98554617eb9e80bb462ac4fdac103ef574c2.tar.xz
nixlib-c3fe98554617eb9e80bb462ac4fdac103ef574c2.tar.zst
nixlib-c3fe98554617eb9e80bb462ac4fdac103ef574c2.zip
* added ncftp
svn path=/nixpkgs/trunk/; revision=17214
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/ncftp/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/pkgs/tools/networking/ncftp/default.nix b/pkgs/tools/networking/ncftp/default.nix
new file mode 100644
index 000000000000..9f4fb29c393d
--- /dev/null
+++ b/pkgs/tools/networking/ncftp/default.nix
@@ -0,0 +1,27 @@
+{stdenv, fetchurl, ncurses, coreutils}:
+
+stdenv.mkDerivation {
+  name = "ncftp-3.2.3";
+
+  src = fetchurl {
+    url = ftp://ftp.ncftp.com/ncftp/ncftp-3.2.3-src.tar.bz2;
+    sha256 = "0455rf6yw568izq2nvz58mjd719dgp9y63yx9cb7l620vvxz5x26";
+  };
+
+  preConfigure = ''
+    find . -name "*.sh" -type f | xargs sed 's@/bin/ls@${coreutils}/bin/ls@g' -i
+    find . -name "*.in" -type f | xargs sed 's@/bin/ls@${coreutils}/bin/ls@g' -i
+    find . -name "*.c" -type f | xargs sed 's@/bin/ls@${coreutils}/bin/ls@g' -i
+    sed 's@/bin/ls@${coreutils}/bin/ls@g' -i configure
+
+    find . -name "*.sh" -type f | xargs sed 's@/bin/rm@${coreutils}/bin/rm@g' -i
+    find . -name "*.in" -type f | xargs sed 's@/bin/rm@${coreutils}/bin/rm@g' -i
+    find . -name "*.c" -type f | xargs sed 's@/bin/rm@${coreutils}/bin/rm@g' -i
+    sed 's@/bin/rm@${coreutils}/bin/rm@g' -i configure
+  '';
+
+  meta = {
+    description = "NcFTP Client (also known as just NcFTP) is a set of FREE application programs implementing the File Transfer Protocol (FTP).";
+    homepage = http://www.ncftp.com/ncftp/;
+  };
+}