summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2018-04-22 16:21:49 +0100
committerGitHub <noreply@github.com>2018-04-22 16:21:49 +0100
commitc3e78d3988b8b4a3b5d51fabd3efed5b196ae07e (patch)
treeab347fe5427114cdf9b87b96e378406b35555d8b /pkgs/tools
parente3b0d05c9d108343e228fcd04b6f395436c1bc7d (diff)
parent6026e43bceb66355f657e3d97bcbe7df173d2c79 (diff)
downloadnixlib-c3e78d3988b8b4a3b5d51fabd3efed5b196ae07e.tar
nixlib-c3e78d3988b8b4a3b5d51fabd3efed5b196ae07e.tar.gz
nixlib-c3e78d3988b8b4a3b5d51fabd3efed5b196ae07e.tar.bz2
nixlib-c3e78d3988b8b4a3b5d51fabd3efed5b196ae07e.tar.lz
nixlib-c3e78d3988b8b4a3b5d51fabd3efed5b196ae07e.tar.xz
nixlib-c3e78d3988b8b4a3b5d51fabd3efed5b196ae07e.tar.zst
nixlib-c3e78d3988b8b4a3b5d51fabd3efed5b196ae07e.zip
Merge pull request #39123 from Infinisil/add/dust
dust: init at 0.2.3
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/dust/default.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/pkgs/tools/misc/dust/default.nix b/pkgs/tools/misc/dust/default.nix
new file mode 100644
index 000000000000..f34d05758cf4
--- /dev/null
+++ b/pkgs/tools/misc/dust/default.nix
@@ -0,0 +1,25 @@
+{ stdenv, fetchFromGitHub, cargo, rustPlatform }:
+
+rustPlatform.buildRustPackage rec {
+  name = "dust-${version}";
+  version = "0.2.3";
+
+  src = fetchFromGitHub {
+    owner = "bootandy";
+    repo = "dust";
+    rev = "v${version}";
+    sha256 = "1l8z1daiq2x92449p2ciblcwl0ddgr3vqj2dsd3z8jj3y0z8j51s";
+  };
+
+  cargoSha256 = "0x3ay440vbc64y3pd8zhd119sw8fih0njmkzpr7r8wdw3k48v96m";
+
+  doCheck = false;
+
+  meta = with stdenv.lib; {
+    description = "du + rust = dust. Like du but more intuitive";
+    homepage = https://github.com/bootandy/dust;
+    license = licenses.asl20;
+    maintainers = [ maintainers.infinisil ];
+    platforms = platforms.all;
+  };
+}