summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2006-10-27 22:50:58 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2006-10-27 22:50:58 +0000
commitc37304db965298593e23169f18d94c02114330e5 (patch)
tree141043c48f6b5aa1b1ff82fee8dae5dbb299ce2a /pkgs/tools
parentde25bee83d1afee9867640e4fa4e46d82302c03a (diff)
downloadnixlib-c37304db965298593e23169f18d94c02114330e5.tar
nixlib-c37304db965298593e23169f18d94c02114330e5.tar.gz
nixlib-c37304db965298593e23169f18d94c02114330e5.tar.bz2
nixlib-c37304db965298593e23169f18d94c02114330e5.tar.lz
nixlib-c37304db965298593e23169f18d94c02114330e5.tar.xz
nixlib-c37304db965298593e23169f18d94c02114330e5.tar.zst
nixlib-c37304db965298593e23169f18d94c02114330e5.zip
* Oops, the bootstrap tools contained an impure gzip/gunzip.
* To prevent this kind of thing, check that all tools are statically
  linked.
* Use findutils 4.2.27, 4.2.28 doesn't build with dietlibc.

svn path=/nixpkgs/trunk/; revision=6881
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/findutils/4.2.27.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/pkgs/tools/misc/findutils/4.2.27.nix b/pkgs/tools/misc/findutils/4.2.27.nix
new file mode 100644
index 000000000000..80f5fbfc5d70
--- /dev/null
+++ b/pkgs/tools/misc/findutils/4.2.27.nix
@@ -0,0 +1,14 @@
+{stdenv, fetchurl, coreutils}:
+
+stdenv.mkDerivation {
+  name = "findutils-4.2.27";
+  src = fetchurl {
+    url = http://nix.cs.uu.nl/dist/tarballs/findutils-4.2.27.tar.gz;
+    md5 = "f1e0ddf09f28f8102ff3b90f3b5bc920";
+  };
+  buildInputs = [coreutils];
+  patches = [./findutils-path.patch]
+    # Note: the dietlibc is just to get findutils to compile.  The
+    # locate command probably won't work though.
+    ++ (if stdenv ? isDietLibC then [./dietlibc-hack.patch] else []);
+}