summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorlethalman <lucabru@src.gnome.org>2015-06-17 13:01:18 +0200
committerlethalman <lucabru@src.gnome.org>2015-06-17 13:01:18 +0200
commitc1f7f6df4cccfc8c1411482079d114d8926f0fd4 (patch)
treef640318ef79a7d2aaaefd671e47eb6153b9f8757 /pkgs/tools
parentfcd7b6829b4dee251b36153259d954c2731af0d7 (diff)
parentbb2d249706fd010c2850b159d701bbc4037fc23a (diff)
downloadnixlib-c1f7f6df4cccfc8c1411482079d114d8926f0fd4.tar
nixlib-c1f7f6df4cccfc8c1411482079d114d8926f0fd4.tar.gz
nixlib-c1f7f6df4cccfc8c1411482079d114d8926f0fd4.tar.bz2
nixlib-c1f7f6df4cccfc8c1411482079d114d8926f0fd4.tar.lz
nixlib-c1f7f6df4cccfc8c1411482079d114d8926f0fd4.tar.xz
nixlib-c1f7f6df4cccfc8c1411482079d114d8926f0fd4.tar.zst
nixlib-c1f7f6df4cccfc8c1411482079d114d8926f0fd4.zip
Merge pull request #8366 from andrewrk/rhash
expose librhash
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/security/rhash/default.nix19
1 files changed, 17 insertions, 2 deletions
diff --git a/pkgs/tools/security/rhash/default.nix b/pkgs/tools/security/rhash/default.nix
index 6a2710869bf8..643053d9cac9 100644
--- a/pkgs/tools/security/rhash/default.nix
+++ b/pkgs/tools/security/rhash/default.nix
@@ -1,7 +1,8 @@
 { stdenv, fetchurl }:
 
 stdenv.mkDerivation rec {
-  name = "rhash-1.3.3";
+  version = "1.3.3";
+  name = "rhash-${version}";
 
   src = fetchurl {
     url = "mirror://sourceforge/rhash/${name}-src.tar.gz";
@@ -10,9 +11,23 @@ stdenv.mkDerivation rec {
 
   installFlags = [ "DESTDIR=$(out)" "PREFIX=/" ];
 
+  # we build the static library because of two makefile bugs
+  # * .h files installed for static library target only
+  # * .so.0 -> .so link only created in the static library install target
+  buildPhase = ''
+    make lib-shared lib-static build-shared
+  '';
+
+  # we don't actually want the static library, so we remove it after it
+  # gets installed
+  installPhase = ''
+    make DESTDIR="$out" PREFIX="/" install-shared install-lib-shared install-lib-static
+    rm $out/lib/librhash.a
+  '';
+
   meta = with stdenv.lib; {
     homepage = http://rhash.anz.ru;
-    description = "Console utility for computing and verifying hash sums of files";
+    description = "Console utility and library for computing and verifying hash sums of files";
     platforms = platforms.linux;
   };
 }