summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorOrivej Desh <orivej@gmx.fr>2017-11-21 22:48:36 +0000
committerOrivej Desh <orivej@gmx.fr>2017-11-21 22:48:36 +0000
commitb8e1e7191e99af29125fbb37f42cb68f43af800c (patch)
tree1ca52bd4c93d50473ebdb7cebc7721140e84a924 /pkgs/tools
parent71a2a5ae40b2b94150365bb846fb78b620562df8 (diff)
parent91d2cf96424cc5209d3cf799bc2b4fa52af34596 (diff)
downloadnixlib-b8e1e7191e99af29125fbb37f42cb68f43af800c.tar
nixlib-b8e1e7191e99af29125fbb37f42cb68f43af800c.tar.gz
nixlib-b8e1e7191e99af29125fbb37f42cb68f43af800c.tar.bz2
nixlib-b8e1e7191e99af29125fbb37f42cb68f43af800c.tar.lz
nixlib-b8e1e7191e99af29125fbb37f42cb68f43af800c.tar.xz
nixlib-b8e1e7191e99af29125fbb37f42cb68f43af800c.tar.zst
nixlib-b8e1e7191e99af29125fbb37f42cb68f43af800c.zip
Merge branch 'master' into staging
* master: (80 commits)
  lkl: Supports aarch64
  wimlib: nitpicks
  gitAndTools.git-codeowners: 0.1.1 -> 0.1.2
  wimlib: init at 1.12.0
  kernel: improve modDirVersion error message
  releaseTools.sourceTarball: Clean up temporary files
  dotnetPackages.SmartIrc4net: rehash source
  migmix: make it a fixed-output derivation
  vm: Create /dev/full
  samba: 4.6.8 -> 4.6.11 to address CVEs CVE-2017-14746 & CVE-2017-15275
  microcodeIntel: 20170707 -> 20171117
  sshd: Remove ripemd160 MACs
  kernel config: Enable MEDIA_CONTROLLER
  linux: 4.4.99 -> 4.4.100
  linux: 4.9.63 -> 4.9.64
  nix-bash-completions: 0.4 -> 0.5
  linux: 4.14 -> 4.14.1
  linux: 4.13.14 -> 4.13.15
  nix-zsh-completions: 0.3.3 -> 0.3.5
  dns-root-data: use a stable URL that I maintain anyway
  ...
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/archivers/wimlib/default.nix48
-rw-r--r--pkgs/tools/backup/rdedup/default.nix25
-rw-r--r--pkgs/tools/filesystems/glusterfs/default.nix4
-rw-r--r--pkgs/tools/misc/mlocate/default.nix4
-rw-r--r--pkgs/tools/misc/screenfetch/default.nix28
-rw-r--r--pkgs/tools/security/opencryptoki/default.nix43
-rw-r--r--pkgs/tools/security/simple-tpm-pk11/default.nix26
-rw-r--r--pkgs/tools/text/languagetool/default.nix41
8 files changed, 152 insertions, 67 deletions
diff --git a/pkgs/tools/archivers/wimlib/default.nix b/pkgs/tools/archivers/wimlib/default.nix
new file mode 100644
index 000000000000..dbf3d91f37aa
--- /dev/null
+++ b/pkgs/tools/archivers/wimlib/default.nix
@@ -0,0 +1,48 @@
+{ stdenv, fetchurl, makeWrapper
+, pkgconfig, openssl, fuse, libxml2
+, cabextract ? null
+, cdrkit ? null
+, mtools ? null
+, ntfs3g ? null
+, syslinux ? null
+}:
+
+stdenv.mkDerivation rec {
+  version = "1.12.0";
+  name = "wimlib-${version}";
+
+  nativeBuildInputs = [ pkgconfig makeWrapper ];
+  buildInputs = [ openssl fuse libxml2 ntfs3g ];
+
+  src = fetchurl {
+    url = "https://wimlib.net/downloads/${name}.tar.gz";
+    sha256 = "852cf59d682a91974f715f09fa98cab621b740226adcfea7a42360be0f86464f";
+  };
+
+  preBuild = ''
+    substituteInPlace programs/mkwinpeimg.in \
+      --replace '/usr/lib/syslinux' "${syslinux}/share/syslinux"
+  '';
+
+  postInstall = let
+    path = stdenv.lib.makeBinPath  [ cabextract cdrkit mtools ntfs3g syslinux ];
+  in ''
+    for prog in $out/bin/*; do
+      wrapProgram $prog --prefix PATH : ${path}
+    done
+  '';
+
+  doCheck = true;
+
+  preCheck = ''
+    patchShebangs tests
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = https://wimlib.net;
+    description = "A library and program to extract, create, and modify WIM files";
+    platforms = platforms.unix;
+    maintainers = with maintainers; [ andir ];
+    license = with licenses; [ gpl3 lgpl3 cc0 ];
+  };
+}
diff --git a/pkgs/tools/backup/rdedup/default.nix b/pkgs/tools/backup/rdedup/default.nix
new file mode 100644
index 000000000000..2da943540192
--- /dev/null
+++ b/pkgs/tools/backup/rdedup/default.nix
@@ -0,0 +1,25 @@
+{ stdenv, fetchFromGitHub, rustPlatform, pkgconfig, libsodium, lzma }:
+
+rustPlatform.buildRustPackage rec {
+  name = "rdedup-${version}";
+  version = "2.0.0";
+
+  src = fetchFromGitHub {
+    owner = "dpc";
+    repo = "rdedup";
+    rev = "v${version}";
+    sha256 = "14r6x1wi5mwadarm0vp6qnr5mykv4g0kxz9msq76fhwghwb9k1d9";
+  };
+
+  buildInputs = [ pkgconfig libsodium lzma ];
+
+  cargoSha256 = "0wyswc4b4hkiw20gz0w94vv1qgcb2zq0cdaj9zxvyr5l0abxip9w";
+
+  meta = with stdenv.lib; {
+    description = "Data deduplication with compression and public key encryption";
+    homepage = https://github.com/dpc/rdedup;
+    license = licenses.mpl20;
+    maintainers = with maintainers; [ dywedir ];
+    platforms = platforms.all;
+  };
+}
diff --git a/pkgs/tools/filesystems/glusterfs/default.nix b/pkgs/tools/filesystems/glusterfs/default.nix
index dc15866f3cda..87356fd34838 100644
--- a/pkgs/tools/filesystems/glusterfs/default.nix
+++ b/pkgs/tools/filesystems/glusterfs/default.nix
@@ -15,10 +15,10 @@ let
     #       The command
     #         find /nix/store/...-glusterfs-.../ -name '*.py' -executable
     #       can help with finding new Python scripts.
-    version = "3.12.1";
+    version = "3.12.3";
     name="${baseName}-${version}";
     url="https://github.com/gluster/glusterfs/archive/v${version}.tar.gz";
-    sha256 = "14l6p2zyjsrnjvf0lipq32p517zk813nqv06pjq6kcqkmy038wdv";
+    sha256 = "16ra4qr4ds011mmxaqdhdj7slcx8yv0xh6ww7bwsz7f1gn9sr10h";
   };
   buildInputs = [
     fuse bison flex_2_5_35 openssl ncurses readline
diff --git a/pkgs/tools/misc/mlocate/default.nix b/pkgs/tools/misc/mlocate/default.nix
index 4aef6114c57c..baf418ac9f04 100644
--- a/pkgs/tools/misc/mlocate/default.nix
+++ b/pkgs/tools/misc/mlocate/default.nix
@@ -7,7 +7,7 @@ in stdenv.mkDerivation rec {
   version = "0.26";
 
   src = fetchurl {
-    url = "http://fedorahosted.org/releases/m/l/mlocate/${name}.tar.xz";
+    url = "https://releases.pagure.org/mlocate/${name}.tar.xz";
     sha256 = "0gi6y52gkakhhlnzy0p6izc36nqhyfx5830qirhvk3qrzrwxyqrh";
   };
 
@@ -16,7 +16,7 @@ in stdenv.mkDerivation rec {
 
   meta = with stdenv.lib; {
     description = "Merging locate is an utility to index and quickly search for files";
-    homepage = https://fedorahosted.org/mlocate/;
+    homepage = https://pagure.io/mlocate;
     license = licenses.gpl2;
     platforms = platforms.linux;
     maintainers = with maintainers; [ ];
diff --git a/pkgs/tools/misc/screenfetch/default.nix b/pkgs/tools/misc/screenfetch/default.nix
index 352fee14fa61..9ef0c9ebdf7d 100644
--- a/pkgs/tools/misc/screenfetch/default.nix
+++ b/pkgs/tools/misc/screenfetch/default.nix
@@ -1,5 +1,6 @@
-{ stdenv, fetchFromGitHub, makeWrapper, coreutils, gawk, procps, gnused
+{ stdenv, lib, fetchFromGitHub, makeWrapper, coreutils, gawk, procps, gnused
 , bc, findutils, xdpyinfo, xprop, gnugrep, ncurses
+, darwin
 }:
 
 stdenv.mkDerivation {
@@ -21,13 +22,22 @@ stdenv.mkDerivation {
     # Fix all of the depedencies of screenfetch
     patchShebangs $out/bin/screenfetch
     wrapProgram "$out/bin/screenfetch" \
-      --set PATH ${stdenv.lib.makeBinPath [
-        coreutils gawk procps gnused findutils xdpyinfo
-        xprop gnugrep ncurses bc
-      ]}
+      --set PATH ${lib.makeBinPath ([
+        coreutils gawk gnused findutils
+        gnugrep ncurses bc
+      ] ++ lib.optionals stdenv.isLinux [
+        procps
+        xdpyinfo
+        xprop
+      ] ++ lib.optionals stdenv.isDarwin (with darwin; [
+        adv_cmds
+        DarwinTools
+        system_cmds
+        "/usr" # some commands like defaults is not available to us
+      ]))}
   '';
 
-  meta = {
+  meta = with lib; {
     description = "Fetches system/theme information in terminal for Linux desktop screenshots";
     longDescription = ''
     screenFetch is a "Bash Screenshot Information Tool". This handy Bash
@@ -39,9 +49,9 @@ stdenv.mkDerivation {
     screenshot upon displaying info, and even customizing the screenshot
     command! This script is very easy to add to and can easily be extended.
     '';
-    license = stdenv.lib.licenses.gpl3;
+    license = licenses.gpl3;
     homepage = http://git.silverirc.com/cgit.cgi/screenfetch-dev.git/;
-    maintainers = with stdenv.lib.maintainers; [relrod];
-    platforms = stdenv.lib.platforms.all;
+    maintainers = with maintainers; [relrod];
+    platforms = platforms.all;
   };
 }
diff --git a/pkgs/tools/security/opencryptoki/default.nix b/pkgs/tools/security/opencryptoki/default.nix
index 9ea9c2f4892b..f2929f3e22b4 100644
--- a/pkgs/tools/security/opencryptoki/default.nix
+++ b/pkgs/tools/security/opencryptoki/default.nix
@@ -1,38 +1,41 @@
-{ stdenv, fetchurl, openssl, trousers, automake, autoconf, libtool, bison, flex }:
+{ stdenv, fetchFromGitHub, openssl, trousers, autoreconfHook, libtool, bison, flex }:
 
 stdenv.mkDerivation rec {
-  version = "3.2";
   name = "opencryptoki-${version}";
+  version = "3.8.1";
 
-  src = fetchurl {
-    url = "mirror://sourceforge/opencryptoki/opencryptoki/v${version}/opencryptoki-v${version}.tgz";
-    sha256 = "06r6zp299vxdspl6k65myzgjv0bihg7kc500v7s4jd3mcrkngd6h";
+  src = fetchFromGitHub {
+    owner = "opencryptoki";
+    repo = "opencryptoki";
+    rev = "v${version}";
+    sha256 = "1m618pjfzw18irmh6i4pfq1gvcxgyfh9ikjn33nrdj55v2l27g31";
   };
 
-  buildInputs = [ automake autoconf libtool openssl trousers bison flex ];
+  nativeBuildInputs = [ autoreconfHook libtool bison flex ];
+  buildInputs = [ openssl trousers ];
 
-  preConfigure = ''
-    substituteInPlace configure.in --replace "chown" "true"
-    substituteInPlace configure.in --replace "chgrp" "true"
-    sh bootstrap.sh --prefix=$out
+  postPatch = ''
+    substituteInPlace configure.ac \
+      --replace "usermod" "true" \
+      --replace "groupadd" "true" \
+      --replace "chmod" "true" \
+      --replace "chgrp" "true"
+    substituteInPlace usr/lib/Makefile.am --replace "DESTDIR" "out"
   '';
 
-  configureFlags = [ "--disable-ccatok" "--disable-icatok" ];
+  configureFlags = [
+    "--prefix=$(out)"
+    "--disable-ccatok"
+    "--disable-icatok"
+  ];
 
-  makeFlags = "DESTDIR=$(out)";
-
-  # work around the build script of opencryptoki
-  postInstall = ''
-    cp -r $out/$out/* $out
-    rm -r $out/nix
-    '';
+  enableParallelBuilding = true;
 
   meta = with stdenv.lib; {
     description = "PKCS#11 implementation for Linux";
-    homepage    = http://opencryptoki.sourceforge.net/;
+    homepage    = https://github.com/opencryptoki/opencryptoki;
     license     = licenses.cpl10;
     maintainers = [ maintainers.tstrobel ];
     platforms   = platforms.unix;
   };
 }
-
diff --git a/pkgs/tools/security/simple-tpm-pk11/default.nix b/pkgs/tools/security/simple-tpm-pk11/default.nix
index 75886399fdc5..96565ec84b52 100644
--- a/pkgs/tools/security/simple-tpm-pk11/default.nix
+++ b/pkgs/tools/security/simple-tpm-pk11/default.nix
@@ -1,27 +1,29 @@
-{ stdenv, fetchgit, trousers, openssl, opencryptoki, automake, autoconf, libtool }:
+{ stdenv, fetchFromGitHub, trousers, openssl, opencryptoki, autoreconfHook, libtool }:
 
 stdenv.mkDerivation rec {
-  name = "simple-tpm-pk11-2016-07-12";
+  name = "simple-tpm-pk11-${version}";
+  version = "0.06";
 
-  src = fetchgit {
-    url = "https://github.com/ThomasHabets/simple-tpm-pk11";
-    rev = "6f1f7a6b96ac82965e977cfecb88d930f1d70243";
-    sha256 = "06vf3djp29slh7hrh4hlh3npyl277fy7d77jv9mxa1sk1idjklxc";
+  src = fetchFromGitHub {
+    owner = "ThomasHabets";
+    repo = "simple-tpm-pk11";
+    rev = version;
+    sha256 = "0vpbaklr4r1a2am0pqcm6m41ph22mkcrq33y8ab5h8qkhkvhd6a6";
   };
 
-  buildInputs = [ trousers openssl opencryptoki automake autoconf libtool ];
+  nativeBuildInputs = [ autoreconfHook libtool ];
+  buildInputs = [ trousers openssl opencryptoki ];
 
-  preConfigure = "sh bootstrap.sh";
+  enableParallelBuilding = true;
 
   meta = with stdenv.lib; {
     description = "Simple PKCS11 provider for TPM chips";
     longDescription = ''
       A simple library for using the TPM chip to secure SSH keys.
-      '';
+    '';
     homepage    = https://github.com/ThomasHabets/simple-tpm-pk11;
-    license     = stdenv.lib.licenses.asl20;
-    maintainers = with stdenv.lib; [ maintainers.tstrobel ];
+    license     = licenses.asl20;
+    maintainers = with maintainers; [ tstrobel ];
     platforms   = platforms.unix;
   };
 }
-
diff --git a/pkgs/tools/text/languagetool/default.nix b/pkgs/tools/text/languagetool/default.nix
index 4f3f8af3256d..6fcfd6fff85f 100644
--- a/pkgs/tools/text/languagetool/default.nix
+++ b/pkgs/tools/text/languagetool/default.nix
@@ -1,30 +1,27 @@
-{ stdenv, lib, fetchurl, unzip, jdk }:
+{ stdenv, fetchzip, jre, makeWrapper }:
 
 stdenv.mkDerivation rec {
-  pname = "LanguageTool";
-  version = "3.7";
-  name = pname + "-" + version;
-  src = fetchurl {
+  name = "LanguageTool-${version}";
+  version = "3.9";
+
+  src = fetchzip {
     url = "https://www.languagetool.org/download/${name}.zip";
-    sha256 = "04i49z022k3nyyr8hnlxima9k5id8qvh2nr3dv8zgcqm5sin6xx9";
+    sha256 = "0hqb4hbl7iryw1xk8q1i606azzgzdr17sy6xfr1zpas4r2pnvhfq";
   };
-  buildInputs = [ unzip jdk ];
-  installPhase =
-  ''
-    mkdir -p $out/{bin,share}
-    mv * $out/share/.
+  nativeBuildInputs = [ makeWrapper ];
+  buildInputs = [ jre ];
+
+  installPhase = ''
+    mkdir -p $out/share
+    mv * $out/share/
+
     for lt in languagetool{,-commandline,-server};do
-    cat > $out/bin/$lt <<EXE
-    #!${stdenv.shell}
-    ${jdk}/bin/java -cp $out/share/ -jar $out/share/$lt.jar "\$@"
-    EXE
-    chmod +x $out/bin/$lt
+      makeWrapper ${jre}/bin/java $out/bin/$lt \
+        --add-flags "-cp $out/share/ -jar $out/share/$lt.jar"
     done
-    cat > $out/bin/languagetool-http-server <<EXE
-    #!${stdenv.shell}
-    ${jdk}/bin/java -cp $out/share/languagetool-server.jar org.languagetool.server.HTTPServer "\$@"
-    EXE
-    chmod +x $out/bin/languagetool-http-server
+
+    makeWrapper ${jre}/bin/java $out/bin/languagetool-http-server \
+      --add-flags "-cp $out/share/languagetool-server.jar org.languagetool.server.HTTPServer"
   '';
 
   meta = with stdenv.lib; {
@@ -34,6 +31,6 @@ stdenv.mkDerivation rec {
       edwtjo
       jgeerds
     ];
-    descrption = "A proofreading program for English, French German, Polish, and more";
+    description = "A proofreading program for English, French German, Polish, and more";
   };
 }