summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2015-06-08 11:48:41 +0200
committerPeter Simons <simons@cryp.to>2015-06-08 11:48:41 +0200
commitb5f868f48ba24b4987071633fdfefd62d17acc12 (patch)
treebda7d53adfe4d36251cc432e27ec20409f54ed0b /pkgs/tools
parent50e9fa5719b233c6c679033871a20427fd619949 (diff)
parentd3435d7ce006436a4056d0800083daffbfa8bca6 (diff)
downloadnixlib-b5f868f48ba24b4987071633fdfefd62d17acc12.tar
nixlib-b5f868f48ba24b4987071633fdfefd62d17acc12.tar.gz
nixlib-b5f868f48ba24b4987071633fdfefd62d17acc12.tar.bz2
nixlib-b5f868f48ba24b4987071633fdfefd62d17acc12.tar.lz
nixlib-b5f868f48ba24b4987071633fdfefd62d17acc12.tar.xz
nixlib-b5f868f48ba24b4987071633fdfefd62d17acc12.tar.zst
nixlib-b5f868f48ba24b4987071633fdfefd62d17acc12.zip
Merge pull request #8150 from ts468/upstream.calamares
Add Calamares: A distribution independent installer framework.
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/calamares/default.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/pkgs/tools/misc/calamares/default.nix b/pkgs/tools/misc/calamares/default.nix
new file mode 100644
index 000000000000..c8fe39f6a7a9
--- /dev/null
+++ b/pkgs/tools/misc/calamares/default.nix
@@ -0,0 +1,35 @@
+{ stdenv, fetchgit, cmake, qt5, polkit_qt5, libyamlcpp, python, boost, parted
+, extra-cmake-modules, kconfig, ki18n, kcoreaddons, solid, utillinux, libatasmart }:
+
+stdenv.mkDerivation rec {
+  name = "calamares-${version}";
+  version = "1.0";
+
+  src = fetchgit {
+    url = "https://github.com/calamares/calamares.git";
+    rev = "dabfb68a68cb012a90cd7b94a22e1ea08f7dd8ad";
+    sha256 = "2851ce487aaac61d2df342a47f91ec87fe52ff036227ef697caa7056fe5f188c";
+  };
+
+  buildInputs = [
+    cmake qt5.base qt5.tools libyamlcpp python boost polkit_qt5 parted
+    extra-cmake-modules kconfig ki18n kcoreaddons solid utillinux libatasmart
+  ];
+
+  cmakeFlags = [
+    "-DPYTHON_LIBRARY=${python}/lib/libpython${python.majorVersion}m.so"
+    "-DPYTHON_INCLUDE_DIR=${python}/include/python${python.majorVersion}m"
+    "-DWITH_PARTITIONMANAGER=1"
+  ];
+
+  preInstall = ''
+    substituteInPlace cmake_install.cmake --replace "${polkit_qt5}" "$out"
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Distribution-independent installer framework";
+    license = licenses.gpl3;
+    maintainers = with stdenv.lib.maintainers; [ tstrobel ];
+    platforms = platforms.linux;
+  };
+}