summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2017-07-29 13:08:11 +0200
committerFrederik Rietdijk <fridh@fridh.nl>2017-07-29 13:08:11 +0200
commitb2608b891062dcc95e50f00c304b297a727adf97 (patch)
tree8b5c8773a75724455e3b67cb563ea84b0f9ec5e5 /pkgs/tools
parent55357de67a2acfb11ba1a3633454c20acc9b54e7 (diff)
parent140f47eb748f9b24a77fa40a1f1ffd2376a24b81 (diff)
downloadnixlib-b2608b891062dcc95e50f00c304b297a727adf97.tar
nixlib-b2608b891062dcc95e50f00c304b297a727adf97.tar.gz
nixlib-b2608b891062dcc95e50f00c304b297a727adf97.tar.bz2
nixlib-b2608b891062dcc95e50f00c304b297a727adf97.tar.lz
nixlib-b2608b891062dcc95e50f00c304b297a727adf97.tar.xz
nixlib-b2608b891062dcc95e50f00c304b297a727adf97.tar.zst
nixlib-b2608b891062dcc95e50f00c304b297a727adf97.zip
Merge remote-tracking branch 'upstream/master' into HEAD
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/admin/cli53/default.nix17
1 files changed, 14 insertions, 3 deletions
diff --git a/pkgs/tools/admin/cli53/default.nix b/pkgs/tools/admin/cli53/default.nix
index 23c35dab57c0..b9852ed587c5 100644
--- a/pkgs/tools/admin/cli53/default.nix
+++ b/pkgs/tools/admin/cli53/default.nix
@@ -1,6 +1,6 @@
-{ lib, python2Packages, fetchurl }:
+{ lib, python2, fetchurl }:
 
-python2Packages.buildPythonApplication rec {
+python2.pkgs.buildPythonApplication rec {
   name = "cli53-${version}";
   version = "0.4.4";
 
@@ -9,7 +9,18 @@ python2Packages.buildPythonApplication rec {
     sha256 = "0s9jzigq6a16m2c3qklssx2lz16cf13g5zh80vh24kxazaxqzbig";
   };
 
-  propagatedBuildInputs = with python2Packages; [
+  postPatch = ''
+    substituteInPlace setup.py --replace "'argparse', " ""
+  '';
+
+  checkPhase = ''
+    ${python2.interpreter} -m unittest discover -s tests
+  '';
+
+  # Tests do not function
+  doCheck = false;
+
+  propagatedBuildInputs = with python2.pkgs; [
     argparse
     boto
     dns