summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorJohn Ericson <Ericson2314@yahoo.com>2017-12-29 17:30:18 -0500
committerGitHub <noreply@github.com>2017-12-29 17:30:18 -0500
commitb1dcc6c2012ef2190caf30043af457c15253abcd (patch)
treee86961af5d8e28f4fff87da964fc2f40005bcdb3 /pkgs/tools
parent4d3282f71efb30538b8c8a3fda19db26e7c1f307 (diff)
parent5dea877368227d818cccab3a1380322a2ba83aa0 (diff)
downloadnixlib-b1dcc6c2012ef2190caf30043af457c15253abcd.tar
nixlib-b1dcc6c2012ef2190caf30043af457c15253abcd.tar.gz
nixlib-b1dcc6c2012ef2190caf30043af457c15253abcd.tar.bz2
nixlib-b1dcc6c2012ef2190caf30043af457c15253abcd.tar.lz
nixlib-b1dcc6c2012ef2190caf30043af457c15253abcd.tar.xz
nixlib-b1dcc6c2012ef2190caf30043af457c15253abcd.tar.zst
nixlib-b1dcc6c2012ef2190caf30043af457c15253abcd.zip
Merge pull request #33185 from obsidiansystems/cross-simple
treewide: A few misc cross changes from #26805
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/colord-kde/default.nix4
-rw-r--r--pkgs/tools/text/diffutils/default.nix3
-rw-r--r--pkgs/tools/text/gawk/default.nix2
3 files changed, 6 insertions, 3 deletions
diff --git a/pkgs/tools/misc/colord-kde/default.nix b/pkgs/tools/misc/colord-kde/default.nix
index a91cd627bdae..12821cf864c2 100644
--- a/pkgs/tools/misc/colord-kde/default.nix
+++ b/pkgs/tools/misc/colord-kde/default.nix
@@ -14,11 +14,11 @@ stdenv.mkDerivation rec {
     sha256 = "0brdnpflm95vf4l41clrqxwvjrdwhs859n7401wxcykkmw4m0m3c";
   };
 
-  nativeBuildInputs = [ extra-cmake-modules ki18n ];
+  nativeBuildInputs = [ extra-cmake-modules ];
 
   buildInputs = [
     kconfig kconfigwidgets kcoreaddons kdbusaddons kiconthemes
-    kcmutils kio knotifications plasma-framework kwidgetsaddons
+    kcmutils ki18n kio knotifications plasma-framework kwidgetsaddons
     kwindowsystem kitemviews lcms2 libXrandr qtx11extras
   ];
 
diff --git a/pkgs/tools/text/diffutils/default.nix b/pkgs/tools/text/diffutils/default.nix
index cd64bd1566b5..60628e2139ce 100644
--- a/pkgs/tools/text/diffutils/default.nix
+++ b/pkgs/tools/text/diffutils/default.nix
@@ -17,7 +17,8 @@ stdenv.mkDerivation rec {
   configureFlags =
     # "pr" need not be on the PATH as a run-time dep, so we need to tell
     # configure where it is. Covers the cross and native case alike.
-    stdenv.lib.optional (coreutils != null) "PR_PROGRAM=${coreutils}/bin/pr";
+    stdenv.lib.optional (coreutils != null) "PR_PROGRAM=${coreutils}/bin/pr"
+    ++ stdenv.lib.optional (stdenv.buildPlatform != stdenv.hostPlatform) "gl_cv_func_getopt_gnu=yes";
 
   meta = {
     homepage = http://www.gnu.org/software/diffutils/diffutils.html;
diff --git a/pkgs/tools/text/gawk/default.nix b/pkgs/tools/text/gawk/default.nix
index 65d0a1e4c00a..6783158ca77e 100644
--- a/pkgs/tools/text/gawk/default.nix
+++ b/pkgs/tools/text/gawk/default.nix
@@ -41,6 +41,8 @@ stdenv.mkDerivation rec {
     (if interactive then "--with-readline=${readline.dev}" else "--without-readline")
   ];
 
+  makeFlags = "AR=${stdenv.cc.targetPrefix}ar";
+
   inherit doCheck;
 
   postInstall = ''