summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2015-03-02 20:10:07 -0800
committerWilliam A. Kennington III <william@wkennington.com>2015-03-02 20:10:07 -0800
commitadbba6ededdab676f08b63c1f671e49c3311ba25 (patch)
tree854213ecef735a338f16af8b3468efe22cb85915 /pkgs/tools
parentc4f63311d49a211566122a0af2fd209d28c24049 (diff)
parente29b0da9c7492732e0dc5730c3da754baa57a1a2 (diff)
downloadnixlib-adbba6ededdab676f08b63c1f671e49c3311ba25.tar
nixlib-adbba6ededdab676f08b63c1f671e49c3311ba25.tar.gz
nixlib-adbba6ededdab676f08b63c1f671e49c3311ba25.tar.bz2
nixlib-adbba6ededdab676f08b63c1f671e49c3311ba25.tar.lz
nixlib-adbba6ededdab676f08b63c1f671e49c3311ba25.tar.xz
nixlib-adbba6ededdab676f08b63c1f671e49c3311ba25.tar.zst
nixlib-adbba6ededdab676f08b63c1f671e49c3311ba25.zip
Merge pull request #6528 from codyopel/stdenv-fixes
remove stdenv.isBSD
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/archivers/sharutils/default.nix6
-rw-r--r--pkgs/tools/archivers/zpaq/default.nix4
-rw-r--r--pkgs/tools/archivers/zpaq/zpaqd.nix4
-rw-r--r--pkgs/tools/system/tree/default.nix10
4 files changed, 10 insertions, 14 deletions
diff --git a/pkgs/tools/archivers/sharutils/default.nix b/pkgs/tools/archivers/sharutils/default.nix
index 0d56e79d0248..146f9bea87a0 100644
--- a/pkgs/tools/archivers/sharutils/default.nix
+++ b/pkgs/tools/archivers/sharutils/default.nix
@@ -12,7 +12,7 @@ stdenv.mkDerivation rec {
     ''
        # Fix for building on Glibc 2.16.  Won't be needed once the
        # gnulib in sharutils is updated.
-       sed -i ${stdenv.lib.optionalString (stdenv.isBSD && stdenv.cc.nativeTools) "''"} '/gets is a security hole/d' lib/stdio.in.h
+       sed -i ${stdenv.lib.optionalString ((stdenv.isFreeBSD || stdenv.isOpenBSD || stdenv.isDarwin) && stdenv.cc.nativeTools) "''"} '/gets is a security hole/d' lib/stdio.in.h
     '';
 
   # GNU Gettext is needed on non-GNU platforms.
@@ -26,7 +26,6 @@ stdenv.mkDerivation rec {
 
   meta = {
     description = "Tools for remote synchronization and `shell archives'";
-
     longDescription =
       '' GNU shar makes so-called shell archives out of many files, preparing
          them for transmission by electronic mail services.  A shell archive
@@ -43,11 +42,8 @@ stdenv.mkDerivation rec {
          by a copy of the shell. unshar may also process files containing
          concatenated shell archives.
       '';
-
     homepage = http://www.gnu.org/software/sharutils/;
-
     license = stdenv.lib.licenses.gpl3Plus;
-
     maintainers = [ ];
     platforms = stdenv.lib.platforms.all;
   };
diff --git a/pkgs/tools/archivers/zpaq/default.nix b/pkgs/tools/archivers/zpaq/default.nix
index 405264c6f663..6812859072d0 100644
--- a/pkgs/tools/archivers/zpaq/default.nix
+++ b/pkgs/tools/archivers/zpaq/default.nix
@@ -1,4 +1,4 @@
-{stdenv, fetchurl, unzip}:
+{ stdenv, fetchurl, unzip }:
 let
   s = # Generated upstream information
   rec {
@@ -12,7 +12,7 @@ let
   buildInputs = [
     unzip
   ];
-  isUnix = stdenv.isLinux || stdenv.isGNU || stdenv.isDarwin || stdenv.isBSD;
+  isUnix = with stdenv; isLinux || isGNU || isDarwin || isFreeBSD || isOpenBSD;
   isx86 = stdenv.isi686 || stdenv.isx86_64;
   compileFlags = ""
     + (stdenv.lib.optionalString isUnix " -Dunix -pthread ")
diff --git a/pkgs/tools/archivers/zpaq/zpaqd.nix b/pkgs/tools/archivers/zpaq/zpaqd.nix
index cfb76d2ff9bf..65f40f68f550 100644
--- a/pkgs/tools/archivers/zpaq/zpaqd.nix
+++ b/pkgs/tools/archivers/zpaq/zpaqd.nix
@@ -1,4 +1,4 @@
-{stdenv, fetchurl, unzip}:
+{ stdenv, fetchurl, unzip }:
 let
   s = # Generated upstream information
   rec {
@@ -12,7 +12,7 @@ let
   buildInputs = [
     unzip
   ];
-  isUnix = stdenv.isLinux || stdenv.isGNU || stdenv.isDarwin || stdenv.isBSD;
+  isUnix = with stdenv; isLinux || isGNU || isDarwin || isFreeBSD || isOpenBSD;
   isx86 = stdenv.isi686 || stdenv.isx86_64;
   compileFlags = ""
     + (stdenv.lib.optionalString isUnix " -Dunix -pthread ")
diff --git a/pkgs/tools/system/tree/default.nix b/pkgs/tools/system/tree/default.nix
index 165eb316a928..02834b70d629 100644
--- a/pkgs/tools/system/tree/default.nix
+++ b/pkgs/tools/system/tree/default.nix
@@ -1,4 +1,4 @@
-{stdenv, fetchurl}:
+{ stdenv, fetchurl }:
 
 let
   version = "1.7.0";
@@ -6,17 +6,17 @@ let
   # These settings are found in the Makefile, but there seems to be no
   # way to select one ore the other setting other than editing the file
   # manually, so we have to duplicate the know how here.
-  systemFlags =
-    if stdenv.isDarwin then ''
+  systemFlags = with stdenv;
+    if isDarwin then ''
       CFLAGS="-O2 -Wall -fomit-frame-pointer"
       LDFLAGS=
       EXTRA_OBJS=strverscmp.o
-    '' else if stdenv.isCygwin then ''
+    '' else if isCygwin then ''
       CFLAGS="-O2 -Wall -fomit-frame-pointer -DCYGWIN"
       LDFLAGS=-s
       TREE_DEST=tree.exe
       EXTRA_OBJS=strverscmp.o
-    '' else if stdenv.isBSD then ''
+    '' else if (isFreeBSD || isOpenBSD) then ''
       CFLAGS="-O2 -Wall -fomit-frame-pointer"
       LDFLAGS=-s
       EXTRA_OBJS=strverscmp.o