summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2013-02-21 11:13:30 -0500
committerShea Levy <shea@shealevy.com>2013-02-21 11:13:30 -0500
commitacd4299e75a167a79521d76a1d312ca1cd8df92e (patch)
tree4afeb7749025dabe55f3aa8f18a397384daa6595 /pkgs/tools
parentaacca1902cbb7117d978199323cf7bc1ffa4ee97 (diff)
parent9cff61881d7391c92000eb83f94b515f763edbf9 (diff)
downloadnixlib-acd4299e75a167a79521d76a1d312ca1cd8df92e.tar
nixlib-acd4299e75a167a79521d76a1d312ca1cd8df92e.tar.gz
nixlib-acd4299e75a167a79521d76a1d312ca1cd8df92e.tar.bz2
nixlib-acd4299e75a167a79521d76a1d312ca1cd8df92e.tar.lz
nixlib-acd4299e75a167a79521d76a1d312ca1cd8df92e.tar.xz
nixlib-acd4299e75a167a79521d76a1d312ca1cd8df92e.tar.zst
nixlib-acd4299e75a167a79521d76a1d312ca1cd8df92e.zip
Merge branch 'master' into stdenv-updates
Conflicts:
	pkgs/applications/networking/browsers/chromium/default.nix
	pkgs/top-level/all-packages.nix

Merge conflicts seemed trivial, but a look from viric and aszlig would be nice.
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/filesystems/davfs2/default.nix27
-rw-r--r--pkgs/tools/filesystems/davfs2/fix-sysconfdir.patch60
-rw-r--r--pkgs/tools/networking/snx/default.nix40
-rwxr-xr-xpkgs/tools/networking/snx/snx_install.shbin0 -> 965717 bytes
4 files changed, 117 insertions, 10 deletions
diff --git a/pkgs/tools/filesystems/davfs2/default.nix b/pkgs/tools/filesystems/davfs2/default.nix
index ce4421f9ca7f..d16af28010c2 100644
--- a/pkgs/tools/filesystems/davfs2/default.nix
+++ b/pkgs/tools/filesystems/davfs2/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, neon, zlib, noDavsUser ? false}:
+{ stdenv, fetchurl, neon, zlib }:
 
 stdenv.mkDerivation rec {
   name = "davfs2-1.4.7";
@@ -8,19 +8,26 @@ stdenv.mkDerivation rec {
     sha256 = "0i7hrwlfzisb4l2mza1kjj9q9xxixggjplsjm339zl7828mfxh2h";
   };
 
-  prePatch = stdenv.lib.optional noDavsUser ''
-    echo "dav_user root" >> etc/davfs2.conf
-    echo "dav_group root" >> etc/davfs2.conf
-  '';
-
   buildInputs = [ neon zlib ];
 
-  patches = [ ./davfs2-install.patch ./isdir.patch ];
+  patches = [ ./davfs2-install.patch ./isdir.patch ./fix-sysconfdir.patch ];
+
+  configureFlags = "--sysconfdir=/etc";
 
   meta = {
-    longDescription = "Web Distributed Authoring and Versioning (WebDAV), an extension to the HTTP-protocol, allows authoring of resources on a remote web server. davfs2 provides the ability to access such resources like a typical filesystem, allowing for use by standard applications with no built-in support for WebDAV.";
+    homepage = "http://savannah.nongnu.org/projects/davfs2";
+    description = "mount WebDAV shares like a typical filesystem";
+    license = stdenv.lib.licenses.gpl3Plus;
+
+    longDescription = ''
+      Web Distributed Authoring and Versioning (WebDAV), an extension to
+      the HTTP-protocol, allows authoring of resources on a remote web
+      server. davfs2 provides the ability to access such resources like
+      a typical filesystem, allowing for use by standard applications
+      with no built-in support for WebDAV.
+    '';
 
-    license = "GPLv3+";
-    homepage = http://savannah.nongnu.org/projects/davfs2;
+    platforms = stdenv.lib.platforms.linux;
+    maintainers = [ stdenv.lib.maintainers.simons ];
   };
 }
diff --git a/pkgs/tools/filesystems/davfs2/fix-sysconfdir.patch b/pkgs/tools/filesystems/davfs2/fix-sysconfdir.patch
new file mode 100644
index 000000000000..f71248a28f4d
--- /dev/null
+++ b/pkgs/tools/filesystems/davfs2/fix-sysconfdir.patch
@@ -0,0 +1,60 @@
+diff -ubr davfs2-1.4.7-orig/etc/Makefile.am davfs2-1.4.7/etc/Makefile.am
+--- davfs2-1.4.7-orig/etc/Makefile.am	2013-02-21 11:45:00.185763558 +0100
++++ davfs2-1.4.7/etc/Makefile.am	2013-02-21 11:53:05.423197775 +0100
+@@ -24,17 +24,17 @@
+ 
+ install-data-local: $(dist_pkgdata_DATA)
+ 	@$(NORMAL_INSTALL)
+-	$(mkinstalldirs) $(DESTDIR)$(pkgsysconfdir)
+-	$(INSTALL_DATA) -b davfs2.conf $(DESTDIR)$(pkgsysconfdir)/davfs2.conf
+-	$(INSTALL_DATA) -b -m 600 secrets $(DESTDIR)$(pkgsysconfdir)/secrets
+-	$(mkinstalldirs) $(DESTDIR)$(pkgsysconfdir)/certs
+-	$(mkinstalldirs) $(DESTDIR)$(pkgsysconfdir)/certs/private
+-	chmod 700 $(DESTDIR)$(pkgsysconfdir)/certs/private
++	$(mkinstalldirs) $(out)$(pkgsysconfdir)
++	$(INSTALL_DATA) -b davfs2.conf $(out)$(pkgsysconfdir)/davfs2.conf
++	$(INSTALL_DATA) -b -m 600 secrets $(out)$(pkgsysconfdir)/secrets
++	$(mkinstalldirs) $(out)$(pkgsysconfdir)/certs
++	$(mkinstalldirs) $(out)$(pkgsysconfdir)/certs/private
++	chmod 700 $(out)$(pkgsysconfdir)/certs/private
+ 
+ uninstall-local:
+ 	@$(NORMAL_UNINSTALL)
+ 	@list='$(dist_pkgdata_DATA)'; for p in $$list; do \
+ 	  f="`echo $$p | sed -e 's|^.*/||'`"; \
+-	  echo " rm -f $(DESTDIR)$(pkgsysconfdir)/$$f"; \
+-	  rm -f $(DESTDIR)$(pkgsysconfdir)/$$f; \
++	  echo " rm -f $(out)$(pkgsysconfdir)/$$f"; \
++	  rm -f $(out)$(pkgsysconfdir)/$$f; \
+ 	done
+diff -ubr davfs2-1.4.7-orig/etc/Makefile.in davfs2-1.4.7/etc/Makefile.in
+--- davfs2-1.4.7-orig/etc/Makefile.in	2013-02-21 11:45:00.185763558 +0100
++++ davfs2-1.4.7/etc/Makefile.in	2013-02-21 11:53:27.241207128 +0100
+@@ -408,19 +408,19 @@
+ 
+ install-data-local: $(dist_pkgdata_DATA)
+ 	@$(NORMAL_INSTALL)
+-	$(mkinstalldirs) $(DESTDIR)$(pkgsysconfdir)
+-	$(INSTALL_DATA) -b davfs2.conf $(DESTDIR)$(pkgsysconfdir)/davfs2.conf
+-	$(INSTALL_DATA) -b -m 600 secrets $(DESTDIR)$(pkgsysconfdir)/secrets
+-	$(mkinstalldirs) $(DESTDIR)$(pkgsysconfdir)/certs
+-	$(mkinstalldirs) $(DESTDIR)$(pkgsysconfdir)/certs/private
+-	chmod 700 $(DESTDIR)$(pkgsysconfdir)/certs/private
++	$(mkinstalldirs) $(out)$(pkgsysconfdir)
++	$(INSTALL_DATA) -b davfs2.conf $(out)$(pkgsysconfdir)/davfs2.conf
++	$(INSTALL_DATA) -b -m 600 secrets $(out)$(pkgsysconfdir)/secrets
++	$(mkinstalldirs) $(out)$(pkgsysconfdir)/certs
++	$(mkinstalldirs) $(out)$(pkgsysconfdir)/certs/private
++	chmod 700 $(out)$(pkgsysconfdir)/certs/private
+ 
+ uninstall-local:
+ 	@$(NORMAL_UNINSTALL)
+ 	@list='$(dist_pkgdata_DATA)'; for p in $$list; do \
+ 	  f="`echo $$p | sed -e 's|^.*/||'`"; \
+-	  echo " rm -f $(DESTDIR)$(pkgsysconfdir)/$$f"; \
+-	  rm -f $(DESTDIR)$(pkgsysconfdir)/$$f; \
++	  echo " rm -f $(out)$(pkgsysconfdir)/$$f"; \
++	  rm -f $(out)$(pkgsysconfdir)/$$f; \
+ 	done
+ 
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
diff --git a/pkgs/tools/networking/snx/default.nix b/pkgs/tools/networking/snx/default.nix
new file mode 100644
index 000000000000..7a73314d0e37
--- /dev/null
+++ b/pkgs/tools/networking/snx/default.nix
@@ -0,0 +1,40 @@
+{ stdenv, fetchurl, makeWrapper, libX11, pam, gcc33 }:
+
+let
+  # The proper value for this offset can be found at the top of the snx_install script.
+  archiveOffset = "78";
+  libraryPath = stdenv.lib.makeSearchPath "lib" [libX11 pam gcc33.gcc];
+in
+stdenv.mkDerivation rec {
+  name = "snx-800007027";
+
+  src = fetchurl {
+    url = "https://remote.us.publicisgroupe.net/CSHELL/snx_install.sh";
+    sha256 = "1yq0r8gb6jw5pyfrw3wxvplrxxfhbhgm9ph4gyd754fyn52iwgxv";
+  };
+
+  buildInputs = [makeWrapper];
+
+  unpackPhase = ''
+    tail -n +${archiveOffset} ${src} | bunzip2 -c - | tar xfvp -
+  '';
+
+  buildPhase = ''
+    patchelf --set-interpreter "$(cat $NIX_GCC/nix-support/dynamic-linker)" snx
+  '';
+
+  installPhase = ''
+    mkdir -p "$out/sbin" "$out/libexec"
+    mv snx "$out/libexec/"
+    makeWrapper "$out/libexec/snx" "$out/sbin/snx" --prefix LD_LIBRARY_PATH ":" "${libraryPath}"
+  '';
+
+  meta = {
+    homepage = "https://www.checkpoint.com/";
+    description = "Check Point SSL Network Extender";
+    license = "unknown";
+
+    platforms = stdenv.lib.platforms.linux;
+    maintainers = [ stdenv.lib.maintainers.simons ];
+  };
+}
diff --git a/pkgs/tools/networking/snx/snx_install.sh b/pkgs/tools/networking/snx/snx_install.sh
new file mode 100755
index 000000000000..759f870468d7
--- /dev/null
+++ b/pkgs/tools/networking/snx/snx_install.sh
Binary files differ