summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorEvgeny Egorochkin <phreedom.stdin@gmail.com>2010-09-28 09:48:15 +0000
committerEvgeny Egorochkin <phreedom.stdin@gmail.com>2010-09-28 09:48:15 +0000
commita77454913966b3aca1ca21a08082738d7950f70e (patch)
tree82ee70076fc305208ee6293f7ffba2358c8fb420 /pkgs/tools
parenta2909b038611b3684dd705e36bc970bc3570b9db (diff)
downloadnixlib-a77454913966b3aca1ca21a08082738d7950f70e.tar
nixlib-a77454913966b3aca1ca21a08082738d7950f70e.tar.gz
nixlib-a77454913966b3aca1ca21a08082738d7950f70e.tar.bz2
nixlib-a77454913966b3aca1ca21a08082738d7950f70e.tar.lz
nixlib-a77454913966b3aca1ca21a08082738d7950f70e.tar.xz
nixlib-a77454913966b3aca1ca21a08082738d7950f70e.tar.zst
nixlib-a77454913966b3aca1ca21a08082738d7950f70e.zip
uni2ascii: packaged
Patch by Cillian de RĂ³iste

svn path=/nixpkgs/trunk/; revision=23984
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/text/uni2ascii/default.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/pkgs/tools/text/uni2ascii/default.nix b/pkgs/tools/text/uni2ascii/default.nix
new file mode 100644
index 000000000000..b4573118a49f
--- /dev/null
+++ b/pkgs/tools/text/uni2ascii/default.nix
@@ -0,0 +1,38 @@
+{ stdenv, fetchurl }:
+
+stdenv.mkDerivation rec {
+  name = "uni2ascii-4.15";
+  src = fetchurl {
+    url = "http://billposer.org/Software/Downloads/${name}.tar.gz";
+    sha256 = "0vlwsqrzmdsb2mx0hbhmw1dvzy56jk8779hphnj6yxijryva6g2v";
+  };
+
+  meta = {
+    license = "GPLv3";
+    homepage = http://billposer.org/Software/uni2ascii.html;
+    description = "Converts between UTF-8 and many 7-bit ASCII equivalents and back";
+
+    longDescription = '' 
+    This package provides conversion in both directions between UTF-8
+    Unicode and more than thirty 7-bit ASCII equivalents, including
+    RFC 2396 URI format and RFC 2045 Quoted Printable format, the
+    representations used in HTML, SGML, XML, OOXML, the Unicode
+    standard, Rich Text Format, POSIX portable charmaps, POSIX locale
+    specifications, and Apache log files, and the escapes used for
+    including Unicode in Ada, C, Common Lisp, Java, Pascal, Perl,
+    Postscript, Python, Scheme, and Tcl.
+
+    Such ASCII equivalents are useful when including Unicode text in
+    program source, when debugging, and when entering text into web
+    programs that can handle the Unicode character set but are not
+    8-bit safe. For example, MovableType, the blog software, truncates
+    posts as soon as it encounters a byte with the high bit
+    set. However, if Unicode is entered in the form of HTML numeric
+    character entities, Movable Type will not garble the post.
+
+    It also provides ways of converting non-ASCII characters to
+    similar ASCII characters, e.g. by stripping diacritics.
+    '';
+    maintainers = [ "cillian.deroiste@gmail.com" ];
+  };
+}