summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2018-04-21 10:27:57 +0100
committerGitHub <noreply@github.com>2018-04-21 10:27:57 +0100
commita769ffc85c5f824fcb089974948291af655621ae (patch)
tree610aacc8a7245b2f3e743e24b29ee90f4c86c2ef /pkgs/tools
parentca462164a93de21a04a8493bdbd414fc3c5e9793 (diff)
parentf44c79e27370fbc59835402035140ad80b79c971 (diff)
downloadnixlib-a769ffc85c5f824fcb089974948291af655621ae.tar
nixlib-a769ffc85c5f824fcb089974948291af655621ae.tar.gz
nixlib-a769ffc85c5f824fcb089974948291af655621ae.tar.bz2
nixlib-a769ffc85c5f824fcb089974948291af655621ae.tar.lz
nixlib-a769ffc85c5f824fcb089974948291af655621ae.tar.xz
nixlib-a769ffc85c5f824fcb089974948291af655621ae.tar.zst
nixlib-a769ffc85c5f824fcb089974948291af655621ae.zip
Merge pull request #39056 from mt-caret/jumanpp
jumanpp: init at 1.02
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/text/jumanpp/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/pkgs/tools/text/jumanpp/default.nix b/pkgs/tools/text/jumanpp/default.nix
new file mode 100644
index 000000000000..c4cb12cb6938
--- /dev/null
+++ b/pkgs/tools/text/jumanpp/default.nix
@@ -0,0 +1,24 @@
+{ stdenv, fetchurl, cmake, protobuf }:
+stdenv.mkDerivation rec {
+  name = "jumanpp";
+  version = "2.0.0-rc2";
+
+  src = fetchurl {
+    url = "https://github.com/ku-nlp/${name}/releases/download/v${version}/${name}-${version}.tar.xz";
+    sha256 = "17fzmd0f5m9ayfhsr0mg7hjp3pg1mhbgknhgyd8v87x46g8bg6qp";
+  };
+  buildInputs = [ cmake protobuf ];
+
+  meta = with stdenv.lib; {
+    description = "A Japanese morphological analyser using a recurrent neural network language model (RNNLM)";
+    longDescription = ''
+      JUMAN++ is a new morphological analyser that considers semantic
+      plausibility of word sequences by using a recurrent neural network
+      language model (RNNLM).
+    '';
+    homepage = http://nlp.ist.i.kyoto-u.ac.jp/index.php?JUMAN++;
+    license = licenses.asl20;
+    maintainers = with maintainers; [ mt-caret ];
+    platforms = platforms.all;
+  };
+}