summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorSong Wenwu <iyzsong@gmail.com>2013-01-28 11:35:03 +0800
committerSong Wenwu <iyzsong@gmail.com>2013-01-28 11:35:03 +0800
commit9f7cc1bfb31942eec200d4a3c4bcea58bac735af (patch)
treebe74dbbbfaf69a8b896ec47264031af61847ae4d /pkgs/tools
parentd596180cf8a7be4f208d746a253abfc598b218ea (diff)
downloadnixlib-9f7cc1bfb31942eec200d4a3c4bcea58bac735af.tar
nixlib-9f7cc1bfb31942eec200d4a3c4bcea58bac735af.tar.gz
nixlib-9f7cc1bfb31942eec200d4a3c4bcea58bac735af.tar.bz2
nixlib-9f7cc1bfb31942eec200d4a3c4bcea58bac735af.tar.lz
nixlib-9f7cc1bfb31942eec200d4a3c4bcea58bac735af.tar.xz
nixlib-9f7cc1bfb31942eec200d4a3c4bcea58bac735af.tar.zst
nixlib-9f7cc1bfb31942eec200d4a3c4bcea58bac735af.zip
add fcitx-4.2.7
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/inputmethods/fcitx/default.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/pkgs/tools/inputmethods/fcitx/default.nix b/pkgs/tools/inputmethods/fcitx/default.nix
new file mode 100644
index 000000000000..ac60cd6134f9
--- /dev/null
+++ b/pkgs/tools/inputmethods/fcitx/default.nix
@@ -0,0 +1,32 @@
+{ stdenv, fetchurl, pkgconfig, cmake, intltool, gettext
+, libxml2, enchant, isocodes, icu, libpthreadstubs
+, pango, cairo, libxkbfile, xorg
+}:
+
+stdenv.mkDerivation rec {
+  name = "fcitx-4.2.7";
+  src = fetchurl {
+    url = "https://fcitx.googlecode.com/files/${name}_dict.tar.xz";
+    sha256 = "1dfvr77j9vnlg76155clrjxnm59r5fzv0d3n6c6yn10zb0bjd40c";
+  };
+
+  buildInputs = [
+    cmake enchant pango gettext libxml2 isocodes pkgconfig libxkbfile
+    intltool cairo icu libpthreadstubs xorg.libXau xorg.libXdmcp
+  ];
+
+  cmakeFlags = ''
+    -DENABLE_DBUS=OFF
+    -DENABLE_QT=OFF
+    -DENABLE_QT_IM_MODULE=OFF
+    -DENABLE_OPENCC=OFF
+    -DENABLE_PRESAGE=OFF
+    -DENABLE_XDGAUTOSTART=OFF
+  '';
+
+  meta = {
+    homepage = "https://code.google.com/p/fcitx/";
+    description = "A Flexible Input Method Framework";
+    license = "GPLv2";
+  };
+}