summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorJascha Geerds <jascha@jgeerds.name>2016-08-01 16:01:02 +0200
committerJascha Geerds <jascha@jgeerds.name>2016-08-01 16:02:50 +0200
commit9cc42ade37cb4f4e9c0bb294e03c80e51fc07fb7 (patch)
tree344e1fae07fe3274f89ee78e486f597ef5087478 /pkgs/tools
parent0fb70dfbb01efa816049b0d821996e0f4d4cf6f6 (diff)
downloadnixlib-9cc42ade37cb4f4e9c0bb294e03c80e51fc07fb7.tar
nixlib-9cc42ade37cb4f4e9c0bb294e03c80e51fc07fb7.tar.gz
nixlib-9cc42ade37cb4f4e9c0bb294e03c80e51fc07fb7.tar.bz2
nixlib-9cc42ade37cb4f4e9c0bb294e03c80e51fc07fb7.tar.lz
nixlib-9cc42ade37cb4f4e9c0bb294e03c80e51fc07fb7.tar.xz
nixlib-9cc42ade37cb4f4e9c0bb294e03c80e51fc07fb7.tar.zst
nixlib-9cc42ade37cb4f4e9c0bb294e03c80e51fc07fb7.zip
tmuxp: init at 1.2.0
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/tmuxp/default.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/pkgs/tools/misc/tmuxp/default.nix b/pkgs/tools/misc/tmuxp/default.nix
new file mode 100644
index 000000000000..08dcc184b3ce
--- /dev/null
+++ b/pkgs/tools/misc/tmuxp/default.nix
@@ -0,0 +1,25 @@
+{ stdenv, fetchurl, pythonPackages }:
+
+pythonPackages.buildPythonApplication rec {
+  name = "tmuxp-${version}";
+  version = "1.2.0";
+
+  namePrefix = "";
+
+  src = fetchurl {
+    url = "mirror://pypi/t/tmuxp/${name}.tar.gz";
+    sha256 = "05z5ssv9glsqmcy9fdq06bawy1274dnzqsqd3a4z4jd0w6j09smn";
+  };
+
+  propagatedBuildInputs = with pythonPackages; [
+    click colorama kaptan libtmux
+  ];
+
+  meta = with stdenv.lib; {
+    description = "Manage tmux workspaces from JSON and YAML";
+    homepage = "http://tmuxp.readthedocs.io";
+    license = licenses.bsd3;
+    platforms = platforms.linux;
+    maintainers = with maintainers; [ jgeerds ];
+  };
+}