summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorJaka Hudoklin <jakahudoklin@gmail.com>2013-08-08 18:33:39 +0200
committerBjørn Forsman <bjorn.forsman@gmail.com>2013-08-12 19:53:08 +0200
commit941055dae9bd78493003c91a3e8e00e6f3697b59 (patch)
tree91f5c7cc665eeeb631207149272823a0a19b515d /pkgs/tools
parent01b483f692c7948ece8b3f4f1a72df31241193e3 (diff)
downloadnixlib-941055dae9bd78493003c91a3e8e00e6f3697b59.tar
nixlib-941055dae9bd78493003c91a3e8e00e6f3697b59.tar.gz
nixlib-941055dae9bd78493003c91a3e8e00e6f3697b59.tar.bz2
nixlib-941055dae9bd78493003c91a3e8e00e6f3697b59.tar.lz
nixlib-941055dae9bd78493003c91a3e8e00e6f3697b59.tar.xz
nixlib-941055dae9bd78493003c91a3e8e00e6f3697b59.tar.zst
nixlib-941055dae9bd78493003c91a3e8e00e6f3697b59.zip
curl: Add support for c-ares, asynchronous dns resolver
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/curl/default.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/pkgs/tools/networking/curl/default.nix b/pkgs/tools/networking/curl/default.nix
index 73dcb44269c3..40e2d9706221 100644
--- a/pkgs/tools/networking/curl/default.nix
+++ b/pkgs/tools/networking/curl/default.nix
@@ -3,12 +3,14 @@
 , sslSupport ? false, openssl ? null
 , scpSupport ? false, libssh2 ? null
 , gssSupport ? false, gss ? null
+, c-aresSupport ? false, c-ares ? null
 , linkStatic ? false
 }:
 
 assert zlibSupport -> zlib != null;
 assert sslSupport -> openssl != null;
 assert scpSupport -> libssh2 != null;
+assert c-aresSupport -> c-ares != null;
 
 stdenv.mkDerivation rec {
   name = "curl-7.30.0";
@@ -24,6 +26,7 @@ stdenv.mkDerivation rec {
   propagatedBuildInputs = with stdenv.lib;
     optional zlibSupport zlib ++
     optional gssSupport gss ++
+    optional c-aresSupport c-ares ++
     optional sslSupport openssl;
 
   preConfigure = ''
@@ -33,6 +36,7 @@ stdenv.mkDerivation rec {
       ( if sslSupport then "--with-ssl=${openssl}" else "--without-ssl" )
       ( if scpSupport then "--with-libssh2=${libssh2}" else "--without-libssh2" )
     ]
+    ++ stdenv.lib.optional c-aresSupport "--enable-ares=${c-ares}"
     ++ stdenv.lib.optional gssSupport "--with-gssapi=${gss}"
     ++ stdenv.lib.optionals linkStatic [ "--enable-static" "--disable-shared" ]
   ;