summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorRobin Stumm <serverkorken@gmail.com>2017-06-13 15:27:51 +0200
committerFranz Pletz <fpletz@fnordicwalking.de>2017-06-13 22:05:27 +0200
commit9079f94df7530b2794a0aa0c032db3e3340cf2b9 (patch)
tree9b2cff55ee8c3e4ae6c350511327b5c4e06c9b8a /pkgs/tools
parentb83609add3e90bf67aba7e4dc628542487271340 (diff)
downloadnixlib-9079f94df7530b2794a0aa0c032db3e3340cf2b9.tar
nixlib-9079f94df7530b2794a0aa0c032db3e3340cf2b9.tar.gz
nixlib-9079f94df7530b2794a0aa0c032db3e3340cf2b9.tar.bz2
nixlib-9079f94df7530b2794a0aa0c032db3e3340cf2b9.tar.lz
nixlib-9079f94df7530b2794a0aa0c032db3e3340cf2b9.tar.xz
nixlib-9079f94df7530b2794a0aa0c032db3e3340cf2b9.tar.zst
nixlib-9079f94df7530b2794a0aa0c032db3e3340cf2b9.zip
exa: 2017-04-02 -> 0.6.0
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/exa/default.nix31
1 files changed, 14 insertions, 17 deletions
diff --git a/pkgs/tools/misc/exa/default.nix b/pkgs/tools/misc/exa/default.nix
index c49f11a72a9e..4dd49e02e0ec 100644
--- a/pkgs/tools/misc/exa/default.nix
+++ b/pkgs/tools/misc/exa/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchFromGitHub, rustPlatform, openssl, cmake, perl, pkgconfig, zlib }:
+{ stdenv, fetchFromGitHub, rustPlatform, cmake, perl, pkgconfig, zlib }:
 
 with rustPlatform;
 
@@ -12,31 +12,28 @@ let
   };
   cargoPatch = ''
     # use non-git dependencies
-    patch -p1 <<EOF
-   --- exa-v0.4.1-src.org/Cargo.toml       1970-01-01 01:00:01.000000000 +0100
-   +++ exa-v0.4.1-src/Cargo.toml   2017-04-04 10:33:31.554377034 +0200
-   @@ -42,4 +42,4 @@
-    optional = true
-
-    [dependencies.zoneinfo_compiled]
-   -git = "https://github.com/rust-datetime/zoneinfo-compiled.git"
-   +path = "${zoneinfo_compiled}"
-EOF
+    patch Cargo.toml <<EOF
+    46c46
+    < git = "https://github.com/rust-datetime/zoneinfo-compiled.git"
+    ---
+    > path = "${zoneinfo_compiled}"
+    EOF
   '';
 in buildRustPackage rec {
-  name = "exa-unstable-2017-04-02";
+  name = "exa-${version}";
+  version = "0.6.0";
 
-  depsSha256 = "0szjba03q4iwzjzb2dp39hhz554ys4z11qdhcdq1mgxqk94scjf4";
+  depsSha256 = "0c1vyl1c67xq18ss0xs5cjdfn892jpwj6ml51dfppzfyns3namm4";
 
   src = fetchFromGitHub {
     owner = "ogham";
     repo = "exa";
-    rev = "1a6066327d2643881996946942aba530e8a1c67c";
-    sha256 = "1xrsg3zw5d3sw2bwx8g0lrs6zpk8rdrvvnknf7c9drp7rplmd8zq";
+    rev = "v${version}";
+    sha256 = "0065gj4pbbppbnwp23s6bb7zlz428nrir00d0kz7axydxk6swhyv";
   };
 
   nativeBuildInputs = [ cmake pkgconfig perl ];
-  buildInputs = [ openssl zlib ];
+  buildInputs = [ zlib ];
 
   # Some tests fail, but Travis ensures a proper build
   doCheck = false;
@@ -60,7 +57,7 @@ in buildRustPackage rec {
       for a directory, or recursing into directories with a tree view. exa is
       written in Rust, so it’s small, fast, and portable.
     '';
-    homepage = http://bsago.me/exa;
+    homepage = http://the.exa.website;
     license = licenses.mit;
     maintainer = [ maintainers.ehegnes ];
   };