summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorTimo Kaufmann <timokau@zoho.com>2018-09-07 21:03:57 +0200
committerTimo Kaufmann <timokau@zoho.com>2018-09-07 21:03:57 +0200
commit8ef940a038c9a4bbd020f164c33a78385867dbfa (patch)
tree8ea188dc2d2000f9e035ecd1c3aac439d6fe9b73 /pkgs/tools
parentfa76f75c7bf2bcb88d3d25c1f7716c730628317d (diff)
downloadnixlib-8ef940a038c9a4bbd020f164c33a78385867dbfa.tar
nixlib-8ef940a038c9a4bbd020f164c33a78385867dbfa.tar.gz
nixlib-8ef940a038c9a4bbd020f164c33a78385867dbfa.tar.bz2
nixlib-8ef940a038c9a4bbd020f164c33a78385867dbfa.tar.lz
nixlib-8ef940a038c9a4bbd020f164c33a78385867dbfa.tar.xz
nixlib-8ef940a038c9a4bbd020f164c33a78385867dbfa.tar.zst
nixlib-8ef940a038c9a4bbd020f164c33a78385867dbfa.zip
youtube-dl: fix youtube video download
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/youtube-dl/default.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/pkgs/tools/misc/youtube-dl/default.nix b/pkgs/tools/misc/youtube-dl/default.nix
index 8284e4af34d4..e497f2a698c7 100644
--- a/pkgs/tools/misc/youtube-dl/default.nix
+++ b/pkgs/tools/misc/youtube-dl/default.nix
@@ -1,5 +1,6 @@
 { lib, fetchurl, buildPythonPackage
 , zip, ffmpeg, rtmpdump, phantomjs2, atomicparsley, pycryptodome, pandoc
+, fetchpatch
 # Pandoc is required to build the package's man page. Release tarballs contain a
 # formatted man page already, though, it will still be installed. We keep the
 # manpage argument in place in case someone wants to use this derivation to
@@ -22,6 +23,15 @@ buildPythonPackage rec {
     sha256 = "0h8x8agl4s5cnfzwmshbcg4pxcgg3iyb86w8krs21y2k9d1ng036";
   };
 
+  patches = [
+    # https://github.com/rg3/youtube-dl/pull/17464
+    (fetchpatch {
+      name = "youtube-js-player-fix.patch";
+      url = "https://github.com/rg3/youtube-dl/pull/17464/commits/6d7359775ae4eef1d1213aae81e092467a2c675c.patch";
+      sha256 = "12mwfmp7iwlawpx6r4rhz546b3anxrx6zc4nyjs8grbh5vxhj9yg";
+    })
+  ];
+
   nativeBuildInputs = [ makeWrapper ];
   buildInputs = [ zip ] ++ lib.optional generateManPage pandoc;
   propagatedBuildInputs = lib.optional hlsEncryptedSupport pycryptodome;