summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2017-06-08 20:53:20 +0200
committerVladimír Čunát <vcunat@gmail.com>2017-06-08 20:53:20 +0200
commit8b49936ad4db7499050aa6f57ce89d606c7382fe (patch)
treeb9b903f655efd9b8fddb53c81790bf9639a626d3 /pkgs/tools
parent10f9fb63f14fbe27dc9b516cca1eb2f72956f141 (diff)
downloadnixlib-8b49936ad4db7499050aa6f57ce89d606c7382fe.tar
nixlib-8b49936ad4db7499050aa6f57ce89d606c7382fe.tar.gz
nixlib-8b49936ad4db7499050aa6f57ce89d606c7382fe.tar.bz2
nixlib-8b49936ad4db7499050aa6f57ce89d606c7382fe.tar.lz
nixlib-8b49936ad4db7499050aa6f57ce89d606c7382fe.tar.xz
nixlib-8b49936ad4db7499050aa6f57ce89d606c7382fe.tar.zst
nixlib-8b49936ad4db7499050aa6f57ce89d606c7382fe.zip
vboot_reference: fix evaluation after 1aac1fe5dd
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/system/vboot_reference/default.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/pkgs/tools/system/vboot_reference/default.nix b/pkgs/tools/system/vboot_reference/default.nix
index 3d4f99fc1f0b..a9a034ebde91 100644
--- a/pkgs/tools/system/vboot_reference/default.nix
+++ b/pkgs/tools/system/vboot_reference/default.nix
@@ -12,11 +12,10 @@ stdenv.mkDerivation rec {
     sha256 = "14d3a93ha5k4al4ib43nyn1ppx7kgb12xw6mkflhx8nxmx8827nc";
   };
 
-  buildInputs = [ pkgconfig openssl stdenv.cc.libc.static ] ++
-                (if libuuid == null
-                 then []
-                 else [ (stdenv.lib.overrideDerivation libuuid
-                          (args: { configureFlags = args.configureFlags + " --enable-static"; })) ]);
+  buildInputs = [ pkgconfig openssl stdenv.cc.libc.static ]
+    ++ stdenv.lib.optional (libuuid != null)
+         (libuuid.overrideAttrs (attrs:
+           { configureFlags = attrs.configureFlags ++ [ "--enable-static" ]; }));
 
   arch = if stdenv.system == "x86_64-linux" then "x86_64"
     else if stdenv.system == "i686-linux" then "x86"