summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorFranz Pletz <fpletz@fnordicwalking.de>2017-10-24 16:07:49 +0200
committerFranz Pletz <fpletz@fnordicwalking.de>2017-10-24 16:07:49 +0200
commit89640746b584b5d64062e8660c7fb745cdf7a55e (patch)
tree86f80cec351bf2c4884d2e2e0d31ee54144c24f1 /pkgs/tools
parent5621b77a33b311e82c8870f6872a2beffef9dbd0 (diff)
parent0f0fcf84ce962cbcc7dfee255f91cba926159705 (diff)
downloadnixlib-89640746b584b5d64062e8660c7fb745cdf7a55e.tar
nixlib-89640746b584b5d64062e8660c7fb745cdf7a55e.tar.gz
nixlib-89640746b584b5d64062e8660c7fb745cdf7a55e.tar.bz2
nixlib-89640746b584b5d64062e8660c7fb745cdf7a55e.tar.lz
nixlib-89640746b584b5d64062e8660c7fb745cdf7a55e.tar.xz
nixlib-89640746b584b5d64062e8660c7fb745cdf7a55e.tar.zst
nixlib-89640746b584b5d64062e8660c7fb745cdf7a55e.zip
Merge branch 'master' into staging
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/notify-desktop/default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/pkgs/tools/misc/notify-desktop/default.nix b/pkgs/tools/misc/notify-desktop/default.nix
new file mode 100644
index 000000000000..661f4f4f435e
--- /dev/null
+++ b/pkgs/tools/misc/notify-desktop/default.nix
@@ -0,0 +1,33 @@
+{ stdenv, fetchFromGitHub, dbus, pkgconfig }:
+
+stdenv.mkDerivation rec {
+  name = "notify-desktop";
+  version = "0.2.0";
+
+  src = fetchFromGitHub {
+    owner = "nowrep";
+    repo = "notify-desktop";
+    rev = "9863919fb4ce7820810ac14a09a46ee73c3d56cc";
+    sha256 = "1brcvl2fx0yzxj9mc8hzfl32zdka1f1bxpzsclcsjplyakyinr1a";
+  };
+
+  buildInputs = [ dbus pkgconfig ];
+
+  installPhase = ''
+    mkdir -p $out/bin
+    install -m 755 bin/notify-desktop $out/bin/notify-desktop
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Little application that lets you send desktop notifications with one command";
+    longDescription = ''
+      It's basically clone of notify-send from libnotify,
+      but it supports reusing notifications on screen by passing its ID.
+      It also does not use any external dependencies (except from libdbus of course).
+    '';
+    homepage = "https://github.com/nowrep/notify-desktop";
+    license = licenses.gpl2;
+    platforms = platforms.unix;
+    maintainers = with maintainers; [ ylwghst ];
+  };
+}