summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorArseniy Seroka <jagajaga@users.noreply.github.com>2016-03-20 21:55:00 +0300
committerArseniy Seroka <jagajaga@users.noreply.github.com>2016-03-20 21:55:00 +0300
commit84ba149e7933b8a53ef8e087bda80f9bf55f1417 (patch)
tree32db4441cf43e0718f0eccc4e783eb4497523b1e /pkgs/tools
parent2d1893899b0ed22bc430c5bcc6fbaaf6acf7add2 (diff)
parentd9e60e4d43ae21dbd63b76cf86edcc8f56c4d764 (diff)
downloadnixlib-84ba149e7933b8a53ef8e087bda80f9bf55f1417.tar
nixlib-84ba149e7933b8a53ef8e087bda80f9bf55f1417.tar.gz
nixlib-84ba149e7933b8a53ef8e087bda80f9bf55f1417.tar.bz2
nixlib-84ba149e7933b8a53ef8e087bda80f9bf55f1417.tar.lz
nixlib-84ba149e7933b8a53ef8e087bda80f9bf55f1417.tar.xz
nixlib-84ba149e7933b8a53ef8e087bda80f9bf55f1417.tar.zst
nixlib-84ba149e7933b8a53ef8e087bda80f9bf55f1417.zip
Merge pull request #14065 from zimbatm/htop-crossplatform
htop: merge both implementations
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/system/htop/default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/pkgs/tools/system/htop/default.nix b/pkgs/tools/system/htop/default.nix
new file mode 100644
index 000000000000..9c05c07c052c
--- /dev/null
+++ b/pkgs/tools/system/htop/default.nix
@@ -0,0 +1,21 @@
+{ fetchurl, stdenv, ncurses }:
+
+stdenv.mkDerivation rec {
+  name = "htop-${version}";
+  version = "2.0.1";
+
+  src = fetchurl {
+    sha256 = "0rjn9ybqx5sav7z4gn18f1q6k23nmqyb6yydfgghzdznz9nn447l";
+    url = "http://hisham.hm/htop/releases/${version}/${name}.tar.gz";
+  };
+
+  buildInputs = [ ncurses ];
+
+  meta = with stdenv.lib; {
+    description = "An interactive process viewer for Linux";
+    homepage = https://hisham.hm/htop/;
+    license = licenses.gpl2Plus;
+    platforms = platforms.all;
+    maintainers = with maintainers; [ rob simons relrod nckx ];
+  };
+}