summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorAlexander Krupenkin <mail@akru.me>2018-05-08 12:31:35 +0300
committerAlexander Krupenkin <mail@akru.me>2018-05-16 15:12:19 +0300
commit82550c639ea8fa609bec82605a0c6f66e26566ea (patch)
treec3e329771f6476a7fb04a384fa265bc4d50e0859 /pkgs/tools
parent4dc33d06b98a2851694f7e903779a240f5f20837 (diff)
downloadnixlib-82550c639ea8fa609bec82605a0c6f66e26566ea.tar
nixlib-82550c639ea8fa609bec82605a0c6f66e26566ea.tar.gz
nixlib-82550c639ea8fa609bec82605a0c6f66e26566ea.tar.bz2
nixlib-82550c639ea8fa609bec82605a0c6f66e26566ea.tar.lz
nixlib-82550c639ea8fa609bec82605a0c6f66e26566ea.tar.xz
nixlib-82550c639ea8fa609bec82605a0c6f66e26566ea.tar.zst
nixlib-82550c639ea8fa609bec82605a0c6f66e26566ea.zip
yrd: init at 0.5.3
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/yrd/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/pkgs/tools/networking/yrd/default.nix b/pkgs/tools/networking/yrd/default.nix
new file mode 100644
index 000000000000..e5d260ef7d42
--- /dev/null
+++ b/pkgs/tools/networking/yrd/default.nix
@@ -0,0 +1,27 @@
+{ stdenv, fetchFromGitHub, pythonPackages }:
+
+let
+  pname = "yrd";
+  version = "0.5.3";
+  sha256 = "1yx1hr8z4cvlb3yi24dwafs0nxq41k4q477jc9q24w61a0g662ps";
+
+in pythonPackages.buildPythonApplication {
+  name = "${pname}-${version}";
+
+  src = fetchFromGitHub {
+    owner = "kpcyrd";
+    repo = "${pname}";
+    rev = "v${version}";
+    inherit sha256;
+  };
+
+  propagatedBuildInputs = with pythonPackages; [ argh ];
+
+  meta = with stdenv.lib; {
+    description = "Cjdns swiss army knife";
+    maintainers = with maintainers; [ akru ];
+    platforms = platforms.linux;
+    license = licenses.gpl3;
+    homepage = https://github.com/kpcyrd/yrd;
+  };
+}