summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorTuomas Tynkkynen <tuomas@tuxera.com>2016-09-06 21:58:42 +0300
committerTuomas Tynkkynen <tuomas@tuxera.com>2016-09-06 21:58:42 +0300
commit81eb0c20f8b5af2da92ef126f304cd1bb32b1621 (patch)
tree4a1ea366ced1638cb4178ee41a7fee5cdf9ca868 /pkgs/tools
parent2bf421d197564ce728f9636e237976f5590c71d8 (diff)
downloadnixlib-81eb0c20f8b5af2da92ef126f304cd1bb32b1621.tar
nixlib-81eb0c20f8b5af2da92ef126f304cd1bb32b1621.tar.gz
nixlib-81eb0c20f8b5af2da92ef126f304cd1bb32b1621.tar.bz2
nixlib-81eb0c20f8b5af2da92ef126f304cd1bb32b1621.tar.lz
nixlib-81eb0c20f8b5af2da92ef126f304cd1bb32b1621.tar.xz
nixlib-81eb0c20f8b5af2da92ef126f304cd1bb32b1621.tar.zst
nixlib-81eb0c20f8b5af2da92ef126f304cd1bb32b1621.zip
honcho: Fix hash
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/system/honcho/default.nix10
1 files changed, 6 insertions, 4 deletions
diff --git a/pkgs/tools/system/honcho/default.nix b/pkgs/tools/system/honcho/default.nix
index 566d9e168ec9..7c33d2e166df 100644
--- a/pkgs/tools/system/honcho/default.nix
+++ b/pkgs/tools/system/honcho/default.nix
@@ -1,13 +1,15 @@
-{ stdenv, fetchzip, pythonPackages, buildPythonApplication }:
+{ stdenv, fetchFromGitHub, pythonPackages, buildPythonApplication }:
 
 let honcho = buildPythonApplication rec {
   name = "honcho-${version}";
   version = "0.6.6";
   namePrefix = "";
 
-  src = fetchzip {
-    url = "https://github.com/nickstenning/honcho/archive/v${version}.tar.gz";
-    sha256 = "1ishyzvq19hdln2nn3bjlk0kwfqsbddpypp28n88jp3px6832w02";
+  src = fetchFromGitHub {
+    owner = "nickstenning";
+    repo = "honcho";
+    rev = "v${version}";
+    sha256 = "0lawwcyrrsd9z9jcr94qn1yabl9bzc529jkpc51jq720fhdlfcr0";
   };
 
   buildInputs = with pythonPackages; [ nose mock jinja2 ];