summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorPeter Hoeg <peter@hoeg.com>2018-03-26 20:34:53 +0800
committerGitHub <noreply@github.com>2018-03-26 20:34:53 +0800
commit81e7c18e4ec1198b23baf8ea8b8efd0c5b42a72e (patch)
tree19f3b405d4e03595643d787457f6f155592dd2ab /pkgs/tools
parent9ae966aaec02fb89a423a32de7a93252f4aadf81 (diff)
parent2642940e71eb6ce42e6f0d00392285a98c60f369 (diff)
downloadnixlib-81e7c18e4ec1198b23baf8ea8b8efd0c5b42a72e.tar
nixlib-81e7c18e4ec1198b23baf8ea8b8efd0c5b42a72e.tar.gz
nixlib-81e7c18e4ec1198b23baf8ea8b8efd0c5b42a72e.tar.bz2
nixlib-81e7c18e4ec1198b23baf8ea8b8efd0c5b42a72e.tar.lz
nixlib-81e7c18e4ec1198b23baf8ea8b8efd0c5b42a72e.tar.xz
nixlib-81e7c18e4ec1198b23baf8ea8b8efd0c5b42a72e.tar.zst
nixlib-81e7c18e4ec1198b23baf8ea8b8efd0c5b42a72e.zip
Merge pull request #34633 from magnetophon/mu
mu: 0.9.18 -> 1.0
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/mu/default.nix22
1 files changed, 14 insertions, 8 deletions
diff --git a/pkgs/tools/networking/mu/default.nix b/pkgs/tools/networking/mu/default.nix
index d0fd7af12902..f8c3d7541008 100644
--- a/pkgs/tools/networking/mu/default.nix
+++ b/pkgs/tools/networking/mu/default.nix
@@ -5,28 +5,32 @@
 
 stdenv.mkDerivation rec {
   name = "mu-${version}";
-  version = "0.9.18";
+  version = "1.0";
 
   src = fetchFromGitHub {
     owner  = "djcb";
     repo   = "mu";
-    rev    = version;
-    sha256 = "0zy0p196bfrfzsq8f58xv04rpnr948sdvljflgzvi6js0vz4009y";
+    rev    = "v${version}";
+    sha256 = "0y6azhcmqdx46a9gi7mn8v8p0mhfx2anjm5rj7i69kbr6j8imlbc";
   };
 
-  # as of 0.9.18 2 tests are failing but previously we had no tests
+  # 0.9.18 and 1.0 have 2 failing tests but previously we had no tests
   patches = [
     ./failing_tests.patch
   ];
 
-  # pmccabe should be a checkInput instead, but configure looks for it
+  # test-utils coredumps so don't run those
+  postPatch = ''
+    sed -i -e '/test-utils/d' lib/parser/Makefile.am
+  '';
+
   buildInputs = [
     sqlite xapian glib gmime texinfo emacs guile libsoup icu
   ] ++ stdenv.lib.optionals withMug [ gtk3 webkitgtk24x-gtk3 ];
-  nativeBuildInputs = [ pkgconfig autoreconfHook ];
-  checkInputs = [ pmccabe ];
 
-  doCheck = true;
+  nativeBuildInputs = [ pkgconfig autoreconfHook pmccabe ];
+
+  enableParallelBuilding = true;
 
   preBuild = ''
     # Fix mu4e-builddir (set it to $out)
@@ -45,6 +49,8 @@ stdenv.mkDerivation rec {
     done
   '';
 
+  doCheck = true;
+
   meta = with stdenv.lib; {
     description = "A collection of utilties for indexing and searching Maildirs";
     license = licenses.gpl3Plus;