summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorPeter Hoeg <peter@hoeg.com>2018-05-16 12:39:06 +0800
committerGitHub <noreply@github.com>2018-05-16 12:39:06 +0800
commit7f27566efd3058ae56a21e85b2ababd1fc65fda2 (patch)
treee1bc217400fb809276dce70a4609e2383f83473e /pkgs/tools
parenta0f7ee0e60c27b2759ff64c43836f9ec09aac914 (diff)
parentc33d8f3d6dd4fbf5fc943187e75a3bad15e9e3e8 (diff)
downloadnixlib-7f27566efd3058ae56a21e85b2ababd1fc65fda2.tar
nixlib-7f27566efd3058ae56a21e85b2ababd1fc65fda2.tar.gz
nixlib-7f27566efd3058ae56a21e85b2ababd1fc65fda2.tar.bz2
nixlib-7f27566efd3058ae56a21e85b2ababd1fc65fda2.tar.lz
nixlib-7f27566efd3058ae56a21e85b2ababd1fc65fda2.tar.xz
nixlib-7f27566efd3058ae56a21e85b2ababd1fc65fda2.tar.zst
nixlib-7f27566efd3058ae56a21e85b2ababd1fc65fda2.zip
Merge pull request #40581 from peterhoeg/p/sedutil
sedutil: init at 1.15.1 and corresponding nixos module
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/security/sedutil/default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/pkgs/tools/security/sedutil/default.nix b/pkgs/tools/security/sedutil/default.nix
new file mode 100644
index 000000000000..343992a6322f
--- /dev/null
+++ b/pkgs/tools/security/sedutil/default.nix
@@ -0,0 +1,28 @@
+{ stdenv, fetchFromGitHub, autoreconfHook }:
+
+stdenv.mkDerivation rec {
+  name = "sedutil-${version}";
+  version = "1.15.1";
+
+  src = fetchFromGitHub {
+    owner  = "Drive-Trust-Alliance";
+    repo   = "sedutil";
+    rev    = version;
+    sha256 = "0zg5v27vbrzzl2vqzks91zj48z30qgcshkqkm1g8ycnhi145l0mf";
+  };
+
+  postPatch = ''
+    patchShebangs .
+  '';
+
+  nativeBuildInputs = [ autoreconfHook ];
+
+  enableParallelBuilding = true;
+
+  meta = with stdenv.lib; {
+    description = "DTA sedutil Self encrypting drive software";
+    homepage    = https://www.drivetrust.com;
+    license     = licenses.gpl3;
+    platforms   = platforms.linux;
+  };
+}