summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorEvgeny Egorochkin <phreedom.stdin@gmail.com>2010-09-22 00:41:31 +0000
committerEvgeny Egorochkin <phreedom.stdin@gmail.com>2010-09-22 00:41:31 +0000
commit7a607648dcc1662a51f91296c4342fc5c0a85b6a (patch)
tree83a242a46bf351a842e727c5fb4b08054e680c2e /pkgs/tools
parent748fa38a35170e99e6cb8fb6c9737e9883527c28 (diff)
downloadnixlib-7a607648dcc1662a51f91296c4342fc5c0a85b6a.tar
nixlib-7a607648dcc1662a51f91296c4342fc5c0a85b6a.tar.gz
nixlib-7a607648dcc1662a51f91296c4342fc5c0a85b6a.tar.bz2
nixlib-7a607648dcc1662a51f91296c4342fc5c0a85b6a.tar.lz
nixlib-7a607648dcc1662a51f91296c4342fc5c0a85b6a.tar.xz
nixlib-7a607648dcc1662a51f91296c4342fc5c0a85b6a.tar.zst
nixlib-7a607648dcc1662a51f91296c4342fc5c0a85b6a.zip
KBluetooth: packaged
svn path=/nixpkgs/trunk/; revision=23889
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/bluetooth/kbluetooth/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/pkgs/tools/bluetooth/kbluetooth/default.nix b/pkgs/tools/bluetooth/kbluetooth/default.nix
new file mode 100644
index 000000000000..047b4f822ae7
--- /dev/null
+++ b/pkgs/tools/bluetooth/kbluetooth/default.nix
@@ -0,0 +1,30 @@
+{ stdenv, fetchurl, kdelibs, cmake, qt4, automoc4, phonon, kdebase_workspace, soprano, gettext
+, semanticDesktop ? true }:
+with stdenv;
+mkDerivation rec {
+  name = "kbluetooth-${version}";
+  version = "0.4.2";
+
+  src = fetchurl {
+    url = "http://kde-apps.org/CONTENT/content-files/112110-${name}.tar.bz2";
+    sha256 = "0z5clp677g1vgh3dd09ilq1r481y342q2cx5pzjj51y1d9lb5zp5";
+  };
+
+  enableParallelBuilding = true;
+
+  buildInputs = [ cmake qt4 kdelibs automoc4 phonon kdebase_workspace soprano gettext]
+    ++ lib.optional semanticDesktop soprano;
+
+  patchPhase = ''
+      substituteInPlace src/CMakeLists.txt --replace "DESTINATION \''${KDE4_BIN_INSTALL_DIR}" "DESTINATION bin"
+      substituteInPlace src/inputwizard/CMakeLists.txt --replace "DESTINATION \''${KDE4_BIN_INSTALL_DIR}" "DESTINATION bin"
+      substituteInPlace src/device-manager/CMakeLists.txt  --replace "DESTINATION \''${KDE4_BIN_INSTALL_DIR}" "DESTINATION bin"
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Bluetooth manager for KDE";
+    license = "GPLv2";
+    inherit (kdelibs.meta) platforms;
+    maintainers = [ maintainers.phreedom ];
+  };
+}
\ No newline at end of file