summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2014-04-06 11:10:01 -0400
committerShea Levy <shea@shealevy.com>2014-04-06 11:10:01 -0400
commit79c9d556e0d1d9c3d82786e222784e76abd59358 (patch)
treef89ae0a5a9261f0577796da0329503bac4ea7320 /pkgs/tools
parent331d234ef6ecd6f32fb2a589a9a97ebf0bf85a9c (diff)
downloadnixlib-79c9d556e0d1d9c3d82786e222784e76abd59358.tar
nixlib-79c9d556e0d1d9c3d82786e222784e76abd59358.tar.gz
nixlib-79c9d556e0d1d9c3d82786e222784e76abd59358.tar.bz2
nixlib-79c9d556e0d1d9c3d82786e222784e76abd59358.tar.lz
nixlib-79c9d556e0d1d9c3d82786e222784e76abd59358.tar.xz
nixlib-79c9d556e0d1d9c3d82786e222784e76abd59358.tar.zst
nixlib-79c9d556e0d1d9c3d82786e222784e76abd59358.zip
Add sproxy-web
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/sproxy-web/default.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/pkgs/tools/networking/sproxy-web/default.nix b/pkgs/tools/networking/sproxy-web/default.nix
new file mode 100644
index 000000000000..fa3221a77598
--- /dev/null
+++ b/pkgs/tools/networking/sproxy-web/default.nix
@@ -0,0 +1,26 @@
+{ cabal, aeson, blazeHtml, blazeMarkup, configurator, hflags
+, httpTypes, mtl, postgresqlSimple, resourcePool, scotty, text
+, waiExtra, waiMiddlewareStatic, fetchurl
+}:
+
+cabal.mkDerivation (self: {
+  pname = "sproxy-web";
+  version = "0.1.0.2";
+  src = fetchurl {
+    url = "https://github.com/zalora/sproxy-web/archive/0.1.0.2.tar.gz";
+    sha256 = "1rdzglvsas0rdgq3j5c9ll411yk168x7v3l7w8zdjgafa947j4d4";
+  };
+  isLibrary = false;
+  isExecutable = true;
+  buildDepends = [
+    aeson blazeHtml blazeMarkup configurator hflags httpTypes mtl
+    postgresqlSimple resourcePool scotty text waiExtra
+    waiMiddlewareStatic
+  ];
+  meta = {
+    homepage = "http://bitbucket.org/zalorasea/sproxy-web";
+    description = "Web interface to sproxy";
+    license = self.stdenv.lib.licenses.bsd3;
+    platforms = self.ghc.meta.platforms;
+  };
+})