summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2018-02-11 17:37:06 +0000
committerGitHub <noreply@github.com>2018-02-11 17:37:06 +0000
commit78ab1b0a178a7f2d17089779690c45c6d085e76e (patch)
tree3099e89c2cf6bb8b16396507c3ea358b267e10cc /pkgs/tools
parent3933b60bae1474ebd315a6c134ad8248fd6edb98 (diff)
parent0312fe48825019669c69251f004426cfd3defdce (diff)
downloadnixlib-78ab1b0a178a7f2d17089779690c45c6d085e76e.tar
nixlib-78ab1b0a178a7f2d17089779690c45c6d085e76e.tar.gz
nixlib-78ab1b0a178a7f2d17089779690c45c6d085e76e.tar.bz2
nixlib-78ab1b0a178a7f2d17089779690c45c6d085e76e.tar.lz
nixlib-78ab1b0a178a7f2d17089779690c45c6d085e76e.tar.xz
nixlib-78ab1b0a178a7f2d17089779690c45c6d085e76e.tar.zst
nixlib-78ab1b0a178a7f2d17089779690c45c6d085e76e.zip
Merge pull request #34845 from yesbox/bfs_init
bfs: init at 1.2.1
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/system/bfs/default.nix38
-rw-r--r--pkgs/tools/system/bfs/tests.patch10
2 files changed, 48 insertions, 0 deletions
diff --git a/pkgs/tools/system/bfs/default.nix b/pkgs/tools/system/bfs/default.nix
new file mode 100644
index 000000000000..2e4133124c11
--- /dev/null
+++ b/pkgs/tools/system/bfs/default.nix
@@ -0,0 +1,38 @@
+{ stdenv, fetchFromGitHub, bash }:
+
+stdenv.mkDerivation rec {
+  name = "bfs-${version}";
+  version = "1.2.1";
+
+  src = fetchFromGitHub {
+    repo = "bfs";
+    owner = "tavianator";
+    rev = version;
+    sha256 = "1dgc31l5d20i0v78c51xga4lr78b5x8dz6yzsvbhlgs0abi0nynx";
+  };
+
+  # Disable fstype test, tries to read /etc/mtab
+  patches = [ ./tests.patch ];
+  postPatch = ''
+    # Patch tests (both shebangs and usage in scripts)
+    for f in $(find -type f -name '*.sh'); do
+      substituteInPlace $f --replace "/bin/bash" "${bash}/bin/bash"
+    done
+  '';
+  doCheck = true;
+
+  makeFlags = [ "PREFIX=$(out)" ];
+  buildFlags = [ "release" ]; # "release" enables compiler optimizations
+
+  meta = with stdenv.lib; {
+    description = "A breadth-first version of the UNIX find command";
+    longDescription = ''
+      bfs is a variant of the UNIX find command that operates breadth-first rather than
+      depth-first. It is otherwise intended to be compatible with many versions of find.
+    '';
+    homepage = https://github.com/tavianator/bfs;
+    license = licenses.bsd0;
+    platforms = platforms.linux;
+    maintainers = with maintainers; [ yesbox ];
+  };
+}
diff --git a/pkgs/tools/system/bfs/tests.patch b/pkgs/tools/system/bfs/tests.patch
new file mode 100644
index 000000000000..a30291d7095f
--- /dev/null
+++ b/pkgs/tools/system/bfs/tests.patch
@@ -0,0 +1,10 @@
+--- a/tests.sh
++++ b/tests.sh
+@@ -369,7 +369,6 @@
+     test_printf_nul
+     test_quit_after_print
+     test_quit_before_print
+-    test_fstype
+     test_not
+     test_and
+     test_or