summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorFranz Pletz <fpletz@fnordicwalking.de>2016-09-25 14:28:29 +0200
committerGitHub <noreply@github.com>2016-09-25 14:28:29 +0200
commit76b142b915531a37ba9fec665ade818601fdee6e (patch)
treee561783de11dbc4543e1331e02a3ac99c6b21404 /pkgs/tools
parent6e063a49b1617815f4f81020a441728972678260 (diff)
parent0609effeb24b96ca334762ba8401257b8a57f312 (diff)
downloadnixlib-76b142b915531a37ba9fec665ade818601fdee6e.tar
nixlib-76b142b915531a37ba9fec665ade818601fdee6e.tar.gz
nixlib-76b142b915531a37ba9fec665ade818601fdee6e.tar.bz2
nixlib-76b142b915531a37ba9fec665ade818601fdee6e.tar.lz
nixlib-76b142b915531a37ba9fec665ade818601fdee6e.tar.xz
nixlib-76b142b915531a37ba9fec665ade818601fdee6e.tar.zst
nixlib-76b142b915531a37ba9fec665ade818601fdee6e.zip
Merge pull request #18894 from tailhook/ripgrep
Add ripgrep package
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/text/ripgrep/default.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/pkgs/tools/text/ripgrep/default.nix b/pkgs/tools/text/ripgrep/default.nix
new file mode 100644
index 000000000000..ca08a2371283
--- /dev/null
+++ b/pkgs/tools/text/ripgrep/default.nix
@@ -0,0 +1,25 @@
+{ stdenv, fetchFromGitHub, rustPlatform, makeWrapper }:
+
+with rustPlatform;
+
+buildRustPackage rec {
+  name = "ripgrep-${version}";
+  version = "0.1.17";
+
+  src = fetchFromGitHub {
+    owner = "BurntSushi";
+    repo = "ripgrep";
+    rev = "${version}";
+    sha256 = "18bpb1jl9fnipgp9icf1wwzm7934lk0ycbpvzlhvs2873zqhv6a6";
+  };
+
+  depsSha256 = "0fzjk5qynxivxmmz7r1za7mzdbdwzwwvxlc5a6cmxmzwnix2lby3";
+
+  meta = with stdenv.lib; {
+    description = "An untility that combines the usability of The Silver Searcher with the raw speed of grep";
+    homepage = https://github.com/BurntSushi/ripgrep;
+    license = with licenses; [ unlicense ];
+    maintainers = [ maintainers.tailhook ];
+    platforms = platforms.all;
+  };
+}