summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2017-07-31 09:12:15 +0200
committerFrederik Rietdijk <fridh@fridh.nl>2017-07-31 09:12:15 +0200
commit740d76371e6c1c76bae4801fc5b736a796c1ebbe (patch)
tree3ea7c544ae005bd5d7c19cb45fb17a886baeb729 /pkgs/tools
parent2a48a62b9cfe99140bfa9d45fca960be848f87fe (diff)
parentba68231273bea4cba01413fd2a0e56d68db9234c (diff)
downloadnixlib-740d76371e6c1c76bae4801fc5b736a796c1ebbe.tar
nixlib-740d76371e6c1c76bae4801fc5b736a796c1ebbe.tar.gz
nixlib-740d76371e6c1c76bae4801fc5b736a796c1ebbe.tar.bz2
nixlib-740d76371e6c1c76bae4801fc5b736a796c1ebbe.tar.lz
nixlib-740d76371e6c1c76bae4801fc5b736a796c1ebbe.tar.xz
nixlib-740d76371e6c1c76bae4801fc5b736a796c1ebbe.tar.zst
nixlib-740d76371e6c1c76bae4801fc5b736a796c1ebbe.zip
Merge commit 'ba68231273bea4cba01413fd2a0e56d68db9234c' into HEAD
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/compression/gzip/default.nix4
-rw-r--r--pkgs/tools/graphics/argyllcms/default.nix2
-rw-r--r--pkgs/tools/misc/coreutils/default.nix3
-rw-r--r--pkgs/tools/misc/grub/2.0x.nix2
-rw-r--r--pkgs/tools/networking/openssh/default.nix6
-rw-r--r--pkgs/tools/networking/ppp/default.nix4
-rw-r--r--pkgs/tools/networking/unbound/default.nix3
-rw-r--r--pkgs/tools/security/vulnix/requirements.nix96
-rw-r--r--pkgs/tools/system/pciutils/default.nix4
-rw-r--r--pkgs/tools/text/gnugrep/default.nix4
10 files changed, 40 insertions, 88 deletions
diff --git a/pkgs/tools/compression/gzip/default.nix b/pkgs/tools/compression/gzip/default.nix
index cb7dc65c710d..bb9555fa600c 100644
--- a/pkgs/tools/compression/gzip/default.nix
+++ b/pkgs/tools/compression/gzip/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, xz }:
+{ stdenv, hostPlatform, fetchurl, xz }:
 
 stdenv.mkDerivation rec {
   name = "gzip-${version}";
@@ -9,6 +9,8 @@ stdenv.mkDerivation rec {
     sha256 = "1lxv3p4iyx7833mlihkn5wfwmz4cys5nybwpz3dfawag8kn6f5zz";
   };
 
+  patches = stdenv.lib.optional hostPlatform.isDarwin stdenv.secure-format-patch;
+
   outputs = [ "out" "man" "info" ];
 
   enableParallelBuilding = true;
diff --git a/pkgs/tools/graphics/argyllcms/default.nix b/pkgs/tools/graphics/argyllcms/default.nix
index 3c7af45f81dd..3cdb4497baf1 100644
--- a/pkgs/tools/graphics/argyllcms/default.nix
+++ b/pkgs/tools/graphics/argyllcms/default.nix
@@ -84,6 +84,8 @@ stdenv.mkDerivation rec {
     substituteInPlace Makefile --replace "-j 3" "-j $NIX_BUILD_CORES"
     # Remove tiff, jpg and png to be sure the nixpkgs-provided ones are used
     rm -rf tiff jpg png
+
+    unset AR
   '';
 
   buildInputs = [
diff --git a/pkgs/tools/misc/coreutils/default.nix b/pkgs/tools/misc/coreutils/default.nix
index 9a988a2b4311..099e9ee0849d 100644
--- a/pkgs/tools/misc/coreutils/default.nix
+++ b/pkgs/tools/misc/coreutils/default.nix
@@ -24,7 +24,8 @@ stdenv.mkDerivation rec {
   # FIXME needs gcc 4.9 in bootstrap tools
   hardeningDisable = [ "stackprotector" ];
 
-  patches = optional hostPlatform.isCygwin ./coreutils-8.23-4.cygwin.patch;
+  patches = optional hostPlatform.isCygwin ./coreutils-8.23-4.cygwin.patch
+    ++ optional hostPlatform.isDarwin stdenv.secure-format-patch;
 
   # The test tends to fail on btrfs and maybe other unusual filesystems.
   postPatch = optionalString (!hostPlatform.isDarwin) ''
diff --git a/pkgs/tools/misc/grub/2.0x.nix b/pkgs/tools/misc/grub/2.0x.nix
index 2bbeea8133e7..634022e88e02 100644
--- a/pkgs/tools/misc/grub/2.0x.nix
+++ b/pkgs/tools/misc/grub/2.0x.nix
@@ -85,6 +85,8 @@ stdenv.mkDerivation rec {
        # See <http://www.mail-archive.com/qemu-devel@nongnu.org/msg22775.html>.
        sed -i "tests/util/grub-shell.in" \
            -e's/qemu-system-i386/qemu-system-x86_64 -nodefaults/g'
+
+      unset CPP # setting CPP intereferes with dependency calculation
     '';
 
   prePatch =
diff --git a/pkgs/tools/networking/openssh/default.nix b/pkgs/tools/networking/openssh/default.nix
index aaef2723da0c..c0440e78a389 100644
--- a/pkgs/tools/networking/openssh/default.nix
+++ b/pkgs/tools/networking/openssh/default.nix
@@ -60,6 +60,12 @@ stdenv.mkDerivation rec {
     ++ optional withKerberos kerberos
     ++ optional hpnSupport autoreconfHook;
 
+  preConfigure = ''
+    # Setting LD causes `configure' and `make' to disagree about which linker
+    # to use: `configure' wants `gcc', but `make' wants `ld'.
+    unset LD
+  '';
+
   # I set --disable-strip because later we strip anyway. And it fails to strip
   # properly when cross building.
   configureFlags = [
diff --git a/pkgs/tools/networking/ppp/default.nix b/pkgs/tools/networking/ppp/default.nix
index 90a4b988c3f7..d07770260ff6 100644
--- a/pkgs/tools/networking/ppp/default.nix
+++ b/pkgs/tools/networking/ppp/default.nix
@@ -34,7 +34,9 @@ stdenv.mkDerivation rec {
   '';
 
   postFixup = ''
-    substituteInPlace $out/bin/{pon,poff,plog} --replace "/usr/sbin" "$out/bin"
+    for tgt in pon poff plog; do
+      substituteInPlace "$out/bin/$tgt" --replace "/usr/sbin" "$out/bin"
+    done
   '';
 
   meta = {
diff --git a/pkgs/tools/networking/unbound/default.nix b/pkgs/tools/networking/unbound/default.nix
index e700ea4fb286..5b6b2ee7ba70 100644
--- a/pkgs/tools/networking/unbound/default.nix
+++ b/pkgs/tools/networking/unbound/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, openssl, nettle, expat, libevent }:
+{ stdenv, fetchurl, openssl, nettle, expat, libevent, dns-root-data }:
 
 stdenv.mkDerivation rec {
   name = "unbound-${version}";
@@ -20,6 +20,7 @@ stdenv.mkDerivation rec {
     "--localstatedir=/var"
     "--sysconfdir=/etc"
     "--sbindir=\${out}/bin"
+    "--with-rootkey-file=${dns-root-data}/root.key"
     "--enable-pie"
     "--enable-relro-now"
   ];
diff --git a/pkgs/tools/security/vulnix/requirements.nix b/pkgs/tools/security/vulnix/requirements.nix
index 11faca44ef93..d44d49f12a92 100644
--- a/pkgs/tools/security/vulnix/requirements.nix
+++ b/pkgs/tools/security/vulnix/requirements.nix
@@ -1,38 +1,6 @@
 { pythonPackages, fetchurl, stdenv }:
 
 rec {
-  BTrees = pythonPackages.buildPythonPackage {
-    name = "BTrees-4.3.1";
-    src = fetchurl {
-      url = "https://pypi.python.org/packages/24/76/cd6f225f2180c22af5cdb6656f51aec5fca45e45bdc4fa75c0a32f161a61/BTrees-4.3.1.tar.gz";
-      sha256 = "2565b7d35260dfc6b1e2934470fd0a2f9326c58c535a2b4cb396289d1c195a95";
-    };
-    propagatedBuildInputs = [
-      persistent
-      transaction
-    ] ++ (with pythonPackages; [ zope_interface coverage ]);
-
-    meta = with stdenv.lib; {
-      homepage = "";
-      license = licenses.zpt21;
-      description = "Scalable persistent object containers";
-    };
-  };
-
-  ZConfig = pythonPackages.buildPythonPackage {
-    name = "ZConfig-3.1.0";
-    src = fetchurl {
-      url = "https://pypi.python.org/packages/52/b3/a96d62711a26d8cfbe546519975dc9ed54d2eb50b3238d2e6de045764796/ZConfig-3.1.0.tar.gz";
-      sha256 = "c21fa3a073a56925a8098036d46717392994a92cffea1b3cda3176b70c0a842e";
-    };
-    propagatedBuildInputs = with pythonPackages; [ zope_testrunner ];
-    meta = with stdenv.lib; {
-      homepage = "";
-      license = licenses.zpt21;
-      description = "Structured Configuration Library";
-    };
-  };
-
   zodb = pythonPackages.buildPythonPackage {
     name = "ZODB-5.2.0";
     src = fetchurl {
@@ -41,31 +9,22 @@ rec {
     };
     doCheck = false;
     propagatedBuildInputs = [
-      BTrees
-      persistent
       transaction
-      ZConfig
-      zc.lockfile
+    ] ++ (with pythonPackages; [
+      six
+      wheel
+      zope_interface
       zodbpickle
-    ] ++ (with pythonPackages; [ six wheel zope_interface ]);
-    meta = with stdenv.lib; {
-      homepage = "";
-      license = licenses.zpt21;
-      description = "Zope Object Database: object database and persistence";
-    };
-  };
+      zconfig
+      persistent
+      zc_lockfile
+      BTrees
+    ]);
 
-  persistent = pythonPackages.buildPythonPackage {
-    name = "persistent-4.2.2";
-    src = fetchurl {
-      url = "https://pypi.python.org/packages/3d/71/3302512282b606ec4d054e09be24c065915518903b29380b6573bff79c24/persistent-4.2.2.tar.gz";
-      sha256 = "52ececc6dbba5ef572d3435189318b4dff07675bafa9620e32f785e147c6563c";
-    };
-    propagatedBuildInputs = with pythonPackages; [ zope_interface six wheel ];
     meta = with stdenv.lib; {
       homepage = "";
       license = licenses.zpt21;
-      description = "Translucent persistent objects";
+      description = "Zope Object Database: object database and persistence";
     };
   };
 
@@ -75,39 +34,16 @@ rec {
       url = "https://pypi.python.org/packages/8c/af/3ffafe85bcc93ecb09459f3f2bd8fbe142e9ab34048f9e2774543b470cbd/transaction-2.0.3.tar.gz";
       sha256 = "67bfb81309ba9717edbb2ca2e5717c325b78beec0bf19f44e5b4b9410f82df7f";
     };
-    propagatedBuildInputs = with pythonPackages; [ zope_interface six wheel ];
+    propagatedBuildInputs = with pythonPackages; [
+      zope_interface
+      six
+      wheel
+      mock
+    ];
     meta = with stdenv.lib; {
       homepage = "";
       license = licenses.zpt21;
       description = "Transaction management for Python";
     };
   };
-
-  zc.lockfile = pythonPackages.buildPythonPackage {
-    name = "zc.lockfile-1.2.1";
-    src = fetchurl {
-      url = "https://pypi.python.org/packages/bd/84/0299bbabbc9d3f84f718ba1039cc068030d3ad723c08f82a64337edf901e/zc.lockfile-1.2.1.tar.gz";
-      sha256 = "11db91ada7f22fe8aae268d4bfdeae012c4fe655f66bbb315b00822ec00d043e";
-    };
-    meta = with stdenv.lib; {
-      homepage = "";
-      license = licenses.zpt21;
-      description = "Basic inter-process locks";
-    };
-  };
-
-  zodbpickle = pythonPackages.buildPythonPackage {
-    name = "zodbpickle-0.6.0";
-    src = fetchurl {
-      url = "https://pypi.python.org/packages/7a/fc/f6f437a5222b330735eaf8f1e67a6845bd1b600e9a9455e552d3c13c4902/zodbpickle-0.6.0.tar.gz";
-      sha256 = "ea3248be966159e7791e3db0e35ea992b9235d52e7d39835438686741d196665";
-    };
-    doCheck = false;
-
-    meta = with stdenv.lib; {
-      homepage = "";
-      license = licenses.zpt21;
-      description = "Fork of Python 3 pickle module.";
-    };
-  };
 }
diff --git a/pkgs/tools/system/pciutils/default.nix b/pkgs/tools/system/pciutils/default.nix
index 998a3bdf6d1d..8a4fe6cb3cff 100644
--- a/pkgs/tools/system/pciutils/default.nix
+++ b/pkgs/tools/system/pciutils/default.nix
@@ -1,11 +1,11 @@
 { stdenv, fetchurl, pkgconfig, zlib, kmod, which }:
 
 stdenv.mkDerivation rec {
-  name = "pciutils-3.5.4"; # with database from 2017-02
+  name = "pciutils-3.5.5"; # with database from 2017-07
 
   src = fetchurl {
     url = "mirror://kernel/software/utils/pciutils/${name}.tar.xz";
-    sha256 = "0rpy7kkb2y89wmbcbfjjjxsk2x89v5xxhxib4vpl131ip5m3qab4";
+    sha256 = "1d62f8fa192f90e61c35a6fc15ff3cb9a7a792f782407acc42ef67817c5939f5";
   };
 
   buildInputs = [ pkgconfig zlib kmod which ];
diff --git a/pkgs/tools/text/gnugrep/default.nix b/pkgs/tools/text/gnugrep/default.nix
index b33ea7169783..0db140c7891c 100644
--- a/pkgs/tools/text/gnugrep/default.nix
+++ b/pkgs/tools/text/gnugrep/default.nix
@@ -1,13 +1,13 @@
 { stdenv, fetchurl, pcre, libiconv, perl }:
 
-let version = "3.0"; in
+let version = "3.1"; in
 
 stdenv.mkDerivation {
   name = "gnugrep-${version}";
 
   src = fetchurl {
     url = "mirror://gnu/grep/grep-${version}.tar.xz";
-    sha256 = "1dcasjp3a578nrvzrcn38mpizb8w1q6mvfzhjmcqqgkf0nsivj72";
+    sha256 = "0zm0ywmyz9g8vn1plw14mn8kj74yipx5qsljndbyfgmvndx5qqnv";
   };
 
   # Perl is needed for testing