summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorcillianderoiste <cillian.deroiste@gmail.com>2015-01-14 11:46:21 +0100
committercillianderoiste <cillian.deroiste@gmail.com>2015-01-14 11:46:21 +0100
commit6e66d3df90ef533f3683bc8057a41504673023b7 (patch)
tree995171ae5fee854a4fbf7b55aaa5ba32f653547a /pkgs/tools
parentb9cb0ce2cecbd1b5d90c174c57357bc87e71a6c4 (diff)
parent8257ed81c9cd54f8247759b5d754eea983aa1a43 (diff)
downloadnixlib-6e66d3df90ef533f3683bc8057a41504673023b7.tar
nixlib-6e66d3df90ef533f3683bc8057a41504673023b7.tar.gz
nixlib-6e66d3df90ef533f3683bc8057a41504673023b7.tar.bz2
nixlib-6e66d3df90ef533f3683bc8057a41504673023b7.tar.lz
nixlib-6e66d3df90ef533f3683bc8057a41504673023b7.tar.xz
nixlib-6e66d3df90ef533f3683bc8057a41504673023b7.tar.zst
nixlib-6e66d3df90ef533f3683bc8057a41504673023b7.zip
Merge pull request #5752 from nckx/lz4
Add lz4: very fast lossless compression
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/compression/lz4/default.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/pkgs/tools/compression/lz4/default.nix b/pkgs/tools/compression/lz4/default.nix
new file mode 100644
index 000000000000..6f7cf5b987a4
--- /dev/null
+++ b/pkgs/tools/compression/lz4/default.nix
@@ -0,0 +1,32 @@
+{ stdenv, fetchurl }:
+
+stdenv.mkDerivation rec {
+  # The r127 source still calls itself r126 everywhere, but I'm not going to
+  # patch over such silly cosmetic oversights in an official release. -- nckx
+  version = "127";
+  name = "lz4-${version}";
+
+  src = fetchurl {
+    url = "https://github.com/Cyan4973/lz4/archive/r${version}.tar.gz";
+    sha256 = "0hvbbr07j4hfix4dn4xw4fsmkr5s02bj596fn0i15d1i49xby2aj";
+  };
+
+  enableParallelBuilding = true;
+
+  makeFlags = "PREFIX=$(out)";
+
+  meta = with stdenv.lib; {
+    description = "Extremely fast compression algorithm";
+    longDescription = ''
+      Very fast lossless compression algorithm, providing compression speed
+      at 400 MB/s per core, with near-linear scalability for multi-threaded
+      applications. It also features an extremely fast decoder, with speed in
+      multiple GB/s per core, typically reaching RAM speed limits on
+      multi-core systems.
+    '';
+    homepage = https://code.google.com/p/lz4/;
+    license = with licenses; [ bsd2 gpl2Plus ];
+    platforms = with platforms; linux;
+    maintainers = with maintainers; [ nckx ];
+  };
+}