summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorJohn Chee <cheecheeo@gmail.com>2015-07-21 18:24:31 -0700
committerJohn Chee <cheecheeo@gmail.com>2015-07-30 23:05:38 -0700
commit6c14111c9df6328374dced088d9fe45b8f693cf3 (patch)
tree490d16208e3613f757cfbfbd481e2f640a5102c4 /pkgs/tools
parentd27b0bc596d2a546be27d9b05a836c50c5920e83 (diff)
downloadnixlib-6c14111c9df6328374dced088d9fe45b8f693cf3.tar
nixlib-6c14111c9df6328374dced088d9fe45b8f693cf3.tar.gz
nixlib-6c14111c9df6328374dced088d9fe45b8f693cf3.tar.bz2
nixlib-6c14111c9df6328374dced088d9fe45b8f693cf3.tar.lz
nixlib-6c14111c9df6328374dced088d9fe45b8f693cf3.tar.xz
nixlib-6c14111c9df6328374dced088d9fe45b8f693cf3.tar.zst
nixlib-6c14111c9df6328374dced088d9fe45b8f693cf3.zip
entr: init at 3.2
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/entr/default.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/pkgs/tools/misc/entr/default.nix b/pkgs/tools/misc/entr/default.nix
new file mode 100644
index 000000000000..8770a5858875
--- /dev/null
+++ b/pkgs/tools/misc/entr/default.nix
@@ -0,0 +1,32 @@
+{ stdenv, fetchurl, coreutils, ncurses }:
+
+stdenv.mkDerivation rec {
+  name = "entr-${version}";
+  version = "3.2";
+
+  src = fetchurl {
+    url = "http://entrproject.org/code/${name}.tar.gz";
+    sha256 = "0ikigpfzyjmr8j6snwlvxzqamrjbhlv78m8w1h0h7kzczc5f1vmi";
+  };
+
+  postPatch = ''
+    substituteInPlace Makefile.bsd --replace /bin/echo echo
+    substituteInPlace entr.c --replace /bin/cat ${coreutils}/bin/cat
+    substituteInPlace entr.c --replace /usr/bin/clear ${ncurses}/bin/clear
+    substituteInPlace entr.1 --replace /bin/cat cat
+    substituteInPlace entr.1 --replace /usr/bin/clear clear
+  '';
+  dontAddPrefix = true;
+  doCheck = true;
+  checkTarget = "test";
+  installFlags = [ "PREFIX=$(out)" ];
+
+  meta = {
+    homepage = http://entrproject.org/;
+    description = "Run arbitrary commands when files change.";
+
+    license = stdenv.lib.licenses.isc;
+
+    platforms = stdenv.lib.platforms.all;
+  };
+}