summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorZach Coyle <zach@trabian.com>2018-09-28 16:59:03 -0400
committerZach Coyle <zach@trabian.com>2018-09-28 16:59:03 -0400
commit68879b36cbf3fae32b485a5af54b009139ae96e5 (patch)
tree275a4ea4a35f4ac31c74bfec77db76759d74f2f9 /pkgs/tools
parent8a57be905083d61f2d061619da86333cb4963255 (diff)
downloadnixlib-68879b36cbf3fae32b485a5af54b009139ae96e5.tar
nixlib-68879b36cbf3fae32b485a5af54b009139ae96e5.tar.gz
nixlib-68879b36cbf3fae32b485a5af54b009139ae96e5.tar.bz2
nixlib-68879b36cbf3fae32b485a5af54b009139ae96e5.tar.lz
nixlib-68879b36cbf3fae32b485a5af54b009139ae96e5.tar.xz
nixlib-68879b36cbf3fae32b485a5af54b009139ae96e5.tar.zst
nixlib-68879b36cbf3fae32b485a5af54b009139ae96e5.zip
teamocil: init at 1.4.2
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/teamocil/Gemfile2
-rw-r--r--pkgs/tools/misc/teamocil/Gemfile.lock13
-rw-r--r--pkgs/tools/misc/teamocil/default.nix17
-rw-r--r--pkgs/tools/misc/teamocil/gemset.nix10
-rwxr-xr-xpkgs/tools/misc/teamocil/update10
5 files changed, 52 insertions, 0 deletions
diff --git a/pkgs/tools/misc/teamocil/Gemfile b/pkgs/tools/misc/teamocil/Gemfile
new file mode 100644
index 000000000000..046ba3d536e0
--- /dev/null
+++ b/pkgs/tools/misc/teamocil/Gemfile
@@ -0,0 +1,2 @@
+source 'https://rubygems.org'
+gem 'teamocil'
diff --git a/pkgs/tools/misc/teamocil/Gemfile.lock b/pkgs/tools/misc/teamocil/Gemfile.lock
new file mode 100644
index 000000000000..419c2ae49d31
--- /dev/null
+++ b/pkgs/tools/misc/teamocil/Gemfile.lock
@@ -0,0 +1,13 @@
+GEM
+  remote: https://rubygems.org/
+  specs:
+    teamocil (1.4.2)
+
+PLATFORMS
+  ruby
+
+DEPENDENCIES
+  teamocil
+
+BUNDLED WITH
+   1.16.3
diff --git a/pkgs/tools/misc/teamocil/default.nix b/pkgs/tools/misc/teamocil/default.nix
new file mode 100644
index 000000000000..2215e4d4fee7
--- /dev/null
+++ b/pkgs/tools/misc/teamocil/default.nix
@@ -0,0 +1,17 @@
+{ lib, bundlerEnv, ruby }:
+
+bundlerEnv rec {
+  inherit ruby;
+  pname = "teamocil";
+  gemdir = ./.;
+
+  meta = with lib; {
+    description     = "A simple tool used to automatically create windows and panes in tmux with YAML files";
+    homepage        = https://github.com/remiprev/teamocil;
+    license         = licenses.mit;
+    platforms       = platforms.all;
+    maintainers     = with maintainers; [
+      zachcoyle 
+    ];
+  };
+}
diff --git a/pkgs/tools/misc/teamocil/gemset.nix b/pkgs/tools/misc/teamocil/gemset.nix
new file mode 100644
index 000000000000..f363d62b6d68
--- /dev/null
+++ b/pkgs/tools/misc/teamocil/gemset.nix
@@ -0,0 +1,10 @@
+{
+  teamocil = {
+    source = {
+      remotes = ["https://rubygems.org"];
+      sha256 = "1l5f33faipb45xx7ds67s7dqgvjlljlcxgpgig4pg8p002vg06r2";
+      type = "gem";
+    };
+    version = "1.4.2";
+  };
+}
\ No newline at end of file
diff --git a/pkgs/tools/misc/teamocil/update b/pkgs/tools/misc/teamocil/update
new file mode 100755
index 000000000000..58a7bd4a4539
--- /dev/null
+++ b/pkgs/tools/misc/teamocil/update
@@ -0,0 +1,10 @@
+#!/usr/bin/env nix-shell
+#! nix-shell -i bash -p bash ruby bundler bundix
+
+rm Gemfile.lock
+bundler install
+bundix
+
+if [ "clean" == "$1" ]; then
+  rm -rf ~/.gem
+fi