summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorxeji <36407913+xeji@users.noreply.github.com>2018-07-06 11:26:33 +0200
committerGitHub <noreply@github.com>2018-07-06 11:26:33 +0200
commit5ea2eb7ac97c6665fc239eaf5f071139fe7c2f2a (patch)
treea93f21069688e87c5ddef975585bcf6b07a684bf /pkgs/tools
parenta4a1627926285b189e215fa59d61908037f29a5c (diff)
parent7e579aa994eb2dc42ddabf5aff6e2d89045a4586 (diff)
downloadnixlib-5ea2eb7ac97c6665fc239eaf5f071139fe7c2f2a.tar
nixlib-5ea2eb7ac97c6665fc239eaf5f071139fe7c2f2a.tar.gz
nixlib-5ea2eb7ac97c6665fc239eaf5f071139fe7c2f2a.tar.bz2
nixlib-5ea2eb7ac97c6665fc239eaf5f071139fe7c2f2a.tar.lz
nixlib-5ea2eb7ac97c6665fc239eaf5f071139fe7c2f2a.tar.xz
nixlib-5ea2eb7ac97c6665fc239eaf5f071139fe7c2f2a.tar.zst
nixlib-5ea2eb7ac97c6665fc239eaf5f071139fe7c2f2a.zip
Merge pull request #43090 from flokli/gocryptfs-1.5
gocryptfs: 1.1.1 -> 1.5
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/filesystems/gocrypfs/default.nix44
-rw-r--r--pkgs/tools/filesystems/gocrypfs/deps.nix39
-rw-r--r--pkgs/tools/filesystems/gocryptfs/default.nix50
-rw-r--r--pkgs/tools/filesystems/gocryptfs/deps.nix66
4 files changed, 116 insertions, 83 deletions
diff --git a/pkgs/tools/filesystems/gocrypfs/default.nix b/pkgs/tools/filesystems/gocrypfs/default.nix
deleted file mode 100644
index b9314015cf55..000000000000
--- a/pkgs/tools/filesystems/gocrypfs/default.nix
+++ /dev/null
@@ -1,44 +0,0 @@
-# This file was generated by go2nix.
-{ stdenv, lib, buildGoPackage, fetchFromGitHub, pkgconfig, openssl }:
-
-with lib;
-
-let
-  goFuseVersion = substring 0 7 (head (filter (
-    d: d.goPackagePath == "github.com/hanwen/go-fuse"
-  ) (import ./deps.nix))).fetch.rev;
-in buildGoPackage rec {
-  name = "gocryptfs-${version}";
-  version = "1.1.1";
-  rev = "v${version}";
-
-  goPackagePath = "github.com/rfjakob/gocryptfs";
-
-  src = fetchFromGitHub {
-    inherit rev;
-    owner = "rfjakob";
-    repo = "gocryptfs";
-    sha256 = "0p173x2s0km7a43h6ihir5p19fdlkkb9lc9120k9hccr33iws25z";
-  };
-
-  nativeBuildInputs = [ pkgconfig ];
-  buildInputs = [ openssl];
-
-  goDeps = ./deps.nix;
-
-  postPatch = "rm -r tests";
-
-  buildFlagsArray = ''
-    -ldflags=
-      -X main.GitVersion=${rev}
-      -X main.GitVersionFuse=${goFuseVersion}
-  '';
-
-  meta = {
-    description = "Encrypted overlay filesystem written in Go";
-    license = licenses.mit;
-    homepage = https://nuetzlich.net/gocryptfs/;
-    maintainers = with maintainers; [offline];
-    platforms = with platforms; linux;
-  };
-}
diff --git a/pkgs/tools/filesystems/gocrypfs/deps.nix b/pkgs/tools/filesystems/gocrypfs/deps.nix
deleted file mode 100644
index 08a4afb52653..000000000000
--- a/pkgs/tools/filesystems/gocrypfs/deps.nix
+++ /dev/null
@@ -1,39 +0,0 @@
-# This file was generated by go2nix.
-[
-  {
-    goPackagePath = "github.com/hanwen/go-fuse";
-    fetch = {
-      type = "git";
-      url = "https://github.com/hanwen/go-fuse";
-      rev = "6c2b7d8f22c99776f8bfe17cd26d5f744a5b4cdc";
-      sha256 = "1mb73vyqfy92830qif83zdlng0zycmm5fgmm9bwihqh92y8inw3h";
-    };
-  }
-  {
-    goPackagePath = "github.com/jacobsa/crypto";
-    fetch = {
-      type = "git";
-      url = "https://github.com/jacobsa/crypto";
-      rev = "293ce0c192fb4f59cd879b46544922b9ed09a13a";
-      sha256 = "12nm5h5dqqk8yrzlkmcqm0aam8l6l1s6rah48mrmz1z5bgm9h5rs";
-    };
-  }
-  {
-    goPackagePath = "github.com/rfjakob/eme";
-    fetch = {
-      type = "git";
-      url = "https://github.com/rfjakob/eme";
-      rev = "601d0e278ceda9aa2085a61c9265f6e690ef5255";
-      sha256 = "1ryh5f2a42psrqcpjh73shk3p0mva2vcyyfav4nhxmfqall77k5z";
-    };
-  }
-  {
-    goPackagePath = "golang.org/x/crypto";
-    fetch = {
-      type = "git";
-      url = "https://go.googlesource.com/crypto";
-      rev = "88d0005bf4c3ec17306ecaca4281a8d8efd73e91";
-      sha256 = "1d3x0rwfd4cml06ka8gy74wxrw94m2z7qgz6ky0rgmxcr7p5iikz";
-    };
-  }
-]
diff --git a/pkgs/tools/filesystems/gocryptfs/default.nix b/pkgs/tools/filesystems/gocryptfs/default.nix
new file mode 100644
index 000000000000..75f5e9ffe11f
--- /dev/null
+++ b/pkgs/tools/filesystems/gocryptfs/default.nix
@@ -0,0 +1,50 @@
+# This file was generated by https://github.com/kamilchm/go2nix v1.2.1
+{ stdenv, buildGoPackage, fetchFromGitHub, openssl, pandoc, pkgconfig }:
+
+let
+  version = "v1.5";
+  goFuseVersion = with stdenv.lib; substring 0 7 (head (filter (
+    d: d.goPackagePath == "github.com/hanwen/go-fuse"
+  ) (import ./deps.nix))).fetch.rev;
+in
+buildGoPackage rec {
+  name = "gocryptfs-${version}";
+
+  goPackagePath = "github.com/rfjakob/gocryptfs";
+
+  nativeBuildInputs = [ pandoc pkgconfig ];
+  buildInputs = [ openssl ];
+
+  src = fetchFromGitHub {
+    owner = "rfjakob";
+    repo = "gocryptfs";
+    rev = version;
+    sha256 = "0s5smjc7n9088n8a2mv7cy3cx31ci13i1i8fhg1vslc17a15qs2d";
+  };
+
+  postPatch = "rm -r tests";
+
+  buildFlagsArray = ''
+    -ldflags=
+      -X main.GitVersion=${version}
+      -X main.GitVersionFuse=${goFuseVersion}
+  '';
+
+  goDeps = ./deps.nix;
+
+  postBuild = ''
+    pushd go/src/github.com/rfjakob/gocryptfs/Documentation/
+    mkdir -p $out/share/man/man1
+    pandoc MANPAGE.md -s -t man -o $out/share/man/man1/gocryptfs.1
+    pandoc MANPAGE-XRAY.md -s -t man -o $out/share/man/man1/gocryptfs-xray.1
+    popd
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Encrypted overlay filesystem written in Go";
+    license = licenses.mit;
+    homepage = https://nuetzlich.net/gocryptfs/;
+    maintainers = with maintainers; [ flokli offline ];
+    platforms = platforms.unix;
+  };
+}
diff --git a/pkgs/tools/filesystems/gocryptfs/deps.nix b/pkgs/tools/filesystems/gocryptfs/deps.nix
new file mode 100644
index 000000000000..cb5aec527f24
--- /dev/null
+++ b/pkgs/tools/filesystems/gocryptfs/deps.nix
@@ -0,0 +1,66 @@
+# This file was generated by https://github.com/kamilchm/go2nix v1.2.1
+[
+  {
+    goPackagePath = "github.com/hanwen/go-fuse";
+    fetch = {
+      type = "git";
+      url = "https://github.com/hanwen/go-fuse";
+      rev = "291273cb8ce0f139636a6fd7414be3c7e2de6288";
+      sha256 = "1djfl6mni8k4wllhwcr6qwyg1nh6wykdalvdl6gpc1rwrjj9c6xi";
+    };
+  }
+  {
+    goPackagePath = "github.com/jacobsa/crypto";
+    fetch = {
+      type = "git";
+      url = "https://github.com/jacobsa/crypto";
+      rev = "c73681c634de898c869684602cf0c0d2ce938c4d";
+      sha256 = "02jbiy6szshbzcmp4j3gpc577hrhikxqvm4kzxixp27k9f2cx5si";
+    };
+  }
+  {
+    goPackagePath = "github.com/pkg/xattr";
+    fetch = {
+      type = "git";
+      url = "https://github.com/pkg/xattr";
+      rev = "d15dbc2bb0b5da267362b5e066e2c44c1fcff6c7";
+      sha256 = "1vab8mpk2x4vbhx0kd0i0kn6sf7z5ivilcmdklyizzcfcwghh17g";
+    };
+  }
+  {
+    goPackagePath = "github.com/rfjakob/eme";
+    fetch = {
+      type = "git";
+      url = "https://github.com/rfjakob/eme";
+      rev = "2222dbd4ba467ab3fc7e8af41562fcfe69c0d770";
+      sha256 = "0c227ly3z8pqaqg22lpd8nzgqrfsbjx5gi9rp9ks1cmd11dv2gl9";
+    };
+  }
+  {
+    goPackagePath = "golang.org/x/crypto";
+    fetch = {
+      type = "git";
+      url = "https://go.googlesource.com/crypto";
+      rev = "a49355c7e3f8fe157a85be2f77e6e269a0f89602";
+      sha256 = "020q1laxjx5kcmnqy4wmdb63zhb0lyq6wpy40axhswzg2nd21s44";
+    };
+  }
+  {
+    goPackagePath = "golang.org/x/sync";
+    fetch = {
+      type = "git";
+      url = "https://go.googlesource.com/sync";
+      rev = "1d60e4601c6fd243af51cc01ddf169918a5407ca";
+      sha256 = "046jlanz2lkxq1r57x9bl6s4cvfqaic6p2xybsj8mq1120jv4rs6";
+    };
+  }
+  {
+    goPackagePath = "golang.org/x/sys";
+    fetch = {
+      type = "git";
+      url = "https://go.googlesource.com/sys";
+      rev = "151529c776cdc58ddbe7963ba9af779f3577b419";
+      sha256 = "149yfzs4k8vxhjr8f832drndir2k5ha0ggs2dw2fd6xvxf698bcx";
+    };
+  }
+]