summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorJoachim Fasting <joachifm@fastmail.fm>2016-08-26 17:14:28 +0200
committerJoachim Fasting <joachifm@fastmail.fm>2016-08-26 17:18:56 +0200
commit5a2dbb1b8b0903b009148f07a533e3cf3515c77d (patch)
treeda3604444405435867795ca11373a6836e936cb5 /pkgs/tools
parent3de68a39791df7d518ee59fcc2b9e6576571d2a4 (diff)
downloadnixlib-5a2dbb1b8b0903b009148f07a533e3cf3515c77d.tar
nixlib-5a2dbb1b8b0903b009148f07a533e3cf3515c77d.tar.gz
nixlib-5a2dbb1b8b0903b009148f07a533e3cf3515c77d.tar.bz2
nixlib-5a2dbb1b8b0903b009148f07a533e3cf3515c77d.tar.lz
nixlib-5a2dbb1b8b0903b009148f07a533e3cf3515c77d.tar.xz
nixlib-5a2dbb1b8b0903b009148f07a533e3cf3515c77d.tar.zst
nixlib-5a2dbb1b8b0903b009148f07a533e3cf3515c77d.zip
tor: 0.2.7.6 -> 0.2.8.7
Also:
- Turn patchPhase into postPatch
- Add systemd and libcap on linux (and also pkgconfig for detection);
  we should be able to change the service unit to Type=notify
- Disable checks for now, the test-suite is failing in sandbox due to
  lack of network
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/security/tor/default.nix23
1 files changed, 12 insertions, 11 deletions
diff --git a/pkgs/tools/security/tor/default.nix b/pkgs/tools/security/tor/default.nix
index 8ac7472a2bc3..533cb0dcd8eb 100644
--- a/pkgs/tools/security/tor/default.nix
+++ b/pkgs/tools/security/tor/default.nix
@@ -1,29 +1,30 @@
-{ stdenv, fetchurl, libevent, openssl, zlib, torsocks, libseccomp }:
+{ stdenv, fetchurl, pkgconfig, libevent, openssl, zlib, torsocks
+, libseccomp, systemd, libcap
+}:
 
 stdenv.mkDerivation rec {
-  name = "tor-0.2.7.6";
+  name = "tor-0.2.8.7";
 
   src = fetchurl {
     url = "https://archive.torproject.org/tor-package-archive/${name}.tar.gz";
-    sha256 = "0p8hjlfi8dwghlyjif5s0q98cmpgz9kn9jja25430l04z5wqcfj9";
+    sha256 = "1iigfi8ljl88s8b5y1g4ak8im57simazscl467zvfbg8k6vf4i5f";
   };
 
-  # Note: torsocks is specified as a dependency, as the distributed
-  # 'torify' wrapper attempts to use it; although there is no
-  # ./configure time check for any of this.
-  buildInputs = [ libevent openssl zlib torsocks ] ++
-    stdenv.lib.optional stdenv.isLinux libseccomp;
+  nativeBuildInputs = [ pkgconfig ];
+  buildInputs = [ libevent openssl zlib ] ++
+    stdenv.lib.optionals stdenv.isLinux [ libseccomp systemd libcap ];
 
   NIX_CFLAGS_LINK = stdenv.lib.optionalString stdenv.cc.isGNU "-lgcc_s";
 
-  # Patch 'torify' to point directly to torsocks.
-  patchPhase = ''
+  postPatch = ''
     substituteInPlace contrib/client-tools/torify \
       --replace 'pathfind torsocks' true          \
       --replace 'exec torsocks' 'exec ${torsocks}/bin/torsocks'
   '';
 
-  doCheck = true;
+  # Fails in a sandboxed environment; at some point we want to disable
+  # just the tests that require networking.
+  doCheck = false;
 
   meta = with stdenv.lib; {
     homepage = https://www.torproject.org/;