summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2013-10-27 04:19:18 -0500
committerEvgeny Egorochkin <phreedom@yandex.ru>2013-10-27 20:21:22 +0200
commit59de62317dbc5270eafd00503c9633af60eb590b (patch)
tree6eca194533000f13c2ea3a991af3a2db07c52fc8 /pkgs/tools
parent216e9976fe0977bf26a3225369c4ef97cc6af066 (diff)
downloadnixlib-59de62317dbc5270eafd00503c9633af60eb590b.tar
nixlib-59de62317dbc5270eafd00503c9633af60eb590b.tar.gz
nixlib-59de62317dbc5270eafd00503c9633af60eb590b.tar.bz2
nixlib-59de62317dbc5270eafd00503c9633af60eb590b.tar.lz
nixlib-59de62317dbc5270eafd00503c9633af60eb590b.tar.xz
nixlib-59de62317dbc5270eafd00503c9633af60eb590b.tar.zst
nixlib-59de62317dbc5270eafd00503c9633af60eb590b.zip
btrfs: fix build to link against libgcc_s so that pthread_cancel is linked
Currently, the command btrfs scrub start <filesystem> attempts to invoke the pthread_cancel
routine and ends with an error melibgcc_sssage about it being missing. This prevents btrfs
scrub status from maintaining proper statistics about the running scrub.

Close #1127.
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/filesystems/btrfsprogs/default.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/pkgs/tools/filesystems/btrfsprogs/default.nix b/pkgs/tools/filesystems/btrfsprogs/default.nix
index 9c8d18231f0f..0661755d2e17 100644
--- a/pkgs/tools/filesystems/btrfsprogs/default.nix
+++ b/pkgs/tools/filesystems/btrfsprogs/default.nix
@@ -13,6 +13,9 @@ stdenv.mkDerivation {
 
   buildInputs = [ zlib libuuid acl attr e2fsprogs lzo ];
 
+  # for btrfs to get the rpath to libgcc_s, needed for pthread_cancel to work
+  NIX_CFLAGS_LINK = "-lgcc_s";
+
   postPatch = ''
     cp ${./btrfs-set-received-uuid.c} btrfs-set-received-uuid.c
   '';